libpcp3-4.3.1-2.1.i586.rpm


Advertisement

Description

libpcp3 - Performance Co-Pilot run-time libraries

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libpcp3-4.3.1-2.1.i586.rpm
Package name libpcp3
Package version 4.3.1
Package release 2.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage https://pcp.io
License LGPL-2.1+
Maintainer -
Download size 314.99 KB
Installed size 791.23 KB
Performance Co-Pilot (PCP) run-time libraries

Alternatives

Package Version Architecture Repository
libpcp3-4.3.1-2.1.x86_64.rpm 4.3.1 x86_64 openSUSE Oss
libpcp3 - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libavahi-client.so.3 -
libavahi-common.so.3 -
libc.so.6(GLIBC_2.28) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libm.so.6 -
libm.so.6(GLIBC_2.29) -
libnspr4.so -
libnss3.so -
libnss3.so(NSS_3.10) -
libnss3.so(NSS_3.2) -
libnss3.so(NSS_3.4) -
libnss3.so(NSS_3.5) -
libnss3.so(NSS_3.6) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libsasl2.so.3 -
libssl3.so -
libssl3.so(NSS_3.11.4) -
libssl3.so(NSS_3.12.6) -
libssl3.so(NSS_3.2) -
libssl3.so(NSS_3.7.4) -
pcp-conf >= 4.3.1-2.1

Provides

Name Value
libpcp.so.3 -
libpcp.so.3(PCP_3.0) -
libpcp.so.3(PCP_3.1) -
libpcp.so.3(PCP_3.10) -
libpcp.so.3(PCP_3.11) -
libpcp.so.3(PCP_3.12) -
libpcp.so.3(PCP_3.13) -
libpcp.so.3(PCP_3.14) -
libpcp.so.3(PCP_3.15) -
libpcp.so.3(PCP_3.16) -
libpcp.so.3(PCP_3.17) -
libpcp.so.3(PCP_3.18) -
libpcp.so.3(PCP_3.19) -
libpcp.so.3(PCP_3.2) -
libpcp.so.3(PCP_3.20) -
libpcp.so.3(PCP_3.21) -
libpcp.so.3(PCP_3.22) -
libpcp.so.3(PCP_3.23) -
libpcp.so.3(PCP_3.24) -
libpcp.so.3(PCP_3.25) -
libpcp.so.3(PCP_3.26) -
libpcp.so.3(PCP_3.3) -
libpcp.so.3(PCP_3.4) -
libpcp.so.3(PCP_3.5) -
libpcp.so.3(PCP_3.6) -
libpcp.so.3(PCP_3.7) -
libpcp.so.3(PCP_3.8) -
libpcp.so.3(PCP_3.9) -
libpcp3 = 4.3.1-2.1
libpcp3(x86-32) = 4.3.1-2.1
libpcp_pmda.so.3 -
libpcp_pmda.so.3(PCP_PMDA_3.0) -
libpcp_pmda.so.3(PCP_PMDA_3.1) -
libpcp_pmda.so.3(PCP_PMDA_3.10) -
libpcp_pmda.so.3(PCP_PMDA_3.2) -
libpcp_pmda.so.3(PCP_PMDA_3.3) -
libpcp_pmda.so.3(PCP_PMDA_3.4) -
libpcp_pmda.so.3(PCP_PMDA_3.5) -
libpcp_pmda.so.3(PCP_PMDA_3.6) -
libpcp_pmda.so.3(PCP_PMDA_3.7) -
libpcp_pmda.so.3(PCP_PMDA_3.8) -
libpcp_pmda.so.3(PCP_PMDA_3.9) -

Conflicts

Name Value
pcp-libs -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libpcp3-4.3.1-2.1.i586.rpm
Source Package pcp-4.3.1-2.1.src.rpm

Install Howto

Install libpcp3 rpm package:

# zypper install libpcp3

Files

Path
/usr/lib/libpcp.so.3
/usr/lib/libpcp_pmda.so.3

Changelog

2019-03-08 - David Disseldorp <ddiss@suse.com>
- Split out zeroconf, pmda-haproxy, pmda-smart, pmda-prometheus,
pcp2elasticsearch, pcp2json, pcp2spark, and pmlogger_daily_report files
into separate packages, matching upstream; (bsc#1128523).
- Fix incorrect dependencies for rewritten monitoring agents; (bsc#1128606).
- Ensure symlink sources and targets are in the same package; (bsc#1127978).
- Move pcp-dstat into the pcp-system-tools package; (bsc#1127978).
2019-03-07 - Bernhard Wiedemann <bwiedemann@suse.com>
- drop unreproducible perfevent_coverage program (boo#1040589)
- override build date to make package build reproducible (boo#1047218)
2019-02-28 - ddiss@suse.com
- Upgrade to 4.3.1; (bsc#1127437).
+ Add proper systemd timer service dependency tracking
+ pmrep: fix a dynamic header corner case with missing values
+ pmie: fix for segv and bad sum_inst() use
+ pmview: fix a missing timeout slot connection
- Drop upstreamed patches:
0004-create-pmlogger-and-pmie-logdirs-during-install.patch
0007-pmie-add-systemd-timers-as-cron-alternative.patch
0008-pmlogger_daily-add-systemd-timers-as-cron-alternativ.patch
0009-pmlogger_daily_report-add-systemd-timers-as-cron-alt.patch
0010-pmns-don-t-package-.NeedRebuild-for-SUSE-distros.patch
2019-02-19 - ddiss@suse.com
- Drop python2 support for Factory and SLES15-SP1; (bsc#1077777).
2019-02-06 - ddiss@suse.com
- export PACKAGE_DISTRIBUTION="suse" for build; (bsc#1123311).
2019-01-31 - ddiss@suse.com
- Drop distribution-release build dependency completely; (bsc#1123311).
+ modify 0010-pmns-don-t-package-.NeedRebuild-for-SUSE-distros.patch
2019-01-30 - ddiss@suse.com
- Replace openSUSE/sles-release build dependency; (bsc#1123311).
2019-01-18 - ddiss@suse.com
- Drop conflicting dstat symlink; (bsc#1122502).
2019-01-15 - ddiss@suse.com
- Package missing PMDA binaries; (bsc#1121920).
+ refresh 0001-Install-libraries-without-exec-permission.patch
- Don't package pmns .NeedRebuild flag; (bsc#1092160).
+ add 0010-pmns-don-t-package-.NeedRebuild-for-SUSE-distros.patch
2019-01-10 - ddiss@suse.com
- Upgrade to 4.3.0; (bsc#1121914).
- Refreshed patches
0001-Install-libraries-without-exec-permission.patch
0007-pmie-add-systemd-timers-as-cron-alternative.patch
0008-pmlogger_daily-add-systemd-timers-as-cron-alternativ.patch
0009-pmlogger_daily_report-add-systemd-timers-as-cron-alt.patch

See Also

Package Description
libpcp_gui2-4.3.1-2.1.i586.rpm Performance Co-Pilot run-time GUI library
libpcp_gui2-4.3.1-2.1.x86_64.rpm Performance Co-Pilot run-time GUI library
libpcp_import1-4.3.1-2.1.i586.rpm Performance Co-Pilot run-time import library
libpcp_import1-4.3.1-2.1.x86_64.rpm Performance Co-Pilot run-time import library
libpcp_mmv1-4.3.1-2.1.i586.rpm Performance Co-Pilot run-time MMV library
libpcp_mmv1-4.3.1-2.1.x86_64.rpm Performance Co-Pilot run-time MMV library
libpcp_trace2-4.3.1-2.1.i586.rpm Performance Co-Pilot run-time tracing library
libpcp_trace2-4.3.1-2.1.x86_64.rpm Performance Co-Pilot run-time tracing library
libpcp_web1-4.3.1-2.1.i586.rpm Performance Co-Pilot run-time web library
libpcp_web1-4.3.1-2.1.x86_64.rpm Performance Co-Pilot run-time web library
libpcre1-32bit-8.42-2.5.x86_64.rpm A library for Perl-compatible regular expressions
libpcre1-8.42-2.5.i586.rpm A library for Perl-compatible regular expressions
libpcre1-8.42-2.5.x86_64.rpm A library for Perl-compatible regular expressions
libpcre16-0-32bit-8.42-2.5.x86_64.rpm A library for Perl-compatible regular expressions
libpcre16-0-8.42-2.5.i586.rpm A library for Perl-compatible regular expressions
Advertisement
Advertisement