libp8-platform2-2.1.0.1-2.3.i586.rpm


Advertisement

Description

libp8-platform2 - Platform support library used by libCEC and binary add-ons for Kodi

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libp8-platform2-2.1.0.1-2.3.i586.rpm
Package name libp8-platform2
Package version 2.1.0.1
Package release 2.3
Package architecture i586
Package type rpm
Category Hardware/TV
Homepage https://github.com/Pulse-Eight/platform
License GPL-2.0-or-later
Maintainer -
Download size 27.04 KB
Installed size 50.12 KB
Platform support library used by libCEC and binary add-ons for Kodi.

Alternatives

Package Version Architecture Repository
libp8-platform2-2.1.0.1-10.12.x86_64.rpm 2.1.0.1 x86_64 Hardware
libp8-platform2-2.1.0.1-10.12.i586.rpm 2.1.0.1 i586 Hardware
libp8-platform2-2.1.0.1-2.3.x86_64.rpm 2.1.0.1 x86_64 openSUSE Oss
libp8-platform2 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -

Provides

Name Value
libp8-platform.so.2 -
libp8-platform2 = 2.1.0.1-2.3
libp8-platform2(x86-32) = 2.1.0.1-2.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libp8-platform2-2.1.0.1-2.3.i586.rpm
Source Package p8-platform-2.1.0.1-2.3.src.rpm

Install Howto

Install libp8-platform2 rpm package:

# zypper install libp8-platform2

Files

Path
/usr/lib/libp8-platform.so.2
/usr/lib/libp8-platform.so.2.1.0
/usr/share/doc/packages/libp8-platform2/README.md
/usr/share/licenses/libp8-platform2/copyright

Changelog

2018-03-08 - mpluskal@suse.com
- Update spec file with spec-cleaner
- Install license
2017-01-29 - mpluskal@suse.com
- Update to version 2.1.0.1
* No upstream changelog provided
- Drop no longer needed p8-platform-install_noarch.patch
2016-01-25 - olaf@aepfle.de
- p8-platform-devel does not obsolete libplatform-devel because
there are no file or provides conflicts
2016-01-23 - mpluskal@suse.com
- Rename package
- Rename patch install_noarch.patch to
p8-platform-install_noarch.patch
2016-01-22 - sagiben@gmail.com
- install_noarch.patch patch was added :
* Fix path to libdir in .pc file instead of using sed
* Fix .pc and .cmake files install location
- p8-platform 2.0.1
* Avoid that cmake removes variables from pkg-config file
- p8-platform 2.0.0-1
* renamed to p8-platform
- platform 2.0.0-1
* removed: fstrcmp and StringUtils::CompareFuzzy() +
StringUtils::FindBestMatch() because of an incompatible license
- platform 1.0.10-1
* fixed: posix socket return value for connect
2016-01-02 - mpluskal@suse.com
- Fix path to libdir in .pc file (boo#960475)
2015-07-18 - mpluskal@suse.com
- Update to 1.0.10
* fixed: posix socket return value for connect.
2015-06-09 - mpluskal@suse.com
- Fix previous changelog entry
- Use url for source
- Use cmake macro
2015-05-14 - sagiben@gmail.com
- platform 1.0.9-1
* fixed: add missing stdio.h include in windows/os-socket.h
- platform 1.0.8-1
* added: cdevsocket.h character device socket
* fixed: guards for #defines on OS X and iOS for values already
defined in
CFPlugInCOM.h
- platform 1.0.7-1~trusty
* fixed: include on OS X
- platform 1.0.6-1
* fixed: add include path and link the threads lib
* (re-)added: public Reset() function in CEvent
* sync UseMultiArch.cmake
- platform 1.0.5-1
* fixed: missing #include <string> in socket.h
- platform 1.0.4-1
* proper platform.pc.in fix
- platform 1.0.3-1
* platform.pc.in fix
- platform 1.0.2-1
* Build fixes
- platform 1.0.0-1
* Initial release

See Also

Package Description
libpacemaker-devel-2.0.1+20190408.1b68da8e8-1.1.i586.rpm Pacemaker development package
libpacemaker-devel-2.0.1+20190408.1b68da8e8-1.1.x86_64.rpm Pacemaker development package
libpacemaker3-2.0.1+20190408.1b68da8e8-1.1.i586.rpm Core Pacemaker libraries
libpacemaker3-2.0.1+20190408.1b68da8e8-1.1.x86_64.rpm Core Pacemaker libraries
libpackagekit-glib2-18-1.1.12-7.1.i586.rpm GLib integration of PackageKit
libpackagekit-glib2-18-1.1.12-7.1.x86_64.rpm GLib integration of PackageKit
libpackagekit-glib2-18-32bit-1.1.12-7.1.x86_64.rpm GLib integration of PackageKit
libpackagekit-glib2-devel-1.1.12-7.1.i586.rpm GLib integration of PackageKit
libpackagekit-glib2-devel-1.1.12-7.1.x86_64.rpm GLib integration of PackageKit
libpackagekit-glib2-devel-32bit-1.1.12-7.1.x86_64.rpm GLib integration of PackageKit
libpackagekitqt5-1-1.0.1-2.1.i586.rpm Simple software installation management software
libpackagekitqt5-1-1.0.1-2.1.x86_64.rpm Simple software installation management software
libpagemaker-0_0-0-0.0.4-1.5.i586.rpm A library to import Adobe PageMaker documents
libpagemaker-0_0-0-0.0.4-1.5.x86_64.rpm A library to import Adobe PageMaker documents
libpagemaker-devel-0.0.4-1.5.i586.rpm Files for Developing with libpagemaker
Advertisement
Advertisement