libopenEMS0-0.0.35-5.6.x86_64.rpm


Advertisement

Description

libopenEMS0 - Electromagnetic field solver library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libopenEMS0-0.0.35-5.6.x86_64.rpm
Package name libopenEMS0
Package version 0.0.35
Package release 5.6
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://openems.de
License GPL-3.0-only
Maintainer -
Download size 283.71 KB
Installed size 944.07 KB
Electromagnetic field solver using the EC-FDTD method library.

Alternatives

Package Version Architecture Repository
libopenEMS0-0.0.35-30.11.x86_64.rpm 0.0.35 x86_64 Science
libopenEMS0-0.0.35-30.11.i586.rpm 0.0.35 i586 Science
libopenEMS0-0.0.35-5.6.i586.rpm 0.0.35 i586 openSUSE Oss
libopenEMS0 - - -

Requires

Name Value
/sbin/ldconfig -
libCSXCAD.so.0()(64bit) -
libboost_thread.so.1.69.0()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libfparser-4.5.2.so()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_4.0.0)(64bit) -
libhdf5.so.103()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libpthread.so.0(GLIBC_2.3.3)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libtinyxml.so.0()(64bit) -
libvtkCommonCore.so.1()(64bit) -
libvtkCommonDataModel.so.1()(64bit) -
libvtkIOCore.so.1()(64bit) -
libvtkIOLegacy.so.1()(64bit) -
libvtkIOXML.so.1()(64bit) -

Provides

Name Value
libopenEMS.so.0()(64bit) -
libopenEMS0 = 0.0.35-5.6
libopenEMS0(x86-64) = 0.0.35-5.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libopenEMS0-0.0.35-5.6.x86_64.rpm
Source Package openEMS-0.0.35-5.6.src.rpm

Install Howto

Install libopenEMS0 rpm package:

# zypper install libopenEMS0

Files

Path
/usr/lib64/libopenEMS.so.0
/usr/lib64/libopenEMS.so.0.0.35

Changelog

2018-12-15 - Stefan BrĂ¼ns <stefan.bruens@rwth-aachen.de>
- Update 0001-Fix-linking-for-VTK-6.3.patch, avoid pulling in dependencies
of unused VTK modules during build.
- Drop MPI environment setup, VTK no longer depends on MPI.
- Do not force AVX for x86, SSE is sufficient for XMM intrinsics
- specfile cleanup
2018-06-25 - stefan.bruens@rwth-aachen.de
- Use mpic++ as C++ compiler, otherwise we end up with missing MPI
symbols when linking
- Always use Qt5, as all current VTK builds use Qt5 as well
2018-03-27 - stefan.bruens@rwth-aachen.de
- Fix build on e.g. ARM, use x86 intrinsics only on x86
add 0001-Guard-xmmintrin.h-include-so-it-is-only-used-when-ne.patch
2018-03-27 - stefan.bruens@rwth-aachen.de
- Change the Qt BuildRequires: for older distributions, Leap 42.x
has a VTK build with Qt4, use the same conditional as the VTK
package (i.e. Qt4 on Leap 42.x, Qt5 on TW and Leap 15.x)
- Fix build when using -std=gnu++11 and glibc <= 2.25
add 0001-Fix-build-error-due-to-ambigous-overload-of-isnan-is.patch
2018-01-17 - adam.majer@suse.de
- Fix boost build dependencies (boo#1062789)
2017-12-27 - kkaempf@suse.com
- Update to 0.0.35
* build fixes
* critical bug fix in waveguide ports
* fix for boxes defined in different coordinate systems
* other smaller fixes
- patch rename and cleanop, now based on git format-patch
* openEMS-vtk.patch to 0001-Fix-linking-for-VTK-6.3.patch
* openEMS-octave-openEMS-load.patch to 0002-Fix-openEMS.sh-load.patch
* openEMS-octave-nf2ff-load.patch to 0003-Fix-nf2ff-load.patch
* openEMS-readme-octave-package.patch to 0004-Add-correct-instruction-about-Octave-and-MATLAB-pack.patch
* openEMS-hdf5.patch to 0005-Fix-build-with-HDF5.patch
* openEMS-no-return.patch to 0006-Add-missing-return-statement.patch
2017-10-26 - badshah400@gmail.com
- Source mpi variables before building to prevent build failures
on openSUSE > 1320.
- Add BuildRequires: sz2-devel, needed for building for openSUSE
>= 1320.
2017-09-13 - stefan.bruens@rwth-aachen.de
- Add explicit BuildRequires for vtk-java, vtk-tcl and python3-vtk,
and Qt5Sql/Qt5Widgets devel packages, as these are no longer
implicitly required by vtk-devel
2017-01-01 - jengelh@inai.de
- Correct RPM group selection
2016-08-26 - dmitry_r@opensuse.org
- Update to version 0.0.34
* Bugfix release
* Update openEMS-vtk.patch
- Drop obsolete
* openEMS-vtk7-support.patch
- Fix build with HDF5
* openEMS-hdf5.patch
- Fix GCC no-return-in-nonvoid-function
* openEMS-no-return.patch

See Also

Package Description
libopenal0-1.19.1-1.1.i586.rpm Audio library with an OpenGL-resembling API
libopenal0-1.19.1-1.1.x86_64.rpm Audio library with an OpenGL-resembling API
libopenal0-32bit-1.19.1-1.1.x86_64.rpm Audio library with an OpenGL-resembling API
libopenal1-1.19.1-1.1.i586.rpm Audio library with an OpenGL-resembling API
libopenal1-1.19.1-1.1.x86_64.rpm Audio library with an OpenGL-resembling API
libopenal1-32bit-1.19.1-1.1.x86_64.rpm Audio library with an OpenGL-resembling API
libopenbabel5-2.4.1-4.5.i586.rpm Component library of Open Babel, a chemistry toolbox
libopenbabel5-2.4.1-4.5.x86_64.rpm Component library of Open Babel, a chemistry toolbox
libopenbabel5-32bit-2.4.1-4.5.x86_64.rpm Component library of Open Babel, a chemistry toolbox
libopenblas-gnu-hpc-0.3.5-3.1.i586.rpm Dependency package for libopenblas_0_3_5-gnu-hpc
libopenblas-gnu-hpc-0.3.5-3.1.x86_64.rpm Dependency package for libopenblas_0_3_5-gnu-hpc
libopenblas-gnu-hpc-devel-0.3.5-3.1.i586.rpm Dependency package for libopenblas_0_3_5-gnu-hpc-devel
libopenblas-gnu-hpc-devel-0.3.5-3.1.x86_64.rpm Dependency package for libopenblas_0_3_5-gnu-hpc-devel
libopenblas-pthreads-gnu-hpc-0.3.5-3.1.i586.rpm Dependency package for libopenblas-pthreads_0_3_5-gnu-hpc
libopenblas-pthreads-gnu-hpc-0.3.5-3.1.x86_64.rpm Dependency package for libopenblas-pthreads_0_3_5-gnu-hpc
Advertisement
Advertisement