libnetapi-devel-4.10.2+git.78.0c89af72312-1.1.i586.rpm


Advertisement

Description

libnetapi-devel - Libraries and Header Files to Develop Programs with netapi Support

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libnetapi-devel-4.10.2+git.78.0c89af72312-1.1.i586.rpm
Package name libnetapi-devel
Package version 4.10.2+git.78.0c89af72312
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage https://www.samba.org/
License GPL-3.0-or-later
Maintainer -
Download size 104.40 KB
Installed size 76.45 KB
This package contains the static libraries and header files needed to
develop programs which make use of the netapi programming interface.

Alternatives

Package Version Architecture Repository
libnetapi-devel-4.10.2+git.78.0c89af72312-1.1.x86_64.rpm 4.10.2+git.78.0c89af72312 x86_64 openSUSE Oss
libnetapi-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libnetapi0 = 4.10.2+git.78.0c89af72312

Provides

Name Value
libnetapi-devel = 4.10.2+git.78.0c89af72312-1.1
libnetapi-devel(x86-32) = 4.10.2+git.78.0c89af72312-1.1
pkgconfig(netapi) = 0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libnetapi-devel-4.10.2+git.78.0c89af72312-1.1.i586.rpm
Source Package samba-4.10.2+git.78.0c89af72312-1.1.src.rpm

Install Howto

Install libnetapi-devel rpm package:

# zypper install libnetapi-devel

Files

Path
/usr/include/samba-4.0/netapi.h
/usr/lib/libnetapi.so
/usr/lib/pkgconfig/netapi.pc

Changelog

2019-04-17 - npower <nopower@suse.com>
- Update to samba-4.10.2:
+ CVE-2019-3870 (World writable files in
Samba AD DC private/ dir); (bso#13834).
+ CVE-2019-3880 (Save registry file outside share as
unprivileged user); (bso#13851).
+ py/kcc_utils: py2.6 compatibility; (bso#13837).
+ libcli: permit larger values of DataLength in
SMB2_ENCRYPTION_CAPABILITIES of negotiate response;
(bso#13869).
+ regfio: Improve handling of malformed registry hive files;
(bso#13840).
+ ctdb-version: Simplify version string usage; (bso#13789).
+ lib: Make fd_load work for non-regular files; (bso#13859).
+ dbcheck: in the middle of the tombstone garbage collection
causes replication failures,
dbcheck: add --selftest-check-expired-tombstones cmdline
option; (bso#13816).
+ ndr_spoolss_buf: Fix out of scope use of stack variable in
NDR_SPOOLSS_PUSH_ENUM_OUT(); (bso#13818).
+ s4/messaging: Fix undefined reference in linking
libMESSAGING-samba4.so; (bso#13854).
+ acl_read: Fix regression for empty lists; (bso#13836).
+ s4:dlz make b9_has_soa check dc=@ node; (bso#13841).
+ s3:client: Fix printing via smbspool backend with kerberos
auth; (bso#13832).
+ s4:librpc: Fix installation of Samba; (bso#13847).
+ s3:lib: Fix the debug message for adding cache entries;
(bso#13848).
+ s3:utils: Add 'smbstatus -L --resolve-uids' to show username;
(bso#13793).
+ s3:lib: Fix the debug message for adding cache entries;
(bso#13848).
+ s3:waf: Fix the detection of makdev() macro on Linux;
(bso#13853).
* ctdb-build: Drop creation of .distversion in tarball;
(bso#13789).
* ctdb-packaging: Test package requires tcpdump, ctdb package
should not own system library directory;  (bso#13838).
- Update to samba-4.10.1:
+ py/kcc_utils: py2.6 compatibility; (bso#13837);
+ libcli: permit larger values of DataLength in
SMB2_ENCRYPTION_CAPABILITIES of negotiate response; (bso#13869);
+ regfio: Improve handling of malformed registry hive files; (bso#13840);
+ ctdb-version: Simplify version string usage; (bso#13789);
+ lib: Make fd_load work for non-regular files; (bso#13859);
+ dbcheck in the middle of the tombstone garbage collection causes
replication failures, dbcheck: add --selftest-check-expired-tombstones
cmdline option; (bso#13816);
+ ndr_spoolss_buf: Fix out of scope use of stack variable in
NDR_SPOOLSS_PUSH_ENUM_OUT(); (bso#13818);
+ s4/messaging: Fix undefined reference in linking
libMESSAGING-samba4.so; (bso#13854);
+ acl_read: Fix regression for empty lists; (bso#13836);
+ s4:dlz make b9_has_soa check dc=@ node; (bso#13841);
+ s3:client: Fix printing via smbspool backend with kerberos auth; (bso#13832);
+ s4:librpc: Fix installation of Samba; (bso#13847);
+ s3:lib: Fix the debug message for adding cache entries; (bso#13848);
+ s3:utils: Add 'smbstatus -L --resolve-uids' to show username; (bso#13793);
+ s3:lib: Fix the debug message for adding cache entries; (bso#13848);
+ s3:waf: Fix the detection of makdev() macro on Linux; (bso#13853);
+ ctdb-build: Drop creation of .distversion in tarball; (bso#13789);
+ ctdb-packaging: Test package requires tcpdump, ctdb package
should not own system library directory; (bso#13838);
- Update to samba-4.10.0:
+ s4-server: Open and close a transaction on sam.ldb at startup; (bso#13760);
+ access_check_max_allowed() doesn't process "Owner Rights" ACEs; (bso#13812);
+ s4/scripting/bin: Open unicode files with utf8 encoding and write
+ unicode string.
+ sambaundoguididx: Use the right escaped oder unescaped sam ldb
files; (bso#13759);
+ Fix idmap cache pollution with S-1-22- IDs on winbind hickup; (bso#13813);
+ passdb: Update ABI to 0.27.2.
+ lib/winbind_util: Add winbind_xid_to_sid for --without-winbind; (bso#13813);
+ lib:util: Move debug message for mkdir failing to log level 1; (bso#13823);

See Also

Package Description
libnetapi0-32bit-4.10.2+git.78.0c89af72312-1.1.x86_64.rpm Samba netapi Library
libnetapi0-4.10.2+git.78.0c89af72312-1.1.i586.rpm Samba netapi Library
libnetapi0-4.10.2+git.78.0c89af72312-1.1.x86_64.rpm Samba netapi Library
libnetcdf-cxx4-gnu-hpc-4.3.0-11.4.i586.rpm Dependency package for libnetcdf-cxx4_4_3_0-gnu-hpc
libnetcdf-cxx4-gnu-hpc-4.3.0-11.4.x86_64.rpm Dependency package for libnetcdf-cxx4_4_3_0-gnu-hpc
libnetcdf-cxx4-gnu-hpc-devel-4.3.0-11.4.i586.rpm Dependency package for libnetcdf-cxx4_4_3_0-gnu-hpc-devel
libnetcdf-cxx4-gnu-hpc-devel-4.3.0-11.4.x86_64.rpm Dependency package for libnetcdf-cxx4_4_3_0-gnu-hpc-devel
libnetcdf-cxx4_4_3_0-gnu-hpc-4.3.0-11.4.i586.rpm C++ library for the Unidata network Common Data Form version 4
libnetcdf-cxx4_4_3_0-gnu-hpc-4.3.0-11.4.x86_64.rpm C++ library for the Unidata network Common Data Form version 4
libnetcdf-cxx4_4_3_0-gnu-hpc-devel-4.3.0-11.4.i586.rpm Development files for netcdf_c++
libnetcdf-cxx4_4_3_0-gnu-hpc-devel-4.3.0-11.4.x86_64.rpm Development files for netcdf_c++
libnetcdf-cxx4_4_3_0-gnu-hpc-devel-static-4.3.0-11.4.i586.rpm Static development files for netcdf_c++
libnetcdf-cxx4_4_3_0-gnu-hpc-devel-static-4.3.0-11.4.x86_64.rpm Static development files for netcdf_c++
libnetcdf-fortran-gnu-mpich-hpc-4.4.4-7.4.i586.rpm Dependency package for libnetcdf-fortran_4_4_4-gnu-mpich-hpc
libnetcdf-fortran-gnu-mpich-hpc-4.4.4-7.4.x86_64.rpm Dependency package for libnetcdf-fortran_4_4_4-gnu-mpich-hpc
Advertisement
Advertisement