libmspub-tools-0.1.4-1.10.x86_64.rpm


Advertisement

Description

libmspub-tools - Tools to work with publications in Microsoft Publisher file-format

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libmspub-tools-0.1.4-1.10.x86_64.rpm
Package name libmspub-tools
Package version 0.1.4
Package release 1.10
Package architecture x86_64
Package type rpm
Category Productivity/Publishing/Word
Homepage https://wiki.documentfoundation.org/DLP/Libraries/libmspub
License MPL-2.0
Maintainer -
Download size 15.38 KB
Installed size 32.74 KB
Command line tools to work with publications in Microsoft Publisher file-format.

Alternatives

Package Version Architecture Repository
libmspub-tools-0.1.4-1.10.i586.rpm 0.1.4 i586 openSUSE Oss
libmspub-tools - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libmspub-0.1.so.1()(64bit) -
librevenge-0.0.so.0()(64bit) -
librevenge-generators-0.0.so.0()(64bit) -
librevenge-stream-0.0.so.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Provides

Name Value
libmspub-tools = 0.1.4-1.10
libmspub-tools(x86-64) = 0.1.4-1.10

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libmspub-tools-0.1.4-1.10.x86_64.rpm
Source Package libmspub-0.1.4-1.10.src.rpm

Install Howto

Install libmspub-tools rpm package:

# zypper install libmspub-tools

Files

Path
/usr/bin/pub2raw
/usr/bin/pub2xhtml

Changelog

2018-03-07 - tchvatal@suse.com
- Version update to 0.1.4:
* Fix several problems found by oss-fuzz
* Fix regression in closing shape groups that caused missing shapes
on second and subsequent pages. (tdf#116018)
2018-01-01 - tchvatal@suse.com
- Version update to 0.1.3:
* Workaround a build error on some 32-bit systems.
* Parse table row and column sizes. (tdf#89061)
* Fix various problems when parsing broken files, found with the help of
american-fuzzy-lop and oss-fuzz.
* Make the output of pub2foo --help more compatible with help2man.
* Extract more metadata from documents.
* Require C++11 for build.
* Drop outdated MSVC project files.
* Handle table cells containing multiple paragraphs correctly. (tdf#89393)
* Parse more text formatting attributes: all underline types, small
caps, all caps, outline, emboss, engrave, shadow.
* Parse text language.
* Various minor changes and improvements.
2017-02-01 - adam.majer@suse.de
- use individual libboost-*-devel packages instead of boost-devel
2016-08-01 - tchvatal@suse.com
- Disable sle11 support code
2014-12-30 - tchvatal@suse.com
- Version bump to 0.1.2:
- Check arguments of public functions. Passing NULL no longer causes
a crash.
- Use symbol visibility on Linux. The library only exports the two public
functions now.
- Fix several crashes and hangs when reading broken files, found with the help
of american-fuzzy-lop.
- Add support for embedded fonts.
- Add initial support for tables.
- Parse document metadata.
- Remove libmspub-0.1.1-pkgconfig.patch
2014-07-25 - fstrba@suse.com
- Added patch: libmspub-0.1.1-pkgconfig.patch
* Remove the Requires.private which breaks SLE11 builds
2014-07-08 - tchvatal@suse.com
- Version bump to 0.1.1:
* Various small bugfixes
2014-05-26 - fstrba@suse.com
- Upgrade to upstream version 0.1.0
* ABI changes
* Remove dependency on libwpd-devel and libwpg-devel
* Add dependency on librevenge-devel
- License change
* Released under MPL-2.0
2014-01-25 - tchvatal@suse.com
- Cleanup with spec-cleaner and noarch documenation.
2014-01-18 - crrodriguez@opensuse.org
- build with -fvisibility-inlines-hidden

See Also

Package Description
libmtdev1-1.1.5-1.16.i586.rpm Multitouch Protocol Translation Library
libmtdev1-1.1.5-1.16.x86_64.rpm Multitouch Protocol Translation Library
libmtdev1-32bit-1.1.5-1.16.x86_64.rpm Multitouch Protocol Translation Library
libmtp-devel-1.1.16-2.2.i586.rpm Development files for access to MTP Player library
libmtp-devel-1.1.16-2.2.x86_64.rpm Development files for access to MTP Player library
libmtp-udev-1.1.16-2.2.i586.rpm Udev rules for accessing MTP devices
libmtp-udev-1.1.16-2.2.x86_64.rpm Udev rules for accessing MTP devices
libmtp9-1.1.16-2.2.i586.rpm Library for accessing MTP Players
libmtp9-1.1.16-2.2.x86_64.rpm Library for accessing MTP Players
libmuffin0-3.8.2-1.3.i586.rpm Muffin shared libraries
libmuffin0-3.8.2-1.3.x86_64.rpm Muffin shared libraries
libmumps-gnu-mpich-hpc-5.1.2-3.1.x86_64.rpm Dependency package for libmumps_5_1_2-gnu-mpich-hpc
libmumps-gnu-mvapich2-hpc-5.1.2-3.1.x86_64.rpm Dependency package for libmumps_5_1_2-gnu-mvapich2-hpc
libmumps-gnu-openmpi1-hpc-5.1.2-3.1.x86_64.rpm Dependency package for libmumps_5_1_2-gnu-openmpi1-hpc
libmumps-gnu-openmpi2-hpc-5.1.2-3.1.x86_64.rpm Dependency package for libmumps_5_1_2-gnu-openmpi2-hpc
Advertisement
Advertisement