libmeep13-1.8.0-1.1.i586.rpm


Advertisement

Description

libmeep13 - FDTD finite-difference time-domain solver library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libmeep13-1.8.0-1.1.i586.rpm
Package name libmeep13
Package version 1.8.0
Package release 1.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://ab-initio.mit.edu/wiki/index.php/Meep
License GPL-2.0-or-later
Maintainer -
Download size 309.01 KB
Installed size 955.75 KB
Meep (or MEEP) is a free finite-difference time-domain (FDTD)
simulation software package developed at MIT to model electromagnetic
systems.

Alternatives

Package Version Architecture Repository
libmeep13-1.8.0-32.1.x86_64.rpm 1.8.0 x86_64 Science
libmeep13-1.8.0-32.1.i586.rpm 1.8.0 i586 Science
libmeep13-1.8.0-1.1.x86_64.rpm 1.8.0 x86_64 openSUSE Oss
libmeep13 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libfftw3.so.3 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_4.0.0) -
libgcc_s.so.1(GLIBC_2.0) -
libgsl.so.23 -
libgslcblas.so.0 -
libharminv.so.3 -
libhdf5 -
libhdf5.so.103 -
liblapack.so.3 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libm.so.6(GLIBC_2.29) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.21) -

Provides

Name Value
libmeep.so.13 -
libmeep13 = 1.8.0-1.1
libmeep13(x86-32) = 1.8.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libmeep13-1.8.0-1.1.i586.rpm
Source Package meep-1.8.0-1.1.src.rpm

Install Howto

Install libmeep13 rpm package:

# zypper install libmeep13

Files

Path
/usr/lib/libmeep.so.13
/usr/lib/libmeep.so.13.0.0

Changelog

2019-02-19 - jbrielmaier@suse.de
- Update to version 1.8.0:
* Add `--without-scheme` flag to `./configure` (#705)
* Improve error messages in Python interface (#699)
* Allow `kguess` to specify MPB lattice vector for launching
oblique waveguide modes (#675)
* Allow user materials when checking for conductivity (#689)
* Add `split_chunks_evenly` flag to `Simulation` constructor.
Setting to `False` will improve parallel simulation performance
by dividing chunks based on work instead of size (#681)
* Added `Simulation.visualize_chunks()` to visualize the chunk
layout (#671)
* Improved stability of lorentzian susceptibility (#666)
* Get array metadata for `get_array` and `get_dft_array` (#655)
* Add ability to get a source slice as a numpy array (#652)
* Fixed performance issues in ModeSolver.find_k (#644)
* Add `force_all_components` flag to `Simulation` constructor
* Expose `run_k_point` to access more Harminv data (#626)
* Various other bug fixes, documentation improvements, etc.
- drop patch:
namespace-for-complex-literals.patch: included in release
- require libctl >= 4.2
- remove libmeepgeom package as it was merged into libmeep
- increase somajor to 13
- don't build with C++14 support anymore, as meep now works fine
with C++11 again
2018-11-22 - Jonathan Brielmaier <jbrielmaier@suse.de>
- Update to version 1.7.0:
* See /usr/share/meep/NEWS.md
- update so version to 12
- add patch:
* namespace-for-complex-literals.patch: fixes build failure
- drop patch:
* meep_change_protos_with_harminv_complex.patch
- add libmeepgeom library
- correct doc file names
- use c++14 for complex_literals
2017-01-20 - wagner-thomas@gmx.at
- added two requirements to make meep start
2015-08-31 - toddrme2178@gmail.com
- Avoid unresolvable errors from multiple providers of libhdf5
2015-02-25 - normand@linux.vnet.ibm.com
- new patch meep_change_protos_with_harminv_complex.patch
required for ppc64 architecture to avoid make check error
while building meep package.
2015-01-25 - dmitry_r@opensuse.org
- Update to version 1.2.1
* See included NEWS file for details
- Move library to separate package according to SLPP
- Enable post-build testing
2012-08-21 - scorot@free.fr
- Buildrequires libguile1 on recent product
2012-05-11 - scorot@free.fr
- remove conditional BuildRequires for blas and lapack since
recent lapack now build correctly for all suse version
2012-04-14 - badshah400@gmail.com
- Update BuildRequires in keeping with lapack package naming
changes
- Spec file cleanups
- Modify License tag in confomity with spdx.org specifications.

See Also

Package Description
libmemcache-devel-1.4.0.rc2-152.14.i586.rpm Development files for libmemcache
libmemcache-devel-1.4.0.rc2-152.14.x86_64.rpm Development files for libmemcache
libmemcache0-1.4.0.rc2-152.14.i586.rpm A client library for memcached
libmemcache0-1.4.0.rc2-152.14.x86_64.rpm A client library for memcached
libmemcached-1.0.18-7.6.i586.rpm A C/C++ client library and tools for the memcached server
libmemcached-1.0.18-7.6.x86_64.rpm A C/C++ client library and tools for the memcached server
libmemcached-devel-1.0.18-7.6.i586.rpm Libmemcached is a C/C++ client library and tools for the memcached server
libmemcached-devel-1.0.18-7.6.x86_64.rpm Libmemcached is a C/C++ client library and tools for the memcached server
libmemcached11-1.0.18-7.6.i586.rpm Libmemcached is a C/C++ client library and tools for the memcached server
libmemcached11-1.0.18-7.6.x86_64.rpm Libmemcached is a C/C++ client library and tools for the memcached server
libmemcachedutil2-1.0.18-7.6.i586.rpm Libmemcached is a C/C++ client library and tools for the memcached server
libmemcachedutil2-1.0.18-7.6.x86_64.rpm Libmemcached is a C/C++ client library and tools for the memcached server
libmemkind0-1.6.0-1.3.x86_64.rpm User Extensible Heap Manager shared library
libmemphis-0_2-0-0.2.3-23.3.i586.rpm Map rendering library for OpenStreetMap
libmemphis-0_2-0-0.2.3-23.3.x86_64.rpm Map rendering library for OpenStreetMap
Advertisement
Advertisement