libgraphviz6-2.40.1+git20190410.b0871968d-1.1.i586.rpm


Advertisement

Description

libgraphviz6 - Library for the manipulation of layout of graphs

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libgraphviz6-2.40.1+git20190410.b0871968d-1.1.i586.rpm
Package name libgraphviz6
Package version 2.40.1+git20190410.b0871968d
Package release 1.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.graphviz.org/
License EPL-1.0
Maintainer -
Download size 623.88 KB
Installed size 3.64 MB
Library for the manipulation of layout of graphs (as in nodes and edges,
not as in bar charts).

Alternatives

Package Version Architecture Repository
libgraphviz6-2.40.1+git20190410.b0871968d-1.1.x86_64.rpm 2.40.1+git20190410.b0871968d x86_64 openSUSE Oss
libgraphviz6 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.28) -
libexpat.so.1 -
libltdl.so.7 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.15) -
libz.so.1 -

Provides

Name Value
config(libgraphviz6) = 2.40.1+git20190410.b0871968d-1.1
libcdt.so.5 -
libcgraph.so.6 -
libgraphviz6 = 2.40.1+git20190410.b0871968d-1.1
libgraphviz6(x86-32) = 2.40.1+git20190410.b0871968d-1.1
libgvc.so.6 -
libgvpr.so.2 -
liblab_gamut.so.1 -
libpathplan.so.4 -
libxdot.so.4 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgraphviz6-2.40.1+git20190410.b0871968d-1.1.i586.rpm
Source Package graphviz-2.40.1+git20190410.b0871968d-1.1.src.rpm

Install Howto

Install libgraphviz6 rpm package:

# zypper install libgraphviz6

Files

Path
/etc/ld.so.conf.d/graphviz.conf
/usr/lib/libcdt.so.5
/usr/lib/libcdt.so.5.0.0
/usr/lib/libcgraph.so.6
/usr/lib/libcgraph.so.6.0.0
/usr/lib/libgvc.so.6
/usr/lib/libgvc.so.6.0.0
/usr/lib/libgvpr.so.2
/usr/lib/libgvpr.so.2.0.0
/usr/lib/liblab_gamut.so.1
/usr/lib/liblab_gamut.so.1.0.0
/usr/lib/libpathplan.so.4
/usr/lib/libpathplan.so.4.0.0
/usr/lib/libxdot.so.4
/usr/lib/libxdot.so.4.0.0

Changelog

2019-04-16 - Christian Vögl <christian.voegl@suse.com>
- Disabled Visio plugin
2019-04-15 - Atri Bhattacharya <badshah400@gmail.com>
- Use %%python3_sitearch macro to package python3 modules.
- use correct ruby version (2.5) for openSUSE 15.1 and earlier.
2019-04-02 - Christian Vögl <christian.voegl@suse.com>
- Now using master branch of upstream, as there have been no releases for
over two years
* this should fix CVE-2019-11023 (boo#1132091)
- Removed  graphviz-qt5.patch (now in upstream)
- Removed reproducible.patch (now in upstream)
- graphviz-smyrna-link_against_glu.patch changed to be applicable to current files
- graphviz-no_strict_aliasing.patch changed to be applicable to current files
- Added graphviz-fix-ruby-version.patch to remove hardcoded dependency on ruby 1.9
- graphviz.spec updated for new version
- created _service file
2018-11-30 - jbrielmaier@suse.de
- use pkg-config with correct parameter, reported by Werner Fink
2018-11-29 - jbrielmaier@suse.de
- Support dynamic move to Guile 2.2, part of boo#1117121:
- Replace conditional pkgconfig(guile-2.[02]) BuildRequires with
guile-devel: The package name is unchanged, which allows the
distro projects to move wihout step-locking changes.
- Patch configure.ac to look for guile-2.2 if guile 2.2 is being
used.
- order inputs alphabetically
2018-11-16 - trenn@suse.de
- Fixed double file declaration in graphviz and graphviz-addons (x11)
- Mark license files with %license instead of %doc
2018-10-25 - trenn@suse.de
- Build with gts support (bsc#1108978, bsc#1108976)
SLE12 flavors do not provide gts, so explicitly exclude
gts support there.
2018-07-30 - bwiedemann@suse.com
- Extend reproducible.patch to make build reproducible (boo#1041534)
2018-03-27 - stefan.bruens@rwth-aachen.de
- Build with PHP5 for Leap 42.x and earlier, PHP7 requires swig 3.0.11
Drop graphviz-plugins-fix_install_dirs.patch, use sed script to
fix directories, same as for Lua
2018-03-27 - stefan.bruens@rwth-aachen.de
- Do not delete dotty/lefty/lneato man pages which are part of
the x11 subpackage, built from the addons package/spec.
(No changelog entry).

See Also

Package Description
libgravatar-19.04.0-1.1.i586.rpm Library to download and display gravatars
libgravatar-19.04.0-1.1.x86_64.rpm Library to download and display gravatars
libgravatar-devel-19.04.0-1.1.i586.rpm Development package for libgravatar
libgravatar-devel-19.04.0-1.1.x86_64.rpm Development package for libgravatar
libgravatar-lang-19.04.0-1.1.noarch.rpm Translations for package libgravatar
libgrilo-0_3-0-0.3.7-1.2.i586.rpm Framework for browsing and searching media content
libgrilo-0_3-0-0.3.7-1.2.x86_64.rpm Framework for browsing and searching media content
libgrlnet-0_3-0-0.3.7-1.2.i586.rpm Framework for browsing and searching media content -- Networking Helper Library
libgrlnet-0_3-0-0.3.7-1.2.x86_64.rpm Framework for browsing and searching media content -- Networking Helper Library
libgrlpls-0_3-0-0.3.7-1.2.i586.rpm Framework for browsing and searching media content -- Playlist Helper Library
libgrlpls-0_3-0-0.3.7-1.2.x86_64.rpm Framework for browsing and searching media content -- Playlist Helper Library
libgromacs3-2018.4-1.7.i586.rpm Libraries for Gromacs
libgromacs3-2018.4-1.7.x86_64.rpm Libraries for Gromacs
libgroove-devel-4.3.0-3.1.i586.rpm Development files for libgroove
libgroove-devel-4.3.0-3.1.x86_64.rpm Development files for libgroove
Advertisement
Advertisement