libgnustep-base1_26-1.26.0-1.4.x86_64.rpm


Advertisement

Description

libgnustep-base1_26 - GNUstep Base library package

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libgnustep-base1_26-1.26.0-1.4.x86_64.rpm
Package name libgnustep-base1_26
Package version 1.26.0
Package release 1.4
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.gnustep.org/
License LGPL-2.1-or-later AND GPL-3.0-or-later
Maintainer -
Download size 1.29 MB
Installed size 6.15 MB
The GNUstep Base Library is a library of general-purpose,
non-graphical Objective C classes, inspired by the
OpenStep API but implementing Apple and GNU additions to the API
as well.  It includes, for example, classes for Unicode strings,
arrays, dictionaries, sets, byte streams, typed coders, invocations,
notifications, notification dispatchers, scanners, tasks, files,
networking, threading, remote object messaging support (distributed
objects), event loops, loadable bundles, attributed Unicode strings,
XML, MIME, user defaults.

Alternatives

Package Version Architecture Repository
libgnustep-base1_26-1.26.0-35.9.x86_64.rpm 1.26.0 x86_64 Education
libgnustep-base1_26-1.26.0-35.9.i586.rpm 1.26.0 i586 Education
libgnustep-base1_26-1.26.0-1.4.i586.rpm 1.26.0 i586 openSUSE Oss
libgnustep-base1_26 - - -

Requires

Name Value
/sbin/ldconfig -
libavahi-client.so.3()(64bit) -
libavahi-common.so.3()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libffi.so.7()(64bit) -
libffi.so.7(LIBFFI_BASE_7.0)(64bit) -
libffi.so.7(LIBFFI_CLOSURE_7.0)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgnutls.so.30()(64bit) -
libgnutls.so.30(GNUTLS_3_4)(64bit) -
libicui18n.so.suse64.2()(64bit) -
libicuuc.so.suse64.2()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libobjc.so.4()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.12)(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
libxml2.so.2(LIBXML2_2.5.8)(64bit) -
libxml2.so.2(LIBXML2_2.6.0)(64bit) -
libxml2.so.2(LIBXML2_2.6.20)(64bit) -
libxml2.so.2(LIBXML2_2.6.23)(64bit) -
libxml2.so.2(LIBXML2_2.6.8)(64bit) -
libxml2.so.2(LIBXML2_2.7.0)(64bit) -
libxml2.so.2(LIBXML2_2.9.0)(64bit) -
libxslt.so.1()(64bit) -
libxslt.so.1(LIBXML2_1.0.11)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
libgnustep-base.so.1.26()(64bit) -
libgnustep-base1_26 = 1.26.0-1.4
libgnustep-base1_26(x86-64) = 1.26.0-1.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgnustep-base1_26-1.26.0-1.4.x86_64.rpm
Source Package gnustep-base-1.26.0-1.4.src.rpm

Install Howto

Install libgnustep-base1_26 rpm package:

# zypper install libgnustep-base1_26

Files

Path
/usr/lib64/libgnustep-base.so.1.26
/usr/lib64/libgnustep-base.so.1.26.0

Changelog

2019-01-11 - Fred kiefer <fredkiefer@gmx.de>
- update to 1.26.0
* Improve utf8 validity checks.
* Make point and size subclasses for NSValue interchangable.
* Add support for TLS SNI. Always request certificate from client and
update certificates after 5 minutes.
* Don't write deprecated fields to desktop link file.
* Use NSLock instead of GSLazyLock and other improvements for
multithreaded processes.
* Clean up of NSString cluster.
* Update NSAssert() and NSCAssert() to handle variable arguments (as
OSX has done) and mark the numbered macros as obsolete.
* Various improvements in tests.
* Require ICU >= 50.
* ICU is now detected using pkg-config.
* Improve XML parsing.
* Make NSXMLNode ivar a union representing different types, instead
of assuming it will contain different underlying class types in
different contexts.  This is important for the new libobjc2 ABI.
* OSX compatibility changes to NSURL.
* NSFileManager call error handle on missing file.
* Dummy spinlock implementation for platforms that don't support it.
* Internationalization improvements: Japanese translation, Turkish
translation, Polish translation.
* Various improvements for new libobjc2 "v2 ABI", including things
like a new NSConstantString implementation, making
GS_REPLACE_CONSTANT_STRING a noop with the new ABI, etc.
* Improvements for stack traces, exception handling and dead lock
detection.
* Other more minor bugfixes and cleanups.  Many found by Coverity
scan results.
* As usual, this release also contains an update to include the most
recent international timezone data.
2018-07-10 - crrodriguez@opensuse.org
- Remove dependencies on insserv, not used.
2017-12-31 - fredkiefer@gmx.de
- update to 1.25.1
o Unicode fixes for characters outside the base plane
o Stubs for some new OSX methods
o Various new OSX compatibility macro and type definitions
o NSFileManager fixes and tweaks to match OSX implementation
o NSDistributedLock bugfix for pre-existing lock directories
o Alternative sort algorithms selectable at runtime
o Compatibility-related changes for environments not supporting weak
symbols
o Other more minor bugfixes and cleanups.
o As usual, this release also contains an update to include the most
recent international timezone data.
2017-09-09 - jengelh@inai.de
- Implement shared library packaging guideline.
Ensure neutrality of description.
2017-09-03 - fredkiefer@gmx.de
- Remove scripts to start gdnc as daemon or on login. (Fixes boo#1055816)
2017-07-22 - fredkiefer@gmx.de
- Change gnustep-make from BuildRequired to Required.
2017-04-16 - fredkiefer@gmx.de
- update to 1.25.0
2017-01-17 - aloisio@gmx.com
- Rename pl to pllist unconditionally.
- Explicit filelist to better monitor conflicts between
packages.
2017-01-14 - aloisio@gmx.com
- Reverted macros in comments
2017-01-12 - aloisio@gmx.com
- Spec cleanup
- Removed _service file and added tarball so that
the package can be accepted into Factory

See Also

Package Description
libgnutls-dane-devel-3.6.7-1.1.i586.rpm Development package for GnuTLS DANE component
libgnutls-dane-devel-3.6.7-1.1.x86_64.rpm Development package for GnuTLS DANE component
libgnutls-dane0-3.6.7-1.1.i586.rpm DANE support for the GNU Transport Layer Security Library
libgnutls-dane0-3.6.7-1.1.x86_64.rpm DANE support for the GNU Transport Layer Security Library
libgnutls-devel-3.6.7-1.1.i586.rpm Development package for the GnuTLS C API
libgnutls-devel-3.6.7-1.1.x86_64.rpm Development package for the GnuTLS C API
libgnutls-devel-32bit-3.6.7-1.1.x86_64.rpm Development package for the GnuTLS C API
libgnutls30-3.6.7-1.1.i586.rpm The GNU Transport Layer Security Library
libgnutls30-3.6.7-1.1.x86_64.rpm The GNU Transport Layer Security Library
libgnutls30-32bit-3.6.7-1.1.x86_64.rpm The GNU Transport Layer Security Library
libgnutlsxx-devel-3.6.7-1.1.i586.rpm Development package for the GnuTLS C++ API
libgnutlsxx-devel-3.6.7-1.1.x86_64.rpm Development package for the GnuTLS C++ API
libgnutlsxx28-3.6.7-1.1.i586.rpm C++ API for the GNU Transport Layer Security Library
libgnutlsxx28-3.6.7-1.1.x86_64.rpm C++ API for the GNU Transport Layer Security Library
libgo11-32bit-7.4.1+r270528-1.1.x86_64.rpm GNU Go compiler runtime library
Advertisement
Advertisement