libgnomeui-devel-2.24.6+20170807.30334c28-3.3.x86_64.rpm


Advertisement

Description

libgnomeui-devel - Development files for libgnomeui

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libgnomeui-devel-2.24.6+20170807.30334c28-3.3.x86_64.rpm
Package name libgnomeui-devel
Package version 2.24.6+20170807.30334c28
Package release 3.3
Package architecture x86_64
Package type rpm
Category Development/Libraries/GNOME
Homepage http://www.gnome.org/
License GPL-2.0-or-later AND LGPL-2.1-or-later
Maintainer -
Download size 55.68 KB
Installed size 244.18 KB
This subpackage contains the header files for developing
applications that want to make use of libgnomeui.

Alternatives

Package Version Architecture Repository
libgnomeui-devel-2.24.6+20170807.30334c28-82.22.x86_64.rpm 2.24.6+20170807.30334c28 x86_64 GNOME Next
libgnomeui-devel-2.24.6+20170807.30334c28-82.22.i586.rpm 2.24.6+20170807.30334c28 i586 GNOME Next
libgnomeui-devel-2.24.6+20170807.30334c28-72.17.x86_64.rpm 2.24.6+20170807.30334c28 x86_64 GNOME Factory
libgnomeui-devel-2.24.6+20170807.30334c28-72.17.i586.rpm 2.24.6+20170807.30334c28 i586 GNOME Factory
libgnomeui-devel-2.24.6+20170807.30334c28-3.3.i586.rpm 2.24.6+20170807.30334c28 i586 openSUSE Oss
libgnomeui-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libgnomeui = 2.24.6+20170807.30334c28
pkgconfig(gconf-2.0) -
pkgconfig(gdk-pixbuf-2.0) -
pkgconfig(gnome-keyring-1) -
pkgconfig(gnome-vfs-2.0) -
pkgconfig(gtk+-2.0) -
pkgconfig(ice) -
pkgconfig(libart-2.0) -
pkgconfig(libbonoboui-2.0) -
pkgconfig(libgnome-2.0) -
pkgconfig(libgnomecanvas-2.0) -
pkgconfig(sm) -

Provides

Name Value
libgnomeui-devel = 2.24.6+20170807.30334c28-3.3
libgnomeui-devel(x86-64) = 2.24.6+20170807.30334c28-3.3
pkgconfig(libgnomeui-2.0) = 2.24.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgnomeui-devel-2.24.6+20170807.30334c28-3.3.x86_64.rpm
Source Package libgnomeui-2.24.6+20170807.30334c28-3.3.src.rpm

Install Howto

Install libgnomeui-devel rpm package:

# zypper install libgnomeui-devel

Files

Path
/usr/include/libgnomeui-2.0/gnome.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-about.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-app-helper.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-app-util.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-app.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-appbar.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-authentication-manager.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-client.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-color-picker.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-dateedit.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-dialog-util.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-dialog.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-druid-page-edge.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-druid-page-standard.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-druid-page.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-druid.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-entry.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-file-entry.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-font-picker.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-help.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-href.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-ice.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-icon-entry.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-icon-item.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-icon-list.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-icon-lookup.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-icon-sel.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-icon-theme.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-mdi-child.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-mdi-generic-child.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-mdi-session.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-mdi.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-messagebox.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-password-dialog.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-pixmap-entry.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-pixmap.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-popup-menu.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-propertybox.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-scores.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-stock-icons.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-theme-parser.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-thumbnail.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-types.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-ui-init.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-uidefs.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-url.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-vfs-util.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-window-icon.h
/usr/include/libgnomeui-2.0/libgnomeui/gnome-window.h
/usr/include/libgnomeui-2.0/libgnomeui/gnometypebuiltins.h
/usr/include/libgnomeui-2.0/libgnomeui/libgnomeui.h
/usr/lib64/libgnomeui-2.so
/usr/lib64/pkgconfig/libgnomeui-2.0.pc

Changelog

2018-03-20 - dimstar@opensuse.org
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-09-08 - jengelh@inai.de
- Update old boilerplate summaries and macros.
2017-08-16 - zaitor@opensuse.org
- Update to version 2.24.6+20170807.30334c28:
+ Fix compiler warnings.
+ Add DOAP file.
+ Doap category deprecated.
+ Explicitly link against libm for floor().
+ gnome-scores.h: Convert to UTF-8.
+ Updated translations.
- Switch to source service git based checkout.
- Following the above, add gnome-common BuildRequires and pass
NOCONFIGURE=1 ./autogen.sh, we need to bootstrap.
- Also add export CFLAGS="%{optflags} -Wno-error=format-nonliteral"
as some warnings are fatal when building a gitcheckout.
- Pass --enable-gtk-doc to configure, needed now to build docs.
- Drop conditionals for obsolete versions of openSUSE.
- Add Url, silence rpmlint.
- Modernize spec.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
2016-06-01 - jengelh@inai.de
- Drop --with-pic, it is only relevant for static libs (which
are not built). Trim trailing dots from summary. Drop redundant
%clean section. Use %_smp_mflags for parallel building.
2016-05-27 - idonmez@suse.com
- Update to GNOME 3.20.2 FATE#318572
2014-07-22 - dimstar@opensuse.org
- Drop gnome-icon-theme Requires: no longer required after the
merging of the themes into Adwaita theme, which in turn is a
dependency to GTK+ 3.0.
2013-04-15 - mmeister@suse.com
- Added url as source.
Please see http://en.opensuse.org/SourceUrls
2013-03-01 - dimstar@opensuse.org
- Spec-cleanup using format_spec_file service.
2012-02-21 - vuntz@opensuse.org
- Remove explicit Requires in devel subpackage, that will
automatically be added the pkgconfig() way: gconf2-devel,
gnome-vfs2-devel, gtk2-devel, libart_lgpl-devel,
libbonoboui-devel, libgnome-devel, libgnome-keyring-devel,
libgnomecanvas-devel.
- Remove unneeded Requires from devel subpackage: libjpeg-devel,
popt-devel, pkg-config.
- Add explicit Requires for pkgconfig(ice) and pkgconfig(sm) in
devel package: the pkgconfig file references some libraries in
Libs (and not Requires), so we need to depend on them.

See Also

Package Description
libgnomeui-doc-2.24.6+20170807.30334c28-3.3.noarch.rpm Documentation for libgnomeui
libgnomeui-lang-2.24.6+20170807.30334c28-3.3.noarch.rpm Translations for package libgnomeui
libgnuastro6-0.8-1.3.i586.rpm Libraries for the GNU Astronomy Utilities
libgnuastro6-0.8-1.3.x86_64.rpm Libraries for the GNU Astronomy Utilities
libgnuradio-3_7_12-0_0_0-3.7.13.5-2.1.i586.rpm Libraries for GNU Radio
libgnuradio-3_7_12-0_0_0-3.7.13.5-2.1.x86_64.rpm Libraries for GNU Radio
libgnuradio-iqbalance-0.37.2+git.20151121-1.3.i586.rpm Libraries for gr-iqbal
libgnuradio-iqbalance-0.37.2+git.20151121-1.3.x86_64.rpm Libraries for gr-iqbal
libgnuradio-iqbalance-devel-0.37.2+git.20151121-1.3.i586.rpm Development files for gr-iqbal
libgnuradio-iqbalance-devel-0.37.2+git.20151121-1.3.x86_64.rpm Development files for gr-iqbal
libgnustep-base1_26-1.26.0-1.4.i586.rpm GNUstep Base library package
libgnustep-base1_26-1.26.0-1.4.x86_64.rpm GNUstep Base library package
libgnutls-dane-devel-3.6.7-1.1.i586.rpm Development package for GnuTLS DANE component
libgnutls-dane-devel-3.6.7-1.1.x86_64.rpm Development package for GnuTLS DANE component
libgnutls-dane0-3.6.7-1.1.i586.rpm DANE support for the GNU Transport Layer Security Library
Advertisement
Advertisement