libgnomesu-devel-2.0.3-1.1.x86_64.rpm


Advertisement

Description

libgnomesu-devel - Development files for libgnomesu

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libgnomesu-devel-2.0.3-1.1.x86_64.rpm
Package name libgnomesu-devel
Package version 2.0.3
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/GNOME
Homepage https://github.com/openSUSE/libgnomesu
License LGPL-2.1-or-later
Maintainer -
Download size 14.12 KB
Installed size 11.76 KB
This package contains all files needed to develop with libgnomesu.

Alternatives

Package Version Architecture Repository
libgnomesu-devel-2.0.3-432.2.x86_64.rpm 2.0.3 x86_64 GNOME Next
libgnomesu-devel-2.0.3-432.2.i586.rpm 2.0.3 i586 GNOME Next
libgnomesu-devel-2.0.3-427.2.x86_64.rpm 2.0.3 x86_64 GNOME Factory
libgnomesu-devel-2.0.3-427.2.i586.rpm 2.0.3 i586 GNOME Factory
libgnomesu-devel-2.0.3-1.1.i586.rpm 2.0.3 i586 openSUSE Oss
libgnomesu-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libgnomesu = 2.0.3
pkgconfig(glib-2.0) -

Provides

Name Value
libgnomesu-devel = 2.0.3-1.1
libgnomesu-devel(x86-64) = 2.0.3-1.1
pkgconfig(libgnomesu-1.0) = 2.0.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgnomesu-devel-2.0.3-1.1.x86_64.rpm
Source Package libgnomesu-2.0.3-1.1.src.rpm

Install Howto

Install libgnomesu-devel rpm package:

# zypper install libgnomesu-devel

Files

Path
/usr/include/libgnomesu-1.0/
/usr/include/libgnomesu-1.0/libgnomesu/gnomesu-auth-dialog.h
/usr/include/libgnomesu-1.0/libgnomesu/libgnomesu.h
/usr/lib64/libgnomesu.so
/usr/lib64/pkgconfig/libgnomesu-1.0.pc
/usr/share/doc/packages/libgnomesu/api.html
/usr/share/doc/packages/libgnomesu/libgnomesu.css

Changelog

2019-04-02 - sbrabec@suse.com
- Update to version 2.0.3:
* Make gnomesu honor /etc/default/su settings for PATH
(boo#1131339).
* Updated translations.
- Sync PAM configuration with su.
2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2017-06-30 - tchvatal@suse.com
- Version update to 2.0.2:
* Automate the package building in travis on github
* Fix the version stored in configure.ac
2017-06-22 - mpluskal@suse.com
- Update to version 2.0.1:
* Update translations
2016-04-15 - mgorse@suse.com
- Update to GNOME 3.20  Fate#318572
- Drop libgnomesu-exit-with-parent.patch: now included in tarball.
2015-09-10 - sbrabec@suse.com
- Include lost SLE11 fix from hpj@novell.com:
* Add libgnomesu-exit-with-parent.patch, to make child process
exit if parent does. Part of bnc#578284.
2015-09-10 - sbrabec@suse.com
- Update to version 2.0.0 maintained by openSUSE:
* Obsolete all SUSE patches
(libgnomesu-better-pam-handling.patch,
libgnomesu-bnc440970-safe-path.patch
libgnomesu-drop-libgnomeui.patch, libgnomesu-gtk3.patch
libgnomesu-check-setuid-retval.patch,
libgnomesu-ia64-crash.patch, libgnomesu-i18n.patch,
libgnomesu-libtool.patch, libgnomesu-makefile.patch,
libgnomesu-modernize.patch, libgnomesu-no-gconf.patch,
libgnomesu-no-manual-memory-cleaning.patch,
libgnomesu-remove-prior-cookie.patch,
libgnomesu-reorder-pam-init.patch,
libgnomesu-set-xdg_runtime_dir.patch,
libgnomesu-startup-notification.patch
libgnomesu-suid_flags.patch, libgnomesu-unsetenv.patch,
libgnomesu-use-pam_xauth.patch,
libgnomesu-1.0.0-spin-mainloop.patch,
libgnomesu-1.0.0-xauth-nolookup.patch, libgnomesu-64bit.patch)
* Include lost SLE11 fix from hpj@novell.com:
Add patch to make child process exit if parent does. Part of
bnc#578284.
* Translation updates.
2015-02-06 - dimstar@opensuse.org
- Add libgnomesu-set-xdg_runtime_dir.patch: explicitly set
XDG_RUNTIME_DIR for the new user (boo#908167).
2015-02-05 - coolo@suse.com
- Use rm -f to avoid rm asking back with strict umasks.
2013-09-21 - dimstar@opensuse.org
- Change RPM Group of shared library package to System/Libraries.

See Also

Package Description
libgnomesu-lang-2.0.3-1.1.noarch.rpm Translations for package libgnomesu
libgnomesu0-2.0.3-1.1.i586.rpm GNOME su Library
libgnomesu0-2.0.3-1.1.x86_64.rpm GNOME su Library
libgnomeui-2.24.6+20170807.30334c28-3.3.i586.rpm The GNOME User Interface Library
libgnomeui-2.24.6+20170807.30334c28-3.3.x86_64.rpm The GNOME User Interface Library
libgnomeui-32bit-2.24.6+20170807.30334c28-3.3.x86_64.rpm The GNOME User Interface Library
libgnomeui-devel-2.24.6+20170807.30334c28-3.3.i586.rpm Development files for libgnomeui
libgnomeui-devel-2.24.6+20170807.30334c28-3.3.x86_64.rpm Development files for libgnomeui
libgnomeui-doc-2.24.6+20170807.30334c28-3.3.noarch.rpm Documentation for libgnomeui
libgnomeui-lang-2.24.6+20170807.30334c28-3.3.noarch.rpm Translations for package libgnomeui
libgnuastro6-0.8-1.3.i586.rpm Libraries for the GNU Astronomy Utilities
libgnuastro6-0.8-1.3.x86_64.rpm Libraries for the GNU Astronomy Utilities
libgnuradio-3_7_12-0_0_0-3.7.13.5-2.1.i586.rpm Libraries for GNU Radio
libgnuradio-3_7_12-0_0_0-3.7.13.5-2.1.x86_64.rpm Libraries for GNU Radio
libgnuradio-iqbalance-0.37.2+git.20151121-1.3.i586.rpm Libraries for gr-iqbal
Advertisement
Advertisement