libgimpui-2_0-0-2.10.8-2.1.x86_64.rpm


Advertisement

Description

libgimpui-2_0-0 - The GNU Image Manipulation Program - UI Libraries

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libgimpui-2_0-0-2.10.8-2.1.x86_64.rpm
Package name libgimpui-2_0-0
Package version 2.10.8
Package release 2.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.gimp.org/
License GPL-3.0-or-later
Maintainer -
Download size 263.90 KB
Installed size 793.49 KB
The GIMP is an image composition and editing program. GIMP offers
many tools and filters, and provides a large image manipulation
toolbox and scripting.
This package provides GIMP UI libraries.

Alternatives

Package Version Architecture Repository
libgimpui-2_0-0-2.10.8-2.1.i586.rpm 2.10.8 i586 openSUSE Oss
libgimpui-2_0-0 - - -

Requires

Name Value
/sbin/ldconfig -
libbabl-0.1.so.0()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libcairo.so.2()(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libgegl-0.4.so.0()(64bit) -
libgexiv2.so.2()(64bit) -
libgimp-2.0.so.0()(64bit) -
libgimpbase-2.0.so.0()(64bit) -
libgimpcolor-2.0.so.0()(64bit) -
libgimpconfig-2.0.so.0()(64bit) -
libgimpmodule-2.0.so.0()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
liblcms2.so.2()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libpango-1.0.so.0()(64bit) -
libpangocairo-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -

Provides

Name Value
libgimpthumb-2.0.so.0()(64bit) -
libgimpui-2.0.so.0()(64bit) -
libgimpui-2_0-0 = 2.10.8-2.1
libgimpui-2_0-0(x86-64) = 2.10.8-2.1
libgimpwidgets-2.0.so.0()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libgimpui-2_0-0-2.10.8-2.1.x86_64.rpm
Source Package gimp-2.10.8-2.1.src.rpm

Install Howto

Install libgimpui-2_0-0 rpm package:

# zypper install libgimpui-2_0-0

Files

Path
/usr/lib64/libgimpthumb-2.0.so.0
/usr/lib64/libgimpthumb-2.0.so.0.1000.8
/usr/lib64/libgimpui-2.0.so.0
/usr/lib64/libgimpui-2.0.so.0.1000.8
/usr/lib64/libgimpwidgets-2.0.so.0
/usr/lib64/libgimpwidgets-2.0.so.0.1000.8

Changelog

2019-03-25 - mvetter@suse.com
- bsc#1130407: Remove dependency on JasPer.
OpenJPEG is actually used.
2018-11-09 - sean@suspend.net
- Update to vesion 2.10.8:
+Core:
- Use adaptive chunk size in GimpProjectio nwhen rendering the
projection asynchronously, rather than using a fixed chunk size.
This provides a better trade-off between throughput and
responsiveness dynamically, based on how fast the processing is.
+Tools:
- In all selection tools, show error on attempt to
subtract-from/intersect-with empty selection.
- Fix text along path not working with vertical text.
- Fix Text tool's frame position when undoing a move operation.
- Streamline Text tool's drawing blocking/unblocking logic.
- When moving a text layer using the text tool (through alt-drag),
don't change the layer's box mode to "fixed", which is unnecessary,
since the layer's size isn't affected.
- Transform and deformation operations now maintain color for fully
transparent pixels, making unerase and curves manipulation of alpha
channel more reliable.
- All transform tools now apply changes when you asve or export/overwrite
an image without pressing Enter first to confirm changes.
- Heal, Dodge/Burn, Smudge and Convovle tools now adjust the processed
buffer and mask_buffer regions according to the changes made to the
application region, as calculated by intersecting it with the
drawable and mask extents. This fixes wrong application position
when painting on a drawable whose origin is above/to the left of the
image's origin, and there's a selection active.
+Plug-ins:
- Port all plug-ins to the new iterator API in GEGL.
- Improve automatic detection of HEIC/HEIF files.
- Improve RawTherapee discovery by looking up registry key (should
become useful with RawTherapee 5.5 and more).
+Usability:
- Compatibility information in the Save dialog is now more understandable.
The minimum GIMP version for the XCD file is always written down when it
is GIMP 2.8 or over. The list of features warranting the minimum version
is now listed in an expander container rather than as tooltip, which
makes it more discoverable. The warning on compression is now displayed
as its own text under the checkbox and not as additional text to the minimum    GIMP version label.
+CLI:
- New self-explanatory --enable-win32-debug-console CLI option
+Translations:
- Updated translations: Danish, Dutch, Finnish, German, Hungarian,
Italian, Polish, Portugese (Brazil), Spanish, Swedish, Ukranian.
2018-09-17 - ecsos@opensuse.org
- pkgconfig(glib-2.0) >= 2.56.0 is needed.

See Also

Package Description
libgimpui-2_0-0-32bit-2.10.8-2.1.x86_64.rpm The GNU Image Manipulation Program - UI Libraries
libginac-devel-1.7.4-1.9.i586.rpm GiNaC development libraries and header files
libginac-devel-1.7.4-1.9.x86_64.rpm GiNaC development libraries and header files
libginac6-1.7.4-1.9.i586.rpm C++ library for symbolic calculations
libginac6-1.7.4-1.9.x86_64.rpm C++ library for symbolic calculations
libgio-2_0-0-2.60.1-1.1.i586.rpm A virtual file system library API
libgio-2_0-0-2.60.1-1.1.x86_64.rpm A virtual file system library API
libgio-2_0-0-32bit-2.60.1-1.1.x86_64.rpm A virtual file system library API
libgio-fam-2.60.1-1.1.i586.rpm GIO module to use FAM
libgio-fam-2.60.1-1.1.x86_64.rpm GIO module to use FAM
libgio-fam-32bit-2.60.1-1.1.x86_64.rpm GIO module to use FAM
libgiomm-2_4-1-2.60.0-1.1.i586.rpm C++ Interface for Gio
libgiomm-2_4-1-2.60.0-1.1.x86_64.rpm C++ Interface for Gio
libgiomm-2_4-1-32bit-2.60.0-1.1.x86_64.rpm C++ Interface for Gio
libgiomm-2_60-1-2.59.1-1.2.i586.rpm C++ Interface for Gio
Advertisement
Advertisement