libfm-qt6-0.14.1-1.3.i586.rpm


Advertisement

Description

libfm-qt6 - Library providing components to build desktop file managers

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libfm-qt6-0.14.1-1.3.i586.rpm
Package name libfm-qt6
Package version 0.14.1
Package release 1.3
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://lxqt.org
License LGPL-2.1-or-later AND GPL-2.0-or-later
Maintainer -
Download size 444.52 KB
Installed size 1.45 MB
libfm-qt is the Qt port of libfm, a library providing components to
build desktop file managers.

Alternatives

Package Version Architecture Repository
libfm-qt6-0.14.1-1.3.x86_64.rpm 0.14.1 x86_64 openSUSE Oss
libfm-qt6 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.12) -
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libQt5Gui.so.5(Qt_5.12.3_PRIVATE_API) -
libQt5Widgets.so.5 -
libQt5Widgets.so.5(Qt_5) -
libQt5X11Extras.so.5 -
libQt5X11Extras.so.5(Qt_5) -
libc.so.6(GLIBC_2.7) -
libexif.so.12 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libmenu-cache.so.3 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.5) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libxcb.so.1 -

Provides

Name Value
libfm-qt.so.6 -
libfm-qt6 = 0.14.1-1.3
libfm-qt6(x86-32) = 0.14.1-1.3

Conflicts

Name Value
pcmanfm <= 0.10.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libfm-qt6-0.14.1-1.3.i586.rpm
Source Package libfm-qt-0.14.1-1.3.src.rpm

Install Howto

Install libfm-qt6 rpm package:

# zypper install libfm-qt6

Files

Path
/usr/lib/libfm-qt.so.6
/usr/lib/libfm-qt.so.6.1.0
/usr/share/doc/packages/libfm-qt6/README.md
/usr/share/libfm-qt/archivers.list
/usr/share/libfm-qt/terminals.list
/usr/share/licenses/libfm-qt6/LICENSE
/usr/share/mime/packages/libfm-qt-mimetypes.xml

Changelog

2019-02-25 - mvetter@suse.com
- Update to 0.14.1:
* Bumped API version to 0.14.1
* Aged ABI version to 6.1.0
* Respect sorting/selection order when launching files
* Generate libfm-qt.pc correctly
* Fix recursive search when a dir is matched
* Fix crash on showing Properties dialog in special cases
* Case-insensitive and match-containing file name completer for file dialog
* Give window parents to some app-modal dialogs
* Gray out cut files in detailed and compact modes
* Added custom widths and visibility for detailed columns
* Added missing sort-by-group action
* Do not rely on the order of folder menu actions. instead check their data
* pathbar: fix an issue with a slot recursive call
* Make setting trust possible anytime
* Define a macro for "metadata::trust".
* Add rubber-band selection to detailed list view
* Updated translations
2019-02-22 - mvetter@suse.com
- Update license to: LGPL-2.1-or-later AND GPL-2.0-or-later
2019-02-11 - mvetter@suse.com
- Fix lang requirement:
%{lang_package} has implicit requires on %{name} We need to
use %{lang_package -r libfm-qt6} to specify correct name.
2019-01-31 - Michael Vetter <mvetter@suse.com>
- Update to 0.14.0:
* The old libfm dependency is completely dropped.
* Options are added for showing full file names instead of display
names and also for shadowing icons of hidden items.
* Problems in mounts and SMB are fixed.
* Added support for trusting executables and also added an emblem
to untrusted desktop files inside user home. Executables/desktop
files can be ?trusted? in their context menus.
* Added selection/deselection corner marks on mouse-over
(usually, small plus/minus icons).
* Properties dialog contains more info, including a device bar.
* The auto-completer of path-edit is made case-insensitive.
* Compressing of a selection of different mimetypes is made possible.
* The Places pane does not elide row texts unnecessarily anymore
(only when they are too long).
* Randomly missing eject button with mounting is fixed.
* Template actions are shown sorted.
* And many other fixes here and there.
- Move translation from lxqt-l10n into package
- Remove libfm dependency
2018-06-12 - mvetter@suse.com
- Update to 0.13.0:
* This LibFM-Qt point release fixes a regression in Qt 5.11
which will crash PcmanFM-Qt under certain conditions
* Seems to be a problem in Qt 5.11 which is fixed in 5.11.1
* Disconnect old source model
2018-05-22 - mvetter@suse.com
- Update to 0.13.0:
* Important functionalities, like file operations, are ported to C++, which means more flexibility and less libfm dependency
* Smooth scrolling for icon and thumbnail views
* Added a group column to the detailed list view
* Merge side-pane with its surroundings
* Support hiding of items in Places side-pane.
* Use special/custom folder icons for bookmarks
* Italic font for hidden items
* Several bug fixes
* Improvements in GUI and functionalities
* Code cleanup
2018-05-02 - mvetter@suse.com
- bsc#1091635 Problem with Terminal Command in PCManFM-Qt:
Move from -devel package to main package:
* archivers.list
* terminals.list
* libfm-qt-mimetypes.xml

See Also

Package Description
libfm4-1.3.1-1.2.i586.rpm Libfm libraries
libfm4-1.3.1-1.2.x86_64.rpm Libfm libraries
libfmapi-devel-0~20170112-1.5.i586.rpm Development files for libfmapi, a library for MAPI data types
libfmapi-devel-0~20170112-1.5.x86_64.rpm Development files for libfmapi, a library for MAPI data types
libfmapi1-0~20170112-1.5.i586.rpm Library for MAPI data types
libfmapi1-0~20170112-1.5.x86_64.rpm Library for MAPI data types
libfmt5-32bit-5.3.0-2.1.x86_64.rpm A formatting library for C++
libfmt5-5.3.0-2.1.i586.rpm A formatting library for C++
libfmt5-5.3.0-2.1.x86_64.rpm A formatting library for C++
libfole-devel-0~20170502-1.3.i586.rpm Development files for libfole
libfole-devel-0~20170502-1.3.x86_64.rpm Development files for libfole
libfole1-0~20170502-1.3.i586.rpm Library for Object Linking and Embedding (OLE) data types
libfole1-0~20170502-1.3.x86_64.rpm Library for Object Linking and Embedding (OLE) data types
libfolks-data-0.11.4-5.1.i586.rpm Data files for libfolks, a library to create metacontacts from many sources
libfolks-data-0.11.4-5.1.x86_64.rpm Data files for libfolks, a library to create metacontacts from many sources
Advertisement
Advertisement