libfbclient-devel-3.0.4.33054-1.5.i586.rpm


Advertisement

Description

libfbclient-devel - Development files for Firebird RDBMS client library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libfbclient-devel-3.0.4.33054-1.5.i586.rpm
Package name libfbclient-devel
Package version 3.0.4.33054
Package release 1.5
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.firebirdsql.org/
License SUSE-IDPL-1.0 AND SUSE-IBPL-1.0
Maintainer -
Download size 155.59 KB
Installed size 1.79 MB
This package is needed for development of client applications accessing
Firebird RDBMS.
Firebird is a relational database offering many ANSI SQL standard
features that runs on Linux, Windows, and a variety of Unix platforms.
Firebird offers excellent concurrency, high performance, and powerful
language support for stored procedures and triggers. It has been used
in production systems, under a variety of names, since 1981.

Alternatives

Package Version Architecture Repository
libfbclient-devel-3.0.4.33054-117.32.x86_64.rpm 3.0.4.33054 x86_64 Database
libfbclient-devel-3.0.4.33054-117.32.i586.rpm 3.0.4.33054 i586 Database
libfbclient-devel-3.0.4.33054-1.5.x86_64.rpm 3.0.4.33054 x86_64 openSUSE Oss
libfbclient-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
firebird = 3.0.4.33054
libfbclient2 = 3.0.4.33054

Provides

Name Value
firebird-devel = 3.0.4.33054
libfbclient-devel = 3.0.4.33054-1.5
libfbclient-devel(x86-32) = 3.0.4.33054-1.5
libfbclient2-devel = 3.0.4.33054
libfbembed-devel -
pkgconfig(fbclient) = 3.0.4

Obsoletes

Name Value
firebird-devel < 3
libfbclient2-devel < 3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libfbclient-devel-3.0.4.33054-1.5.i586.rpm
Source Package firebird-3.0.4.33054-1.5.src.rpm

Install Howto

Install libfbclient-devel rpm package:

# zypper install libfbclient-devel

Files

Path
/usr/include/firebird/Firebird.pas
/usr/include/firebird/IdlFbInterfaces.h
/usr/include/firebird/Interface.h
/usr/include/firebird/Message.h
/usr/include/firebird/UdrCppEngine.h
/usr/include/firebird/ibase.h
/usr/include/firebird/iberror.h
/usr/include/firebird/impl/
/usr/include/firebird/impl/boost/
/usr/include/firebird/impl/boost/preprocessor/cat.hpp
/usr/include/firebird/impl/boost/preprocessor/arithmetic/dec.hpp
/usr/include/firebird/impl/boost/preprocessor/arithmetic/inc.hpp
/usr/include/firebird/impl/boost/preprocessor/config/config.hpp
/usr/include/firebird/impl/boost/preprocessor/control/expr_if.hpp
/usr/include/firebird/impl/boost/preprocessor/control/expr_iif.hpp
/usr/include/firebird/impl/boost/preprocessor/control/if.hpp
/usr/include/firebird/impl/boost/preprocessor/control/iif.hpp
/usr/include/firebird/impl/boost/preprocessor/debug/error.hpp
/usr/include/firebird/impl/boost/preprocessor/detail/auto_rec.hpp
/usr/include/firebird/impl/boost/preprocessor/detail/dmc/auto_rec.hpp
/usr/include/firebird/impl/boost/preprocessor/facilities/empty.hpp
/usr/include/firebird/impl/boost/preprocessor/logical/bool.hpp
/usr/include/firebird/impl/boost/preprocessor/repetition/for.hpp
/usr/include/firebird/impl/boost/preprocessor/repetition/detail/for.hpp
/usr/include/firebird/impl/boost/preprocessor/repetition/detail/dmc/for.hpp
/usr/include/firebird/impl/boost/preprocessor/repetition/detail/edg/for.hpp
/usr/include/firebird/impl/boost/preprocessor/repetition/detail/msvc/for.hpp
/usr/include/firebird/impl/boost/preprocessor/seq/elem.hpp
/usr/include/firebird/impl/boost/preprocessor/seq/for_each_i.hpp
/usr/include/firebird/impl/boost/preprocessor/seq/seq.hpp
/usr/include/firebird/impl/boost/preprocessor/seq/size.hpp
/usr/include/firebird/impl/boost/preprocessor/tuple/eat.hpp
/usr/include/firebird/impl/boost/preprocessor/tuple/elem.hpp
/usr/include/firebird/impl/boost/preprocessor/tuple/rem.hpp
/usr/lib/libfbclient.so
/usr/lib/pkgconfig/fbclient.pc

Changelog

2018-11-21 - mkubecek@suse.cz
- update to upstream version 3.0.4
* add support for SRP authentication using SHA-256
* ODS (database file format) version raised to 12.2 on some
architectures (including i586, not x86_64); new version will be
able to open existing ODS 12.0 created on the same architecture
but for database transfer between architectures, backup/restore
is always recommended
* context variables WIRE_COMPRESSED and WIRE_ENCRYPTED were added
to the SYSTEM namespace to report compression and encryption
status, respectively, of the current connection (CORE-5913)
* enhanced reporting of errors when dynamic library fails to load
(CORE-5908)
* include funciton name when UDF causes "Arithmetic exception,
numeric overflow, or string truncation" error (CORE-5876)
* context variables LOCALTIME and LOCALTIMESTAMP (synonyms for
CURRENT_TIME and CURRENT_TIMESTAMP) for compatibility with 4.0
(CORE-5853)
* read-only restriction for system tables was relaxed to permit
CREATE, ALTER and DROP operations on their indexes (CORE-5746)
* fix unauthorized BLOB access vulnerability (CORE-5801)
* for a full list of bugfixes and improvements see
http://www.firebirdsql.org/file/documentation/release_notes/html/en/3_0/rnfb30-general.html#rnfb30-general-v304
- drop patches included in new upstream release:
Make-it-build-with-icu60.patch
An-attempt-to-fix-CORE-5764-need-feedback-on-snapsho.patch
Fixed-a-code-somewhy-accepted-by-gcc6.patch
- refresh patches:
work-around-g-problem-in-SLE11.patch
use-C-98-on-SLE11.patch
2018-07-04 - mkubecek@suse.cz
- replace unicode-handle-the-ICU-version-hack-from-SuSE.patch
with more general upstream solution:
* An-attempt-to-fix-CORE-5764-need-feedback-on-snapsho.patch
* Fixed-a-code-somewhy-accepted-by-gcc6.patch
- unicode-handle-new-SUSE-ICU-version-hack.patch:
search also for "suse%d.%d" soname pattern to fix build after
upcoming ICU update (bsc#1095425)
2018-03-28 - mkubecek@suse.cz
- move firebitd.xinetd back to firebird-server subpackage on SLE15
- provide /etc/xinetd.d directory on Tumbleweed and Leap 15.0 as
xinetd is no longer guaranteed to be present there; this solution
(suggested by Dimstar) is less painful than either having
firebird-server depend on xinetd or splitting a new subpackage
firebird-server-classic.
2018-03-23 - mkubecek@suse.cz
- patch xinetd config file unconditionally; previous change would
result in unpatched xinetd config file installed on Tumbleweed
so that the service would be enabled by default and firebird
binary run as root
2018-03-22 - fcrozat@suse.com
- Do no ship xinetd file on SLE15 (bsc#1084459).

See Also

Package Description
libfbclient2-3.0.4.33054-1.5.i586.rpm Firebird RDBMS client library
libfbclient2-3.0.4.33054-1.5.x86_64.rpm Firebird RDBMS client library
libfbclient2-32bit-3.0.4.33054-1.5.x86_64.rpm Firebird RDBMS client library
libfcache-devel-0~20170111-1.5.i586.rpm Development files for libfcache
libfcache-devel-0~20170111-1.5.x86_64.rpm Development files for libfcache
libfcache1-0~20170111-1.5.i586.rpm Library to provide generic file data cache functions
libfcache1-0~20170111-1.5.x86_64.rpm Library to provide generic file data cache functions
libfcgi0-2.4.0-172.5.i586.rpm A scalable, open extension to CGI - System library
libfcgi0-2.4.0-172.5.x86_64.rpm A scalable, open extension to CGI - System library
libfcitx-4_2_9-32bit-4.2.9.6-1.5.x86_64.rpm Shared libraries for fcitx
libfcitx-4_2_9-4.2.9.6-1.5.i586.rpm Shared libraries for fcitx
libfcitx-4_2_9-4.2.9.6-1.5.x86_64.rpm Shared libraries for fcitx
libfdata-devel-0~20170112-1.7.i586.rpm Development files for libfdata
libfdata-devel-0~20170112-1.7.x86_64.rpm Development files for libfdata
libfdata1-0~20170112-1.7.i586.rpm Library to provide generic file data functions
Advertisement
Advertisement