libexpat-devel-2.2.6-3.1.i586.rpm


Advertisement

Description

libexpat-devel - Development files for expat, an XML parser toolkit

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libexpat-devel-2.2.6-3.1.i586.rpm
Package name libexpat-devel
Package version 2.2.6
Package release 3.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://libexpat.github.io
License MIT
Maintainer -
Download size 30.60 KB
Installed size 51.53 KB
Expat is an XML parser library written in C. It is a stream-oriented
parser in which an application registers handlers for things the
parser might find in the XML document (like start tags).
This package contains the development headers for the library found
in libexpat.

Alternatives

Package Version Architecture Repository
libexpat-devel-2.2.6-3.1.x86_64.rpm 2.2.6 x86_64 openSUSE Oss
libexpat-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
glibc-devel -
libexpat1 = 2.2.6

Provides

Name Value
libexpat-devel = 2.2.6-3.1
libexpat-devel(x86-32) = 2.2.6-3.1
pkgconfig(expat) = 2.2.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libexpat-devel-2.2.6-3.1.i586.rpm
Source Package expat-2.2.6-3.1.src.rpm

Install Howto

Install libexpat-devel rpm package:

# zypper install libexpat-devel

Files

Path
/usr/include/expat.h
/usr/include/expat_config.h
/usr/include/expat_external.h
/usr/lib/libexpat.so
/usr/lib/pkgconfig/expat.pc

Changelog

2019-02-07 - Bernhard Wiedemann <bwiedemann@suse.com>
- Add expat-2.2.6-fix-make-clean.patch
- Allow profile guided optimization again
2019-01-03 - Tomá? Chvátal <tchvatal@suse.com>
- Drop docbook2x dependency, the manpages are generated in
the upstream archive and this way we break buildcycle
2018-09-11 - pmonrealgonzalez@suse.com
- Version update to 2.2.6 Sun August 12 2018
* Bug fixes:
- Avoid doing arithmetic with NULL pointers in XML_GetBuffer
- Fix 2.2.5 regression with suspend-resume while parsing
a document like '<root/>'
* Other changes:
- Autotools: Fix docbook-related configure syntax error
- Autotools: Avoid grep option `-q` for Solaris
- Autotools: Support
./configure DOCBOOK_TO_MAN="xmlto man --skip-validation"
- Autotools: Support DOCBOOK_TO_MAN command which produces
xmlwf.1 rather than XMLWF.1; also covers case insensitive
file systems
- Autotools: Drop -rpath option passed to libtool
- Autotools: Detect and deny SGML docbook2man as ours is XML
- Autotools/CMake: Support command db2x_docbook2man as well
- CMake: Introduce option WARNINGS_AS_ERRORS, defaults to OFF
- CMake: Introduce option MSVC_USE_STATIC_CRT, defaults to OFF
- CMake: Introduce option XML_UNICODE and XML_UNICODE_WCHAR_T,
both defaulting to OFF
- CMake: Prefer check_symbol_exists over check_function_exists
- CMake: Create the same pkg-config file as with GNU Autotools
- CMake: Use GNUInstallDirs module to set proper defaults for
install directories
- CMake: Utilize expat_config.h.cmake for XML_DEV_URANDOM
- Address compiler warnings
- Fix miscellaneous typos
2017-11-16 - jengelh@inai.de
- Expand description of expat-devel.
2017-11-16 - mpluskal@suse.com
- Do not generate manpages from docbook
- Temporarily disable profiling due to bug in build system
2017-11-08 - aavindraa@gmail.com
- Version update to 2.2.5 Tue October 31 2017
* Bug fixes:
- If the parser runs out of memory, make sure its internal
state reflects the memory it actually has, not the memory
it wanted to have.
- The default handler wasn't being called when it should for
a SYSTEM or PUBLIC doctype if an entity declaration handler
was registered.
- Fix a case of mistakenly reported parsing success where
XML_StopParser was called from an element handler
- Function XML_ErrorString was returning NULL rather than
a message for code XML_ERROR_INVALID_ARGUMENT
introduced with release 2.2.1
* Other changes:
- Add argument -N adding notation declarations
- various compiler-specific fixes
- Improve docbook2x-man detection
- drop expat-docbook.patch
* fixed in 0f5186c7b8e503c669e332d944712de010b265f3
- switch to github for release tarballs and website

See Also

Package Description
libexpat-devel-32bit-2.2.6-3.1.x86_64.rpm Development files for expat, an XML parser toolkit
libexpat1-2.2.6-3.1.i586.rpm XML Parser Toolkit
libexpat1-2.2.6-3.1.x86_64.rpm XML Parser Toolkit
libexpat1-32bit-2.2.6-3.1.x86_64.rpm XML Parser Toolkit
libexplain-devel-1.4-3.2.i586.rpm Development files for libexplain
libexplain-devel-1.4-3.2.x86_64.rpm Development files for libexplain
libexplain51-1.4-3.2.i586.rpm Library functions to explain system call errors
libexplain51-1.4-3.2.x86_64.rpm Library functions to explain system call errors
libext2fs-devel-1.45.0-1.1.i586.rpm Development files for libext2fs
libext2fs-devel-1.45.0-1.1.x86_64.rpm Development files for libext2fs
libext2fs-devel-32bit-1.45.0-1.1.x86_64.rpm Development files for libext2fs
libext2fs-devel-static-1.45.0-1.1.i586.rpm Development files for libext2fs
libext2fs-devel-static-1.45.0-1.1.x86_64.rpm Development files for libext2fs
libext2fs2-1.45.0-1.1.i586.rpm Ext2fs library
libext2fs2-1.45.0-1.1.x86_64.rpm Ext2fs library
Advertisement
Advertisement