libewf-devel-0~20140608-7.1.x86_64.rpm


Advertisement

Description

libewf-devel - Development files for libewf, an Expert Witness Compression Format library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libewf-devel-0~20140608-7.1.x86_64.rpm
Package name libewf-devel
Package version 0~20140608
Package release 7.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://code.google.com/p/libewf/
License LGPL-3.0+ and GFDL-1.3+
Maintainer -
Download size 523.24 KB
Installed size 824.65 KB
libewf is a library for support of the Expert Witness Compression
Format (EWF). It supports both the SMART format (EWF-S01) and the
EnCase format (EWF-E01). libewf allows you to read and write media
information within the EWF files. libewf allows to read files created
by EnCase 1 to 6, linen and FTK Imager.
This subpackage contains libraries and header files for developing
applications that want to make use of libewf.

Alternatives

Package Version Architecture Repository
libewf-devel-0~20140608-7.1.i586.rpm 0~20140608 i586 openSUSE Oss
libewf-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libewf2 = 0~20140608

Provides

Name Value
libewf-devel = 0~20140608-7.1
libewf-devel(x86-64) = 0~20140608-7.1
pkgconfig(libewf) = 20140608

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libewf-devel-0~20140608-7.1.x86_64.rpm
Source Package libewf-0~20140608-7.1.src.rpm

Install Howto

Install libewf-devel rpm package:

# zypper install libewf-devel

Files

Path
/usr/include/libewf.h
/usr/include/libewf/codepage.h
/usr/include/libewf/definitions.h
/usr/include/libewf/error.h
/usr/include/libewf/extern.h
/usr/include/libewf/features.h
/usr/include/libewf/types.h
/usr/lib64/libewf.so
/usr/lib64/pkgconfig/libewf.pc
/usr/share/doc/packages/libewf-devel/AUTHORS
/usr/share/doc/packages/libewf-devel/COPYING
/usr/share/doc/packages/libewf-devel/ChangeLog
/usr/share/doc/packages/libewf-devel/Expert_Witness_Compression_Format_2_EWF2.pdf
/usr/share/doc/packages/libewf-devel/Expert_Witness_Compression_Format_EWF.pdf
/usr/share/doc/packages/libewf-devel/NEWS
/usr/share/doc/packages/libewf-devel/README
/usr/share/man/man3/libewf.3.gz

Changelog

2019-04-19 - Greg Freemyer <Greg.Freemyer@gmail.com>
- Use the built in version of libcpath
* libcpath has been updated and one of the functions renamed
* until libewf is updated the internal version of libcpath must be used
2018-01-14 - Greg.Freemyer@gmail.com
- fix a problem with the python to python2 rename
2017-10-11 - Greg.Freemyer@gmail.com
- add skeleton python3 support - upstream doesn't have python 3 in the stable release
- rename python-libewf to python2-libewf to be compatible with python singlespec
- remove pyewf as it isn't versioned and isn't singlespec compatible
2015-01-10 - Greg.Freemyer@gmail.com
- clean up buildrequires section
- remove %if opensuse.  Not needed now that libyal is in security:forensics.
- begin to use newly released libyal packages from OBS
2014-08-25 - Greg.Freemyer@gmail.com
- The latest update of libsmraw in factory is not building right in libewf.
- Use internal version instead
- add a version number to Provides: pyewf
2014-08-20 - Greg.Freemyer@gmail.com
- update to libewf-20140608
* worked on integrating multi threaded ewfacquire changes
* bug fix for utf16 header functions
* bug fix in ewfmount regarding logical files date and time values
* make pyewf_handle_open more strict to catch non-string objects
without the check the code will segfault on non-string objects
* bug fixes in empty block compression
* bug fix in libewf_read_io_handle_read_chunk_data error tolerance
code path
* bug fix in recent process status changes
* changed behavior of empty-block check
- review BuildRequires for new external packages
- use external packages where possible
- added to python sub-package section
- Requires:       %{lname} = %{version"
- Provides:       pyewf
- ran spec-cleaner
2014-02-03 - varadgautam@gmail.com
- update to libewf-20140201
- remove nonexistent README.dll from %doc
2013-07-31 - Greg.Freemyer@gmail.com
- update to 0~20130416
* changes to zlib.m4 for adler32 detection
- add Obsoletes/Provides pair for ewftools.  That was the old name of the tool package.
2013-04-05 - jengelh@inai.de
- Cleanups: Set RPM group, license, summary and description
metadata; remove unused %py_requires; do not bloat shlib package
with documentation
- Use system libraries instead of bundled ones where possible
- Name the tools package according to upstream's recommendation
- Drop unnecessary -fno-strict-aliasing
2013-04-03 - Greg.Freemyer@gmail.com
- update to latest release 20130331
* more sync with experimental version
* improved error tolerance for issue 8
* updated libsmdev to fix issue 13
- add 2 documentation files provided by upstream
- fix a illegal group setting
- update %files sections to match sample specfile in source tree
- update Requires and BuildRequires to match sample specfile in source tree

See Also

Package Description
libewf-tools-0~20140608-7.1.i586.rpm Utilities for the Expert Witness Compression Format (EWF)
libewf-tools-0~20140608-7.1.x86_64.rpm Utilities for the Expert Witness Compression Format (EWF)
libewf2-0~20140608-7.1.i586.rpm Library to support the Expert Witness Compression Format
libewf2-0~20140608-7.1.x86_64.rpm Library to support the Expert Witness Compression Format
libexe-devel-0~20160110-1.12.i586.rpm Development files for libexe
libexe-devel-0~20160110-1.12.x86_64.rpm Development files for libexe
libexe-tools-0~20160110-1.12.i586.rpm Tools to access Microsoft executable (EXE) format files
libexe-tools-0~20160110-1.12.x86_64.rpm Tools to access Microsoft executable (EXE) format files
libexe1-0~20160110-1.12.i586.rpm Library to access the executable (EXE) format
libexe1-0~20160110-1.12.x86_64.rpm Library to access the executable (EXE) format
libexempi-devel-2.4.5-1.6.i586.rpm Development files for the Exempi XMP support library
libexempi-devel-2.4.5-1.6.x86_64.rpm Development files for the Exempi XMP support library
libexempi3-2.4.5-1.6.i586.rpm XMP support library
libexempi3-2.4.5-1.6.x86_64.rpm XMP support library
libexempi3-32bit-2.4.5-1.6.x86_64.rpm XMP support library
Advertisement
Advertisement