libe-book-devel-0.1.3-1.11.x86_64.rpm


Advertisement

Description

libe-book-devel - A library to import non-HTML reflowable e-book formats

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libe-book-devel-0.1.3-1.11.x86_64.rpm
Package name libe-book-devel
Package version 0.1.3
Package release 1.11
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://sourceforge.net/projects/libebook/
License MPL-2.0
Maintainer -
Download size 47.61 KB
Installed size 118.90 KB
libe-book is a library to import non-HTML reflowable e-book formats.
Currently supported are PalmDoc, TealDoc, Plucker eBook, eReader eBook,
FictionBook v.2, TCR, zTXT.

Alternatives

Package Version Architecture Repository
libe-book-devel-0.1.3-1.11.i586.rpm 0.1.3 i586 openSUSE Oss
libe-book-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libe-book-0_1-1 = 0.1.3
libstdc++-devel -
pkgconfig(icu-uc) -
pkgconfig(liblangtag) -
pkgconfig(librevenge-0.0) -
pkgconfig(libxml-2.0) -
pkgconfig(zlib) -

Provides

Name Value
libe-book-devel = 0.1.3-1.11
libe-book-devel(x86-64) = 0.1.3-1.11
pkgconfig(libe-book-0.1) = 0.1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libe-book-devel-0.1.3-1.11.x86_64.rpm
Source Package libe-book-0.1.3-1.11.src.rpm

Install Howto

Install libe-book-devel rpm package:

# zypper install libe-book-devel

Files

Path
/usr/include/libe-book-0.1/
/usr/include/libe-book-0.1/libe-book/EBOOKDocument.h
/usr/include/libe-book-0.1/libe-book/libe-book.h
/usr/lib64/libe-book-0.1.so
/usr/lib64/pkgconfig/libe-book-0.1.pc
/usr/share/doc/packages/libe-book-devel/COPYING
/usr/share/doc/packages/libe-book-devel/ChangeLog
/usr/share/doc/packages/libe-book-devel/NEWS
/usr/share/doc/packages/libe-book-devel/TODO

Changelog

2018-01-09 - jengelh@inai.de
- Cure linguistic problem in descriptions.
2018-01-08 - tchvatal@suse.com
- Update to 0.1.3:
* Fix various problems when reading broken files, found with the help of
american-fuzzy-lop and oss-fuzz.
* Fix build with boost >= 1.59.
* Set default page margins. (tdf#94162)
* Make output of ebook2* --help more compatible with help2man.
* Check for librevenge-stream if tests are enabled. (gentoo#603098)
* Require C++11 for build.
* Drop outdated MSVC project files.
* Fix several issues found by Coverity.
* FictionBook v.2:
* Use document language as default language for text.
* Use note title as footnote mark.
* Handle subscript and superscript.
* Output content of <code> in monospace font.
2017-02-01 - adam.majer@suse.de
- use individual libboost-*-devel packages instead of boost-devel
2016-08-01 - tchvatal@suse.com
- Disable sle11 support code
2015-11-11 - idonmez@suse.com
- Fix compilation with boost 1.59
2015-02-05 - p.drouand@gmail.com
- Update to version 0.1.2
* Check arguments of public functions. Passing NULL no longer causes
cash.
* Use symbol visibility on Linux. The library only exports the two
public functions now.
* Fix handling of   *  *enable  *experimental configure option.
* Fix various crashes and hangs when reading broken files, found
with the help of american  *fuzzy  *lop.
* Fix incorrect mime type for JPEG images that occurs occasionally
in FB2 files.
* Handle zipped files that contain more than one file.
* Add support for headings.
* Add support for text language.
* Convert dimensions and font sizes correctly. This makes the
output actually usable
* Parse basic paragraph and character properties.
* Add initial support for images. Only Plot tag is supported, as
Canvas is much more complex and can contain other objects too,
not just a single image.
* Recognize GIF images too.
* Parse important page properties, like dimensions and margins.
* Substitute the default fonts embedded on the devices for Liberation fonts.
* Try to reconstruct headings from table of contents.
2014-06-03 - fstrba@suse.com
- Upgrade to upstream version 0.1.1
* Fix various problems when using --disable-experimental.
* Work around MSVC bug.
* Fix parsing of zipped FictionBook 2 files.
2014-05-26 - fstrba@suse.com
- Upgrade to upstream version 0.1.0
* ABI change
* Remove dependency on libwpd-devel
* Add dependency on librevenge-devel
- License change
* Released under MPL-2.0
2014-05-01 - crrodriguez@opensuse.org
- Use -fvisibility-inlines-hidden here as well, saves around
360 global symbol table entries.
2014-02-06 - fcrozat@suse.com
- Fix license tag to LGPL-2.1+ or MPL-2.0

See Also

Package Description
libe-book-devel-doc-0.1.3-1.11.noarch.rpm Documentation for the libe-book API
libe-book-tools-0.1.3-1.11.i586.rpm Tools to transform e-books into other formats
libe-book-tools-0.1.3-1.11.x86_64.rpm Tools to transform e-books into other formats
libeXosip2-12-5.0.0-2.4.i586.rpm Extended osip2 library
libeXosip2-12-5.0.0-2.4.x86_64.rpm Extended osip2 library
libeXosip2-5.0.0-2.4.i586.rpm Extended osip2 library
libeXosip2-5.0.0-2.4.x86_64.rpm Extended osip2 library
libeXosip2-devel-5.0.0-2.4.i586.rpm Extended osip2 library
libeXosip2-devel-5.0.0-2.4.x86_64.rpm Extended osip2 library
libeb16-4.4.3-3.10.i586.rpm C Library for Accessing CD-ROM Books - shared library
libeb16-4.4.3-3.10.x86_64.rpm C Library for Accessing CD-ROM Books - shared library
libebackend-1_2-10-3.32.1-1.1.i586.rpm Evolution Data Server's Backend Utilities Library
libebackend-1_2-10-3.32.1-1.1.x86_64.rpm Evolution Data Server's Backend Utilities Library
libebackend-1_2-10-32bit-3.32.1-1.1.x86_64.rpm Evolution Data Server's Backend Utilities Library
libebl-devel-0.176-1.1.i586.rpm Development files for libebl and for EBL plugins
Advertisement
Advertisement