libdnf-devel-0.31.0-1.1.i586.rpm


Advertisement

Description

libdnf-devel - Development files for libdnf

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libdnf-devel-0.31.0-1.1.i586.rpm
Package name libdnf-devel
Package version 0.31.0
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage https://github.com/rpm-software-management/libdnf
License LGPL-2.1-or-later
Maintainer -
Download size 44.12 KB
Installed size 194.93 KB
This package provides the headers and libraries for developing applications
that use libdnf.

Alternatives

Package Version Architecture Repository
libdnf-devel-0.31.0-1.1.x86_64.rpm 0.31.0 x86_64 openSUSE Oss
libdnf-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libdnf2(x86-32) = 0.31.0-1.1
pkgconfig(glib-2.0) -
pkgconfig(librepo) -
pkgconfig(libsolv) -
pkgconfig(libsolvext) -
pkgconfig(rpm) -
pkgconfig(sqlite3) -

Provides

Name Value
libdnf-devel = 0.31.0-1.1
libdnf-devel(x86-32) = 0.31.0-1.1
pkgconfig(libdnf) = 0.31.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libdnf-devel-0.31.0-1.1.i586.rpm
Source Package libdnf-0.31.0-1.1.src.rpm

Install Howto

Install libdnf-devel rpm package:

# zypper install libdnf-devel

Files

Path
/usr/include/libdnf/config.h
/usr/include/libdnf/dnf-advisory.h
/usr/include/libdnf/dnf-advisorypkg.h
/usr/include/libdnf/dnf-advisoryref.h
/usr/include/libdnf/dnf-context.h
/usr/include/libdnf/dnf-db.h
/usr/include/libdnf/dnf-enums.h
/usr/include/libdnf/dnf-goal.h
/usr/include/libdnf/dnf-keyring.h
/usr/include/libdnf/dnf-lock.h
/usr/include/libdnf/dnf-package.h
/usr/include/libdnf/dnf-packagedelta.h
/usr/include/libdnf/dnf-reldep-list.h
/usr/include/libdnf/dnf-reldep.h
/usr/include/libdnf/dnf-repo-loader.h
/usr/include/libdnf/dnf-repo.h
/usr/include/libdnf/dnf-rpmts.h
/usr/include/libdnf/dnf-sack.h
/usr/include/libdnf/dnf-state.h
/usr/include/libdnf/dnf-transaction.h
/usr/include/libdnf/dnf-types.h
/usr/include/libdnf/dnf-utils.h
/usr/include/libdnf/dnf-version.h
/usr/include/libdnf/hy-goal.h
/usr/include/libdnf/hy-package.h
/usr/include/libdnf/hy-packageset.h
/usr/include/libdnf/hy-query.h
/usr/include/libdnf/hy-repo.h
/usr/include/libdnf/hy-selector.h
/usr/include/libdnf/hy-subject.h
/usr/include/libdnf/hy-types.h
/usr/include/libdnf/hy-util.h
/usr/include/libdnf/libdnf.h
/usr/include/libdnf/log.hpp
/usr/include/libdnf/nevra.hpp
/usr/include/libdnf/nsvcap.hpp
/usr/include/libdnf/conf/Config.hpp
/usr/include/libdnf/conf/ConfigMain.hpp
/usr/include/libdnf/conf/ConfigParser.hpp
/usr/include/libdnf/conf/ConfigRepo.hpp
/usr/include/libdnf/conf/Option.hpp
/usr/include/libdnf/conf/OptionBinds.hpp
/usr/include/libdnf/conf/OptionBool.hpp
/usr/include/libdnf/conf/OptionChild.hpp
/usr/include/libdnf/conf/OptionEnum.hpp
/usr/include/libdnf/conf/OptionNumber.hpp
/usr/include/libdnf/conf/OptionPath.hpp
/usr/include/libdnf/conf/OptionSeconds.hpp
/usr/include/libdnf/conf/OptionString.hpp
/usr/include/libdnf/conf/OptionStringList.hpp
/usr/include/libdnf/plugin/plugin.h
/usr/include/libdnf/utils/PreserveOrderMap.hpp
/usr/include/libdnf/utils/logger.hpp
/usr/lib/libdnf.so
/usr/lib/pkgconfig/libdnf.pc
/usr/share/gtk-doc/html/libdnf/
/usr/share/gtk-doc/html/libdnf/html/common.css
/usr/share/gtk-doc/html/libdnf/html/index.htm

Changelog

2019-04-26 - Neal Gompa <ngompa13@gmail.com>
- Add patch for SLE to temporarily drop support for Module advisories
* Patch: libdnf-0.31.0-Revert-support-for-Module-advisories.patch
2019-04-26 - Neal Gompa <ngompa13@gmail.com>
- Update to version 0.31.0
+ Installroot now requires absolute path
+ Support "_none_" value for repo option "proxy" (rh#1680272)
+ Add support for Module advisories
+ Add support for xml:base attribute from primary.xml (rh#1691315)
+ Fix detection of Platform ID for modules (rh#1688462)
2019-03-31 - Neal Gompa <ngompa13@gmail.com>
- Update to version 0.28.1
+ Enhance modular solver to handle enabled and default module streams differently (rh#1648839)
+ Add support of wild cards for modules (rh#1644588)
+ Exclude module pkgs that have conflict
+ Enhance config parser to preserve order of data, and keep comments and format
+ Improve ARM detection
+ Add support for SHA-384
+ Return empty query if incorrect reldep (rh#1687135)
+ ConfigParser: Improve compatibility with Python ConfigParser and dnf-plugin-spacewalk (rh#1692044)
+ ConfigParser: Unify default set of string represenation of boolean values
+ Fix segfault when interrupting dnf process (rh#1610456)
- Drop backported patches that are part of this release
* 0001-Reset-callback-to-NULL-RhBug-1637923.patch
* 0002-reldep-list-Add-glib-AUTOPTR-cleanup.patch
* 0003-swdb-Put-Swdb-constructors-together.patch
* 0004-utils-Drop-empty-else-block.patch
* 0005-transformer-Fix-minor-docstring-typo.patch
* 0006-repo-Squash-Wmaybe-uninitialized-warning.patch
* 0007-transaction-Consistently-use-the-same-swdb-variable.patch
* 0008-transaction-Minor-syntax-tweak.patch
* 0101-Zchunk-configuration-flags-were-backwards-so-setting.patch
* 0102-hy_repos-weren-t-being-filled-properly-when-using-zc.patch
- Refresh patches
* Remove patch: libdnf-0.24.1-with-static-libsolvext.patch
* Remove patch: libdnf-0.24.1-Switch-default-reposdir-to-etc-dnf-repos.d.patch
* Add patch: libdnf-0.28.1-with-static-libsolvext.patch
* Add patch: libdnf-0.28.1-Switch-default-reposdir-to-etc-dnf-repos.d.patch
2019-02-13 - Jan Engelhardt <jengelh@inai.de>
- Ensure neutrality of descriptions.
- Adjust RPM groups.
2019-02-13 - Neal Gompa <ngompa13@gmail.com>
- Fix cmake macro pointer to source tree
2019-02-07 - Neal Gompa <ngompa13@gmail.com>
- Switch default reposdir to /etc/dnf/repos.d
* Add patch: libdnf-0.24.1-Switch-default-reposdir-to-etc-dnf-repos.d.patch
2019-02-05 - Neal Gompa <ngompa13@gmail.com>
- Rebase to version 0.24.1
+ Add support for RH/Fedora modules
+ Add plugin support (unstable API)
+ Add zchunk support
+ Migrate from YUMDB to new SWDB
+ Rewrite into C++
- Drop Python 2 bindings
- Backport fixes from upstream eliminate various bugs
* 0001-Reset-callback-to-NULL-RhBug-1637923.patch
* 0002-reldep-list-Add-glib-AUTOPTR-cleanup.patch
* 0003-swdb-Put-Swdb-constructors-together.patch
* 0004-utils-Drop-empty-else-block.patch
* 0005-transformer-Fix-minor-docstring-typo.patch
* 0006-repo-Squash-Wmaybe-uninitialized-warning.patch
* 0007-transaction-Consistently-use-the-same-swdb-variable.patch
* 0008-transaction-Minor-syntax-tweak.patch
- Add proposed patches for improving zchunk support
* 0101-Zchunk-configuration-flags-were-backwards-so-setting.patch
* 0102-hy_repos-weren-t-being-filled-properly-when-using-zc.patch
- Refresh patch for linking to static libsolvext
* Remove patch: libdnf-0.9.3-with-static-libsolvext.patch
* Add patch: libdnf-0.24.1-with-static-libsolvext.patch
- Drop patch merged in upstream libdnf
* 0001-Add-multiversion-kernel-as-a-recognized-installonlyp.patch
2018-08-20 - Neal Gompa <ngompa13@gmail.com>
- Refresh patch to fix building against static libsolvext
- Switch to full author identities
2018-01-04 - Neal Gompa <ngompa13@gmail.com>
- Ensure SUSE kernel packages are recognized properly
* New patch: 0001-Add-multiversion-kernel-as-a-recognized-installonlyp.patch

See Also

Package Description
libdnf2-0.31.0-1.1.i586.rpm Library providing an interface atop libsolv
libdnf2-0.31.0-1.1.x86_64.rpm Library providing an interface atop libsolv
libdns169-32bit-9.11.2-44.1.x86_64.rpm DNS library used by BIND
libdns169-9.11.2-44.1.i586.rpm DNS library used by BIND
libdns169-9.11.2-44.1.x86_64.rpm DNS library used by BIND
libdns_sd-0.7-7.1.i586.rpm mDNSResponder Compatibility Package for the Zeroconf/Bonjour D-Bus service
libdns_sd-0.7-7.1.x86_64.rpm mDNSResponder Compatibility Package for the Zeroconf/Bonjour D-Bus service
libdns_sd-32bit-0.7-7.1.x86_64.rpm mDNSResponder Compatibility Package for the Zeroconf/Bonjour D-Bus service
libdolphinvcs5-19.04.0-1.1.i586.rpm KDE File Manager
libdolphinvcs5-19.04.0-1.1.x86_64.rpm KDE File Manager
libdotconf0-1.3-15.10.i586.rpm Configuration file parser library
libdotconf0-1.3-15.10.x86_64.rpm Configuration file parser library
libdouble-conversion2-3.0.3-1.1.i586.rpm Binary-decimal and decimal-binary routines for IEEE doubles
libdouble-conversion2-3.0.3-1.1.x86_64.rpm Binary-decimal and decimal-binary routines for IEEE doubles
libdouble-conversion2-32bit-3.0.3-1.1.x86_64.rpm Binary-decimal and decimal-binary routines for IEEE doubles
Advertisement
Advertisement