libcppunit_subunit0-devel-1.3.0-3.1.i586.rpm


Advertisement

Description

libcppunit_subunit0-devel - Header files for applications that use cppunit and subunit

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libcppunit_subunit0-devel-1.3.0-3.1.i586.rpm
Package name libcppunit_subunit0-devel
Package version 1.3.0
Package release 3.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage https://github.com/testing-cabal/subunit
License Apache-2.0 OR BSD-3-Clause
Maintainer -
Download size 11.34 KB
Installed size 3.79 KB
Header files and libraries for developing applications that use cppunit
and subunit.

Alternatives

Package Version Architecture Repository
libcppunit_subunit0-devel-1.3.0-3.1.x86_64.rpm 1.3.0 x86_64 openSUSE Oss
libcppunit_subunit0-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
cppunit-devel(x86-32) -
libcppunit_subunit0(x86-32) = 1.3.0-3.1
subunit-devel(x86-32) = 1.3.0-3.1

Provides

Name Value
libcppunit_subunit0-devel = 1.3.0-3.1
libcppunit_subunit0-devel(x86-32) = 1.3.0-3.1
pkgconfig(libcppunit_subunit) = 1.3.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libcppunit_subunit0-devel-1.3.0-3.1.i586.rpm
Source Package subunit-1.3.0-3.1.src.rpm

Install Howto

Install libcppunit_subunit0-devel rpm package:

# zypper install libcppunit_subunit0-devel

Files

Path
/usr/include/subunit/SubunitTestProgressListener.h
/usr/lib/libcppunit_subunit.so
/usr/lib/pkgconfig/libcppunit_subunit.pc
/usr/share/doc/packages/libcppunit_subunit0-devel/README

Changelog

2019-04-16 - Dirk Mueller <dmueller@suse.com>
- fix dependency for subunit-filters
2019-04-10 - Dirk Mueller <dmueller@suse.com>
- fix package naming of the python subpackages to follow
packaging policy
2019-04-08 - Dirk Mueller <dmueller@suse.com>
- add explicit unittest2 buildrequires
2019-04-06 - Dirk Mueller <dmueller@suse.com>
- add obsoletes
2019-04-06 - Dirk Mueller <dmueller@suse.com>
- drop subunit-unbundle-iso8601.patch: there is no room for fedora
specific patches in opensuse and the iso8601 pypi module is completely
incompatible with that this version, so nothing works
- remove-unittest2.patch, subunit-decode-binary-to-unicode.patch
needed to get it back to a working state
2019-04-06 - Dirk Mueller <dmueller@suse.com>
- fix build for older distros by adding the singlespec macros
2019-03-18 - Matej Cepl <mcepl@suse.com>
- Fix Requires
2019-03-12 - Matej Cepl <mcepl@suse.com>
- Just Obsolete, don't Conflict as well
2019-02-25 - Matej Cepl <mcepl@suse.com>
- Add Conflicts to python-* subpackages
2019-02-06 - Matej Cepl <mcepl@suse.com>
- Clean up the SPEC file and use more macros
- Add remove-unittest2.patch to remove necessity to use python-unittest2 BR.
- Change all URLs to the new location.

See Also

Package Description
libcpuid-devel-0.4.1-1.1.i586.rpm Development files for libcpuid
libcpuid-devel-0.4.1-1.1.x86_64.rpm Development files for libcpuid
libcpuid-tools-0.4.1-1.1.i586.rpm Tools based on libcpuid
libcpuid-tools-0.4.1-1.1.x86_64.rpm Tools based on libcpuid
libcpuid14-0.4.1-1.1.i586.rpm Library providing CPU identification for x86
libcpuid14-0.4.1-1.1.x86_64.rpm Library providing CPU identification for x86
libcpupower0-5.1-1.1.i586.rpm Obsolete processor frequency related C-library
libcpupower0-5.1-1.1.x86_64.rpm Obsolete processor frequency related C-library
libcpuset-devel-1.0-36.8.i586.rpm cpuset processor and memory placement library
libcpuset-devel-1.0-36.8.x86_64.rpm cpuset processor and memory placement library
libcpuset1-1.0-36.8.i586.rpm cpuset processor and memory placement library
libcpuset1-1.0-36.8.x86_64.rpm cpuset processor and memory placement library
libcrack2-2.9.6-2.9.i586.rpm Library to crack passwords using dictionaries
libcrack2-2.9.6-2.9.x86_64.rpm Library to crack passwords using dictionaries
libcrack2-32bit-2.9.6-2.9.x86_64.rpm Library to crack passwords using dictionaries
Advertisement
Advertisement