libcppunit_subunit0-1.3.0-3.1.x86_64.rpm


Advertisement

Description

libcppunit_subunit0 - Subunit integration into cppunit

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libcppunit_subunit0-1.3.0-3.1.x86_64.rpm
Package name libcppunit_subunit0
Package version 1.3.0
Package release 3.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://github.com/testing-cabal/subunit
License Apache-2.0 OR BSD-3-Clause
Maintainer -
Download size 13.14 KB
Installed size 18.34 KB
Subunit integration into cppunit.

Alternatives

Package Version Architecture Repository
libcppunit_subunit0-1.3.0-3.1.i586.rpm 1.3.0 i586 openSUSE Oss
libcppunit_subunit0 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
libcppunit-1.14.so.0()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libsubunit.so.0()(64bit) -
subunit(x86-64) >= 1.3.0-3.1

Provides

Name Value
libcppunit_subunit.so.0()(64bit) -
libcppunit_subunit0 = 1.3.0-3.1
libcppunit_subunit0(x86-64) = 1.3.0-3.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libcppunit_subunit0-1.3.0-3.1.x86_64.rpm
Source Package subunit-1.3.0-3.1.src.rpm

Install Howto

Install libcppunit_subunit0 rpm package:

# zypper install libcppunit_subunit0

Files

Path
/usr/lib64/libcppunit_subunit.so.0
/usr/lib64/libcppunit_subunit.so.0.0.0

Changelog

2019-04-16 - Dirk Mueller <dmueller@suse.com>
- fix dependency for subunit-filters
2019-04-10 - Dirk Mueller <dmueller@suse.com>
- fix package naming of the python subpackages to follow
packaging policy
2019-04-08 - Dirk Mueller <dmueller@suse.com>
- add explicit unittest2 buildrequires
2019-04-06 - Dirk Mueller <dmueller@suse.com>
- add obsoletes
2019-04-06 - Dirk Mueller <dmueller@suse.com>
- drop subunit-unbundle-iso8601.patch: there is no room for fedora
specific patches in opensuse and the iso8601 pypi module is completely
incompatible with that this version, so nothing works
- remove-unittest2.patch, subunit-decode-binary-to-unicode.patch
needed to get it back to a working state
2019-04-06 - Dirk Mueller <dmueller@suse.com>
- fix build for older distros by adding the singlespec macros
2019-03-18 - Matej Cepl <mcepl@suse.com>
- Fix Requires
2019-03-12 - Matej Cepl <mcepl@suse.com>
- Just Obsolete, don't Conflict as well
2019-02-25 - Matej Cepl <mcepl@suse.com>
- Add Conflicts to python-* subpackages
2019-02-06 - Matej Cepl <mcepl@suse.com>
- Clean up the SPEC file and use more macros
- Add remove-unittest2.patch to remove necessity to use python-unittest2 BR.
- Change all URLs to the new location.

See Also

Package Description
libcppunit_subunit0-devel-1.3.0-3.1.i586.rpm Header files for applications that use cppunit and subunit
libcppunit_subunit0-devel-1.3.0-3.1.x86_64.rpm Header files for applications that use cppunit and subunit
libcpuid-devel-0.4.1-1.1.i586.rpm Development files for libcpuid
libcpuid-devel-0.4.1-1.1.x86_64.rpm Development files for libcpuid
libcpuid-tools-0.4.1-1.1.i586.rpm Tools based on libcpuid
libcpuid-tools-0.4.1-1.1.x86_64.rpm Tools based on libcpuid
libcpuid14-0.4.1-1.1.i586.rpm Library providing CPU identification for x86
libcpuid14-0.4.1-1.1.x86_64.rpm Library providing CPU identification for x86
libcpupower0-5.1-1.1.i586.rpm Obsolete processor frequency related C-library
libcpupower0-5.1-1.1.x86_64.rpm Obsolete processor frequency related C-library
libcpuset-devel-1.0-36.8.i586.rpm cpuset processor and memory placement library
libcpuset-devel-1.0-36.8.x86_64.rpm cpuset processor and memory placement library
libcpuset1-1.0-36.8.i586.rpm cpuset processor and memory placement library
libcpuset1-1.0-36.8.x86_64.rpm cpuset processor and memory placement library
libcrack2-2.9.6-2.9.i586.rpm Library to crack passwords using dictionaries
Advertisement
Advertisement