libbfio1-0~20190112-1.1.i586.rpm


Advertisement

Description

libbfio1 - Library to provide basic file input/output abstraction

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libbfio1-0~20190112-1.1.i586.rpm
Package name libbfio1
Package version 0~20190112
Package release 1.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage https://github.com/libyal/libbfio/wiki
License LGPL-3.0-or-later
Maintainer -
Download size 36.53 KB
Installed size 110.46 KB
libbfio is used in multiple other libraries like libewf, libmsiecf,
libnk2, libolecf and libpff. It is used to chain I/O to support
file-in-file access.

Alternatives

Package Version Architecture Repository
libbfio1-0~20190112-1.1.x86_64.rpm 0~20190112 x86_64 openSUSE Oss
libbfio1 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libcdata.so.1 -
libcerror.so.1 -
libcfile.so.1 -
libclocale.so.1 -
libcpath.so.1 -
libcthreads.so.1 -
libuna.so.1 -

Provides

Name Value
libbfio.so.1 -
libbfio1 = 0~20190112-1.1
libbfio1(x86-32) = 0~20190112-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libbfio1-0~20190112-1.1.i586.rpm
Source Package libbfio-0~20190112-1.1.src.rpm

Install Howto

Install libbfio1 rpm package:

# zypper install libbfio1

Files

Path
/usr/lib/libbfio.so.1
/usr/lib/libbfio.so.1.0.0
/usr/share/doc/packages/libbfio1/AUTHORS
/usr/share/doc/packages/libbfio1/ChangeLog
/usr/share/licenses/libbfio1/COPYING

Changelog

2019-04-02 - Greg Freemyer <Greg.Freemyer@gmail.com>
- update to v0~20190112
* Additional restrictions for memory tests
* Changes for latest version of libcdata
2017-02-15 - Greg.Freemyer@gmail.com
- update to v0~20170123
* no changelog provided
- use libcstring from factory
2016-01-29 - Greg.Freemyer@gmail.com
- update to v0~20160108
* changes to seek
* added function to remove handle from pool
* 2016 update
* merged history from backups
* updated m4 scripts and msvscpp files
* update man page: libbfio.3
2015-01-06 - Greg.Freemyer@gmail.com
- update to v0~20150101
* 2015 update - minimal changes
- update URL to the new github site
- replace Source: field with fully defined URL
- remove DL-URL comment
- start using libcerror from OBS, not internal version
- continue to use internal version of libcstring
2014-08-14 - Greg.Freemyer@gmail.com
- update to v0~20140105
* 2014 update
* updated dependencies
2013-10-23 - Greg.Freemyer@gmail.com
- update to v0~20131003
2013-10-03 - Greg.Freemyer@gmail.com
- update to v0~20130908
* worked on tests
* updated dependencies
- updated dependencies in specfile
2013-07-29 - Greg.Freemyer@gmail.com
- update to v0~20130721
* worked on multi threading support
* removed open on demand code from seek offset
* refactored pool to use a cdata array
* worked on tests
* updated dependencies
* fix for compiling with stand-alone version of libcdata
* fix in .pc.in file
* worked on git release
* moved examples to project page
* removed codegear files
* remove libbfio_legacy.[ch]
* 2013 update
- change to gz compression to simplyfy download/convert step
2013-04-22 - Greg.Freemyer@gmail.com
- run spec-cleaner, update comment
2013-04-03 - jengelh@inai.de
- Initial package (version 0~20121225) for build.opensuse.org

See Also

Package Description
libbiblesync2_0-2.0.1-2.2.i586.rpm A library for sharing Bible navigation
libbiblesync2_0-2.0.1-2.2.x86_64.rpm A library for sharing Bible navigation
libbind9-160-32bit-9.11.2-44.1.x86_64.rpm BIND9 shared library used by BIND
libbind9-160-9.11.2-44.1.i586.rpm BIND9 shared library used by BIND
libbind9-160-9.11.2-44.1.x86_64.rpm BIND9 shared library used by BIND
libbitcoinconsensus-devel-0.16.3-1.1.i586.rpm Developmont files for bitcoin consensus library
libbitcoinconsensus-devel-0.17.1-1.1.x86_64.rpm Developmont files for bitcoin consensus library
libbitcoinconsensus0-0.16.3-1.1.i586.rpm Bitcoin consensus library
libbitcoinconsensus0-0.17.1-1.1.x86_64.rpm Bitcoin consensus library
libbitmask-devel-2.0-28.14.i586.rpm Multi-word bitmask abstract data type (used by cpusets)
libbitmask-devel-2.0-28.14.x86_64.rpm Multi-word bitmask abstract data type (used by cpusets)
libbitmask1-2.0-28.14.i586.rpm Multi-word bitmask abstract data type (used by cpusets)
libbitmask1-2.0-28.14.x86_64.rpm Multi-word bitmask abstract data type (used by cpusets)
libblacs2-gnu-mpich-hpc-2.0.2-11.2.i586.rpm Dependency package for libblacs2_2_0_2-gnu-mpich-hpc
libblacs2-gnu-mpich-hpc-2.0.2-11.2.x86_64.rpm Dependency package for libblacs2_2_0_2-gnu-mpich-hpc
Advertisement
Advertisement