libQt5WebKitWidgets-private-headers-devel-5.212~alpha2-6.6.noarch.rpm


Advertisement

Description

libQt5WebKitWidgets-private-headers-devel - Non-ABI stable experimental API for the Qt5 WebKit Widgets library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libQt5WebKitWidgets-private-headers-devel-5.212~alpha2-6.6.noarch.rpm
Package name libQt5WebKitWidgets-private-headers-devel
Package version 5.212~alpha2
Package release 6.6
Package architecture noarch
Package type rpm
Category Development/Libraries/C and C++
Homepage https://www.qt.io
License LGPL-2.1+
Maintainer -
Download size 26.61 KB
Installed size 40.09 KB
This package provides private headers of libqt5-qtwebkit that are normally
not used by application development and that do not have any ABI or
API guarantees. The packages that build against these have to require
the exact Qt version.

Alternatives

Package Version Architecture Repository
libQt5WebKitWidgets-private-headers-devel-5.212~alpha2-9.28.noarch.rpm 5.212~alpha2 noarch KDE 5
libQt5WebKitWidgets-private-headers-devel-5.212~alpha2-ku.12.22.noarch.rpm 5.212~alpha2 noarch KDE Unstable
libQt5WebKitWidgets-private-headers-devel - - -

Requires

Name Value
libQt5WebKit-private-headers-devel = 5.212~alpha2
libQt5WebKitWidgets-devel = 5.212~alpha2

Provides

Name Value
libQt5WebKitWidgets-private-headers-devel = 5.212~alpha2-6.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libQt5WebKitWidgets-private-headers-devel-5.212~alpha2-6.6.noarch.rpm
Source Package libqt5-qtwebkit-5.212~alpha2-6.6.src.rpm

Install Howto

Install libQt5WebKitWidgets-private-headers-devel rpm package:

# zypper install libQt5WebKitWidgets-private-headers-devel

Files

Path
/usr/include/qt5/QtWebKitWidgets/5.212.0/
/usr/include/qt5/QtWebKitWidgets/5.212.0/QtWebKitWidgets/
/usr/include/qt5/QtWebKitWidgets/5.212.0/QtWebKitWidgets/private/qwebframe_p.h
/usr/include/qt5/QtWebKitWidgets/5.212.0/QtWebKitWidgets/private/qwebinspector_p.h
/usr/include/qt5/QtWebKitWidgets/5.212.0/QtWebKitWidgets/private/qwebpage_p.h
/usr/include/qt5/QtWebKitWidgets/5.212.0/QtWebKitWidgets/private/qwebviewaccessible_p.h
/usr/share/doc/packages/libQt5WebKitWidgets-private-headers-devel/LICENSE.LGPLv21

Changelog

2018-12-03 - Guillaume GARDET <guillaume.gardet@opensuse.org>
- Add patch to fix armv6 build:
* fix_armv6.patch
2018-06-17 - mlin@suse.com
- Add -fpermissive to workaround build error with gcc8
2018-03-09 - stefan.bruens@rwth-aachen.de
- Set minimum amount of RAM in _constraints to 8 GiB for aarch64,
use the default value of 6 GiB for armv7/armv6
2018-03-01 - wbauer@tmo.at
- Add upstream patches to fix broken layout of plain-text mails in
Trojita (boo#1083451):
* Trigger-layout-after-resizing-the-FrameView.patch
* run-adjustViewSize-after-relayout.patch
2018-02-23 - mlin@suse.com
- Re-ordering patches
- Add fix-nullptr-crash-in-QWebPage-selectedHtml-when-selectedRange.patch
* Fix crash in QWebPage::selectedHtml() when selectedRange is nullptr
- Add fix-nullTerminatedWCharToString-loses-last-character.patch
* Fix nullTerminatedWCharToString loses last character of input string
2018-02-15 - fabian@ritter-vogt.de
- Use gcc-7 on 42.3 to fix mismatch with the optflags
2017-12-20 - mlin@suse.com
- Add patch to fix build failure with CMake 3.10
* fix-build-with-cmake-3.10.diff
- Use Gstreamer for audio/video support optional
2017-12-12 - fvogt@suse.com
- Add patch to keep the same private symbol version scheme:
* tell-the-truth-about-private-api.patch
- Add patch to fix detection of OpenGL ES 2.0 with Qt >= 5.8:
* fix-gles-detection.patch
- Add patch to enable symbol versioning for libQt5WebKit.so.5 as well:
* qt5webkit-symver.patch
2017-12-12 - mlin@suse.com
- Ported to Konstantin Tokarev's <annulen@yandex.ru> QtWebKit fork
version 5.212.0 Alpha 2 (FATE#323918, bsc#1050469)
* Based on WebKitGTK 2.12 (uses CMake instead of QMake)
* Newer WebKit base
* Improved support for web standards
* Many bugfixes and patched security holes inherited from upstream WebKit
* For more details please see:
https://github.com/annulen/webkit/releases/tag/qtwebkit-5.212.0-alpha
and
https://github.com/annulen/webkit/releases/tag/qtwebkit-5.212.0-alpha2
- Drop unneeded patches
* 03_hide_std_symbols.diff
* 04_enable_debug_information.diff
* 05-fix-linker-errors.diff
* 7dac8c2d5f743563df76c2347c6ad394b6779ffc.patch
* fix-build-icu59.patch
* no-Werror-rpath.diff
* reduce-link-optimization.diff
* workaround-gcc7-crash.patch
- Set minimum amount of RAM in _constraints to 10 GiB for x86_64
- Add patch to always enable X11 target build:
* enable_x11_target_always.patch
- Add patch to work around gcc7-related crash:
* webkit-fix-WTF-StringImpl-copyChars-segfaults-with-gcc7.patch
- Corrected License tag. QtWebKit is just LGPL-2.1+ and does not follow Qt's
commercial-inspired licensing scheme of (L)GPLv3-only.
2017-12-08 - christophe@krop.fr
- Update the license tag (boo#967696)

See Also

Package Description
libQt5WebKitWidgets5-32bit-5.212~alpha2-6.6.x86_64.rpm Qt 5 WebKit Widget library
libQt5WebKitWidgets5-5.212~alpha2-6.6.i586.rpm Qt 5 WebKit Widget library
libQt5WebKitWidgets5-5.212~alpha2-6.6.x86_64.rpm Qt 5 WebKit Widget library
libQt5WebSockets5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 WebSockets Library
libQt5WebSockets5-5.12.3-1.1.i586.rpm Qt 5 WebSockets Library
libQt5WebSockets5-5.12.3-1.1.x86_64.rpm Qt 5 WebSockets Library
libQt5WebSockets5-imports-5.12.3-1.1.i586.rpm QML imports for the Qt 5 WebSockets library
libQt5WebSockets5-imports-5.12.3-1.1.x86_64.rpm QML imports for the Qt 5 WebSockets library
libQt5WebView5-5.12.3-1.1.i586.rpm Qt 5 WebView Library
libQt5WebView5-5.12.3-1.1.x86_64.rpm Qt 5 WebView Library
libQt5WebView5-imports-5.12.3-1.1.i586.rpm Qt 5 WebView Library - QML imports
libQt5WebView5-imports-5.12.3-1.1.x86_64.rpm Qt 5 WebView Library - QML imports
libQt5Widgets-devel-32bit-5.12.3-1.1.x86_64.rpm Development files for the Qt5 widgets library
libQt5Widgets-devel-5.12.3-1.1.i586.rpm Development files for the Qt5 widgets library
libQt5Widgets-devel-5.12.3-1.1.x86_64.rpm Development files for the Qt5 widgets library
Advertisement
Advertisement