libQt5WebKit5-5.212~alpha2-6.6.i586.rpm


Advertisement

Description

libQt5WebKit5 - Qt5 WebKit Library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libQt5WebKit5-5.212~alpha2-6.6.i586.rpm
Package name libQt5WebKit5
Package version 5.212~alpha2
Package release 6.6
Package architecture i586
Package type rpm
Category Development/Libraries/X11
Homepage https://www.qt.io
License LGPL-2.1+
Maintainer -
Download size 12.01 MB
Installed size 46.65 MB
You need this package if you want to compile programs with qtwebkit.

Alternatives

Package Version Architecture Repository
libQt5WebKit5-5.212~alpha2-9.28.x86_64.rpm 5.212~alpha2 x86_64 KDE 5
libQt5WebKit5-5.212~alpha2-9.28.i586.rpm 5.212~alpha2 i586 KDE 5
libQt5WebKit5-5.212~alpha2-6.6.x86_64.rpm 5.212~alpha2 x86_64 openSUSE Oss
libQt5WebKit5-5.212~alpha2-ku.12.22.x86_64.rpm 5.212~alpha2 x86_64 KDE Unstable
libQt5WebKit5-5.212~alpha2-ku.12.22.i586.rpm 5.212~alpha2 i586 KDE Unstable
libQt5WebKit5 - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.12) -
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libQt5Gui.so.5(Qt_5.12.3_PRIVATE_API) -
libQt5Network.so.5 -
libQt5Network.so.5(Qt_5) -
libQt5Positioning.so.5 -
libQt5Positioning.so.5(Qt_5) -
libQt5Qml.so.5 -
libQt5Qml.so.5(Qt_5) -
libQt5Quick.so.5 -
libQt5Quick.so.5(Qt_5) -
libQt5Quick.so.5(Qt_5.12.3_PRIVATE_API) -
libQt5Sensors.so.5 -
libQt5Sensors.so.5(Qt_5) -
libQt5WebChannel.so.5 -
libQt5WebChannel.so.5(Qt_5) -
libX11.so.6 -
libc.so.6(GLIBC_2.28) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_4.0.0) -
libgcc_s.so.1(GCC_7.0.0) -
libgcc_s.so.1(GLIBC_2.0) -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgstapp-1.0.so.0 -
libgstaudio-1.0.so.0 -
libgstbase-1.0.so.0 -
libgstfft-1.0.so.0 -
libgstpbutils-1.0.so.0 -
libgstreamer-1.0.so.0 -
libgsttag-1.0.so.0 -
libgstvideo-1.0.so.0 -
libhyphen.so.0 -
libicui18n.so.suse64.2 -
libicuuc.so.suse64.2 -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libm.so.6(GLIBC_2.27) -
libm.so.6(GLIBC_2.29) -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.2.3) -
libpthread.so.0(GLIBC_2.3.2) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libsqlite3.so.0 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.19) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.22) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libwebp.so.7 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.6.0) -
libxml2.so.2(LIBXML2_2.6.6) -
libxslt.so.1 -
libxslt.so.1(LIBXML2_1.0.11) -
libxslt.so.1(LIBXML2_1.0.22) -
libxslt.so.1(LIBXML2_1.0.24) -
libxslt.so.1(LIBXML2_1.1.9) -
libz.so.1 -
libz.so.1(ZLIB_1.2.0) -

Provides

Name Value
libQt5WebKit.so.5 -
libQt5WebKit.so.5(Qt_5) -
libQt5WebKit.so.5(Qt_5.0) -
libQt5WebKit.so.5(Qt_5.1) -
libQt5WebKit.so.5(Qt_5.10) -
libQt5WebKit.so.5(Qt_5.11) -
libQt5WebKit.so.5(Qt_5.12) -
libQt5WebKit.so.5(Qt_5.12.3_PRIVATE_API) -
libQt5WebKit.so.5(Qt_5.2) -
libQt5WebKit.so.5(Qt_5.3) -
libQt5WebKit.so.5(Qt_5.4) -
libQt5WebKit.so.5(Qt_5.5) -
libQt5WebKit.so.5(Qt_5.6) -
libQt5WebKit.so.5(Qt_5.7) -
libQt5WebKit.so.5(Qt_5.8) -
libQt5WebKit.so.5(Qt_5.9) -
libQt5WebKit5 = 5.212~alpha2-6.6
libQt5WebKit5(x86-32) = 5.212~alpha2-6.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libQt5WebKit5-5.212~alpha2-6.6.i586.rpm
Source Package libqt5-qtwebkit-5.212~alpha2-6.6.src.rpm

Install Howto

Install libQt5WebKit5 rpm package:

# zypper install libQt5WebKit5

Files

Path
/usr/lib/libQt5WebKit.so.5
/usr/lib/libQt5WebKit.so.5.212.0
/usr/lib/qt5/libexec/QtWebDatabaseProcess
/usr/lib/qt5/libexec/QtWebNetworkProcess
/usr/lib/qt5/libexec/QtWebPluginProcess
/usr/share/doc/packages/libQt5WebKit5/LICENSE.LGPLv21

Changelog

2018-12-03 - Guillaume GARDET <guillaume.gardet@opensuse.org>
- Add patch to fix armv6 build:
* fix_armv6.patch
2018-06-17 - mlin@suse.com
- Add -fpermissive to workaround build error with gcc8
2018-03-09 - stefan.bruens@rwth-aachen.de
- Set minimum amount of RAM in _constraints to 8 GiB for aarch64,
use the default value of 6 GiB for armv7/armv6
2018-03-01 - wbauer@tmo.at
- Add upstream patches to fix broken layout of plain-text mails in
Trojita (boo#1083451):
* Trigger-layout-after-resizing-the-FrameView.patch
* run-adjustViewSize-after-relayout.patch
2018-02-23 - mlin@suse.com
- Re-ordering patches
- Add fix-nullptr-crash-in-QWebPage-selectedHtml-when-selectedRange.patch
* Fix crash in QWebPage::selectedHtml() when selectedRange is nullptr
- Add fix-nullTerminatedWCharToString-loses-last-character.patch
* Fix nullTerminatedWCharToString loses last character of input string
2018-02-15 - fabian@ritter-vogt.de
- Use gcc-7 on 42.3 to fix mismatch with the optflags
2017-12-20 - mlin@suse.com
- Add patch to fix build failure with CMake 3.10
* fix-build-with-cmake-3.10.diff
- Use Gstreamer for audio/video support optional
2017-12-12 - fvogt@suse.com
- Add patch to keep the same private symbol version scheme:
* tell-the-truth-about-private-api.patch
- Add patch to fix detection of OpenGL ES 2.0 with Qt >= 5.8:
* fix-gles-detection.patch
- Add patch to enable symbol versioning for libQt5WebKit.so.5 as well:
* qt5webkit-symver.patch
2017-12-12 - mlin@suse.com
- Ported to Konstantin Tokarev's <annulen@yandex.ru> QtWebKit fork
version 5.212.0 Alpha 2 (FATE#323918, bsc#1050469)
* Based on WebKitGTK 2.12 (uses CMake instead of QMake)
* Newer WebKit base
* Improved support for web standards
* Many bugfixes and patched security holes inherited from upstream WebKit
* For more details please see:
https://github.com/annulen/webkit/releases/tag/qtwebkit-5.212.0-alpha
and
https://github.com/annulen/webkit/releases/tag/qtwebkit-5.212.0-alpha2
- Drop unneeded patches
* 03_hide_std_symbols.diff
* 04_enable_debug_information.diff
* 05-fix-linker-errors.diff
* 7dac8c2d5f743563df76c2347c6ad394b6779ffc.patch
* fix-build-icu59.patch
* no-Werror-rpath.diff
* reduce-link-optimization.diff
* workaround-gcc7-crash.patch
- Set minimum amount of RAM in _constraints to 10 GiB for x86_64
- Add patch to always enable X11 target build:
* enable_x11_target_always.patch
- Add patch to work around gcc7-related crash:
* webkit-fix-WTF-StringImpl-copyChars-segfaults-with-gcc7.patch
- Corrected License tag. QtWebKit is just LGPL-2.1+ and does not follow Qt's
commercial-inspired licensing scheme of (L)GPLv3-only.
2017-12-08 - christophe@krop.fr
- Update the license tag (boo#967696)

See Also

Package Description
libQt5WebKit5-devel-32bit-5.212~alpha2-6.6.x86_64.rpm Development files for the Qt5 WebKit library
libQt5WebKit5-devel-5.212~alpha2-6.6.i586.rpm Development files for the Qt5 WebKit library
libQt5WebKit5-devel-5.212~alpha2-6.6.x86_64.rpm Development files for the Qt5 WebKit library
libQt5WebKit5-imports-5.212~alpha2-6.6.i586.rpm QML imports for the Qt5 WebKit library
libQt5WebKit5-imports-5.212~alpha2-6.6.x86_64.rpm QML imports for the Qt5 WebKit library
libQt5WebKitWidgets-devel-32bit-5.212~alpha2-6.6.x86_64.rpm Development files for the Qt5 WebKit Widgets library
libQt5WebKitWidgets-devel-5.212~alpha2-6.6.i586.rpm Development files for the Qt5 WebKit Widgets library
libQt5WebKitWidgets-devel-5.212~alpha2-6.6.x86_64.rpm Development files for the Qt5 WebKit Widgets library
libQt5WebKitWidgets-private-headers-devel-5.212~alpha2-6.6.noarch.rpm Non-ABI stable experimental API for the Qt5 WebKit Widgets library
libQt5WebKitWidgets5-32bit-5.212~alpha2-6.6.x86_64.rpm Qt 5 WebKit Widget library
libQt5WebKitWidgets5-5.212~alpha2-6.6.i586.rpm Qt 5 WebKit Widget library
libQt5WebKitWidgets5-5.212~alpha2-6.6.x86_64.rpm Qt 5 WebKit Widget library
libQt5WebSockets5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 WebSockets Library
libQt5WebSockets5-5.12.3-1.1.i586.rpm Qt 5 WebSockets Library
libQt5WebSockets5-5.12.3-1.1.x86_64.rpm Qt 5 WebSockets Library
Advertisement
Advertisement