libQt5WaylandClient5-5.12.3-1.1.x86_64.rpm


Advertisement

Description

libQt5WaylandClient5 - Qt 5 Wayland Addon

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libQt5WaylandClient5-5.12.3-1.1.x86_64.rpm
Package name libQt5WaylandClient5
Package version 5.12.3
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://www.qt.io
License LGPL-2.1-with-Qt-Company-Qt-exception-1.1 or LGPL-3.0-only
Maintainer -
Download size 292.63 KB
Installed size 1.08 MB
Qt is a set of libraries for developing applications.

Alternatives

Package Version Architecture Repository
libQt5WaylandClient5-5.12.3-1.1.i586.rpm 5.12.3 i586 openSUSE Oss
libQt5WaylandClient5-5.12.3-1.1.x86_64.rpm 5.12.3 x86_64 KDE 5
libQt5WaylandClient5-5.12.3-1.1.i586.rpm 5.12.3 i586 KDE 5
libQt5WaylandClient5-5.12.3-ku.1.1.x86_64.rpm 5.12.3 x86_64 KDE Unstable
libQt5WaylandClient5-5.12.3-ku.1.1.i586.rpm 5.12.3 i586 KDE Unstable
libQt5WaylandClient5 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Core.so.5(Qt_5.12.3_PRIVATE_API)(64bit) -
libQt5DBus.so.5()(64bit) -
libQt5DBus.so.5(Qt_5)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Gui.so.5(Qt_5.12.3_PRIVATE_API)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libfontconfig.so.1()(64bit) -
libfreetype.so.6()(64bit) -
libglib-2.0.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libwayland-client.so.0()(64bit) -
libwayland-cursor.so.0()(64bit) -
libxkbcommon.so.0()(64bit) -
libxkbcommon.so.0(V_0.5.0)(64bit) -

Provides

Name Value
libQt5WaylandClient.so.5()(64bit) -
libQt5WaylandClient.so.5(Qt_5)(64bit) -
libQt5WaylandClient.so.5(Qt_5.0)(64bit) -
libQt5WaylandClient.so.5(Qt_5.1)(64bit) -
libQt5WaylandClient.so.5(Qt_5.10)(64bit) -
libQt5WaylandClient.so.5(Qt_5.11)(64bit) -
libQt5WaylandClient.so.5(Qt_5.12)(64bit) -
libQt5WaylandClient.so.5(Qt_5.12.3_PRIVATE_API)(64bit) -
libQt5WaylandClient.so.5(Qt_5.2)(64bit) -
libQt5WaylandClient.so.5(Qt_5.3)(64bit) -
libQt5WaylandClient.so.5(Qt_5.4)(64bit) -
libQt5WaylandClient.so.5(Qt_5.5)(64bit) -
libQt5WaylandClient.so.5(Qt_5.6)(64bit) -
libQt5WaylandClient.so.5(Qt_5.7)(64bit) -
libQt5WaylandClient.so.5(Qt_5.8)(64bit) -
libQt5WaylandClient.so.5(Qt_5.9)(64bit) -
libQt5WaylandClient5 = 5.12.3-1.1
libQt5WaylandClient5(x86-64) = 5.12.3-1.1

Conflicts

Name Value
qtwayland -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libQt5WaylandClient5-5.12.3-1.1.x86_64.rpm
Source Package libqt5-qtwayland-5.12.3-1.1.src.rpm

Install Howto

Install libQt5WaylandClient5 rpm package:

# zypper install libQt5WaylandClient5

Files

Path
/usr/lib64/libQt5WaylandClient.so.5
/usr/lib64/libQt5WaylandClient.so.5.12
/usr/lib64/libQt5WaylandClient.so.5.12.3
/usr/share/doc/packages/libQt5WaylandClient5/LICENSE.FDL
/usr/share/doc/packages/libQt5WaylandClient5/LICENSE.GPL2
/usr/share/doc/packages/libQt5WaylandClient5/LICENSE.GPL3
/usr/share/doc/packages/libQt5WaylandClient5/LICENSE.GPL3-EXCEPT
/usr/share/doc/packages/libQt5WaylandClient5/LICENSE.LGPL3

Changelog

2019-04-18 - fabian@ritter-vogt.de
- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.12.3/?h=v5.12.3
2019-03-14 - fabian@ritter-vogt.de
- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.12.2/?h=5.12.2
2019-02-01 - fabian@ritter-vogt.de
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.12.1/?h=v5.12.1
2018-12-06 - fabian@ritter-vogt.de
- Update to 5.12.0:
* New feature release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.12.0/?h=v5.12.0
2018-12-03 - fabian@ritter-vogt.de
- Update to 5.12.0-rc2:
* New bugfix release
* Only important bugfixes
- Changelog for Qt 5.12.0:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.12.0/?h=5.12.0
2018-11-22 - fabian@ritter-vogt.de
- Update to 5.12.0-rc:
* New bugfix release
* No changelog available
2018-11-08 - fabian@ritter-vogt.de
- Update to 5.12.0-beta4:
* New bugfix release
* No changelog available
2018-10-26 - fabian@ritter-vogt.de
- Update to 5.12.0-beta3:
* New bugfix release
* No changelog available
2018-10-17 - fabian@ritter-vogt.de
- Update to 5.12.0-beta2:
* New bugfix release
* No changelog available
- Remove patches, now upstream:
* 0001-Avoid-spurious-move-events-after-configure-call.patch
2018-10-08 - fabian@ritter-vogt.de
- Add patch to fix window geometry in specific situations:
* 0001-Avoid-spurious-move-events-after-configure-call.patch

See Also

Package Description
libQt5WaylandCompositor5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 Wayland Addon
libQt5WaylandCompositor5-5.12.3-1.1.i586.rpm Qt 5 Wayland Addon
libQt5WaylandCompositor5-5.12.3-1.1.x86_64.rpm Qt 5 Wayland Addon
libQt5WebChannel5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 WebChannel Addon
libQt5WebChannel5-5.12.3-1.1.i586.rpm Qt 5 WebChannel Addon
libQt5WebChannel5-5.12.3-1.1.x86_64.rpm Qt 5 WebChannel Addon
libQt5WebChannel5-imports-5.12.3-1.1.i586.rpm QML imports for the Qt5 WebSockets library
libQt5WebChannel5-imports-5.12.3-1.1.x86_64.rpm QML imports for the Qt5 WebSockets library
libQt5WebKit-private-headers-devel-5.212~alpha2-6.6.noarch.rpm Non-ABI stable experimental API for the Qt5 WebKit library
libQt5WebKit5-32bit-5.212~alpha2-6.6.x86_64.rpm Qt5 WebKit Library
libQt5WebKit5-5.212~alpha2-6.6.i586.rpm Qt5 WebKit Library
libQt5WebKit5-5.212~alpha2-6.6.x86_64.rpm Qt5 WebKit Library
libQt5WebKit5-devel-32bit-5.212~alpha2-6.6.x86_64.rpm Development files for the Qt5 WebKit library
libQt5WebKit5-devel-5.212~alpha2-6.6.i586.rpm Development files for the Qt5 WebKit library
libQt5WebKit5-devel-5.212~alpha2-6.6.x86_64.rpm Development files for the Qt5 WebKit library
Advertisement
Advertisement