libQt5Sql-devel-5.12.3-1.1.x86_64.rpm


Advertisement

Description

libQt5Sql-devel - Development files for the Qt5 SQL library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libQt5Sql-devel-5.12.3-1.1.x86_64.rpm
Package name libQt5Sql-devel
Package version 5.12.3
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://www.qt.io
License LGPL-2.1-with-Qt-Company-Qt-exception-1.1 or LGPL-3.0-only
Maintainer -
Download size 111.61 KB
Installed size 256.45 KB
Qt 5 libraries which are used for connection with an SQL server. You
will need also a plugin package for a supported SQL server.

Alternatives

Package Version Architecture Repository
libQt5Sql-devel-5.12.3-1.4.x86_64.rpm 5.12.3 x86_64 KDE 5
libQt5Sql-devel-5.12.3-1.4.i586.rpm 5.12.3 i586 KDE 5
libQt5Sql-devel-5.12.3-1.1.i586.rpm 5.12.3 i586 openSUSE Oss
libQt5Sql-devel-5.12.3-ku.1.1.x86_64.rpm 5.12.3 x86_64 KDE Unstable
libQt5Sql-devel-5.12.3-ku.1.1.i586.rpm 5.12.3 i586 KDE Unstable
libQt5Sql-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libQt5Core-devel = 5.12.3
libQt5Sql5 = 5.12.3
pkgconfig(Qt5Core) -

Provides

Name Value
cmake(Qt5Sql) = 5.12.3
libQt5Sql-devel = 5.12.3-1.1
libQt5Sql-devel(x86-64) = 5.12.3-1.1
pkgconfig(Qt5Sql) = 5.12.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libQt5Sql-devel-5.12.3-1.1.x86_64.rpm
Source Package libqt5-qtbase-5.12.3-1.1.src.rpm

Install Howto

Install libQt5Sql-devel rpm package:

# zypper install libQt5Sql-devel

Files

Path
/usr/include/qt5/QtSql/QSql
/usr/include/qt5/QtSql/QSqlDatabase
/usr/include/qt5/QtSql/QSqlDriver
/usr/include/qt5/QtSql/QSqlDriverCreator
/usr/include/qt5/QtSql/QSqlDriverCreatorBase
/usr/include/qt5/QtSql/QSqlDriverPlugin
/usr/include/qt5/QtSql/QSqlError
/usr/include/qt5/QtSql/QSqlField
/usr/include/qt5/QtSql/QSqlIndex
/usr/include/qt5/QtSql/QSqlQuery
/usr/include/qt5/QtSql/QSqlQueryModel
/usr/include/qt5/QtSql/QSqlRecord
/usr/include/qt5/QtSql/QSqlRelation
/usr/include/qt5/QtSql/QSqlRelationalDelegate
/usr/include/qt5/QtSql/QSqlRelationalTableModel
/usr/include/qt5/QtSql/QSqlResult
/usr/include/qt5/QtSql/QSqlTableModel
/usr/include/qt5/QtSql/QtSql
/usr/include/qt5/QtSql/QtSqlDepends
/usr/include/qt5/QtSql/QtSqlVersion
/usr/include/qt5/QtSql/qsql.h
/usr/include/qt5/QtSql/qsqldatabase.h
/usr/include/qt5/QtSql/qsqldriver.h
/usr/include/qt5/QtSql/qsqldriverplugin.h
/usr/include/qt5/QtSql/qsqlerror.h
/usr/include/qt5/QtSql/qsqlfield.h
/usr/include/qt5/QtSql/qsqlindex.h
/usr/include/qt5/QtSql/qsqlquery.h
/usr/include/qt5/QtSql/qsqlquerymodel.h
/usr/include/qt5/QtSql/qsqlrecord.h
/usr/include/qt5/QtSql/qsqlrelationaldelegate.h
/usr/include/qt5/QtSql/qsqlrelationaltablemodel.h
/usr/include/qt5/QtSql/qsqlresult.h
/usr/include/qt5/QtSql/qsqltablemodel.h
/usr/include/qt5/QtSql/qtsql-config.h
/usr/include/qt5/QtSql/qtsqlglobal.h
/usr/include/qt5/QtSql/qtsqlversion.h
/usr/lib64/libQt5Sql.prl
/usr/lib64/libQt5Sql.so
/usr/lib64/cmake/Qt5Sql/Qt5SqlConfig.cmake
/usr/lib64/cmake/Qt5Sql/Qt5SqlConfigVersion.cmake
/usr/lib64/pkgconfig/Qt5Sql.pc
/usr/share/doc/packages/libQt5Sql-devel/config_help.txt
/usr/share/licenses/libQt5Sql-devel/LICENSE.FDL
/usr/share/licenses/libQt5Sql-devel/LICENSE.GPL2
/usr/share/licenses/libQt5Sql-devel/LICENSE.GPL3
/usr/share/licenses/libQt5Sql-devel/LICENSE.GPL3-EXCEPT
/usr/share/licenses/libQt5Sql-devel/LICENSE.LGPL3
/usr/share/licenses/libQt5Sql-devel/LICENSE.LGPLv3
/usr/share/licenses/libQt5Sql-devel/LICENSE.QT-LICENSE-AGREEMENT-4.0

Changelog

2019-04-18 - fabian@ritter-vogt.de
- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.12.3/?h=v5.12.3
2019-04-13 - Christophe Giboudeaux <christophe@krop.fr>
- Add fix-fixqt4headers.patch to use the include path used by our
Qt5 packages.
2019-03-14 - fabian@ritter-vogt.de
- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.12.2/?h=5.12.2
- Replace 0001-Revert-White-list-more-recent-Mesa-version-for-multi.patch with
* 0001-Revert-Blacklist-nouveau-and-llvmpipe-for-multithrea.patch
* 0002-Revert-qtlite-Fix-build-libs-with-no-feature-regular.patch
* 0003-Revert-White-list-more-recent-Mesa-version-for-multi.patch
- Remove 0002-Revert-QImage-merge-the-size-calculations-with-prope.patch,
fixed upstream
2019-02-12 - Fabian Vogt <fabian@ritter-vogt.de>
- Clean %install a bit
- Use %license
- Add patch to fix crashes with nouveau (QTBUG-73715):
* 0001-Revert-White-list-more-recent-Mesa-version-for-multi.patch
- Add patch to fix apparent memory leaks (QTBUG-73731):
* 0002-Revert-QImage-merge-the-size-calculations-with-prope.patch
2019-02-04 - wbauer@tmo.at
- Refresh tell-the-truth-about-private-api.patch to apply cleanly
2019-02-01 - fabian@ritter-vogt.de
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.12.1/?h=v5.12.1
- xkbcommon not bundled anymore, removed now obsolete option
- Refresh patches:
* 0001-Add-remote-print-queue-support.patch
* 0001-Fix-qfloat16-methods-definition-without-declaration-.patch
- Drop patches, now upstream:
* 0001-Fix-compile-issue-with-gcc-9.patch
2019-01-30 - alarrosa@suse.com
- Add 0001-Fix-compile-issue-with-gcc-9.patch to fix building with
the latest libstdc++ (boo#1121561)
2019-01-18 - Fabian Vogt <fabian@ritter-vogt.de>
- Remove workaround patch as fixed in KWin meanwhile:
* 0001-Revert-xcb-Initialize-OpenGL-integration-only-when-r.patch
2019-01-17 - Karl Cheng <qantas94heavy@gmail.com>
- Add 0001-Revert-xcb-Initialize-OpenGL-integration-only-when-r.patch:
* Revert upstream commit 60cecc86f8 to work around display
flickering issues with some display drivers
(https://bugreports.qt.io/browse/QTBUG-73122, boo#1120090)
2019-01-07 - bwiedemann@suse.com
- Add reproducible-qrc-time.patch to use SOURCE_DATE_EPOCH
for qrc embedded timestamps to make bitcoin-qt build reproducible
(https://bugreports.qt.io/browse/QTBUG-62511, boo#1047218)

See Also

Package Description
libQt5Sql-private-headers-devel-5.12.3-1.1.noarch.rpm Non-ABI stable experimental API for the Qt5 SQL library
libQt5Sql5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 SQL related libraries
libQt5Sql5-5.12.3-1.1.i586.rpm Qt 5 SQL related libraries
libQt5Sql5-5.12.3-1.1.x86_64.rpm Qt 5 SQL related libraries
libQt5Sql5-mysql-32bit-5.12.3-1.1.x86_64.rpm Qt 5 MySQL support
libQt5Sql5-mysql-5.12.3-1.1.i586.rpm Qt 5 MySQL support
libQt5Sql5-mysql-5.12.3-1.1.x86_64.rpm Qt 5 MySQL support
libQt5Sql5-postgresql-32bit-5.12.3-1.1.x86_64.rpm Qt 5 PostgreSQL plugin
libQt5Sql5-postgresql-5.12.3-1.1.i586.rpm Qt 5 PostgreSQL plugin
libQt5Sql5-postgresql-5.12.3-1.1.x86_64.rpm Qt 5 PostgreSQL plugin
libQt5Sql5-sqlite-32bit-5.12.3-1.1.x86_64.rpm Qt 5 sqlite plugin
libQt5Sql5-sqlite-5.12.3-1.1.i586.rpm Qt 5 sqlite plugin
libQt5Sql5-sqlite-5.12.3-1.1.x86_64.rpm Qt 5 sqlite plugin
libQt5Sql5-unixODBC-32bit-5.12.3-1.1.x86_64.rpm Qt 5 unixODBC plugin
libQt5Sql5-unixODBC-5.12.3-1.1.i586.rpm Qt 5 unixODBC plugin
Advertisement
Advertisement