libQt53DRender5-5.12.3-1.1.x86_64.rpm


Advertisement

Description

libQt53DRender5 - Qt 5 3D Addon

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libQt53DRender5-5.12.3-1.1.x86_64.rpm
Package name libQt53DRender5
Package version 5.12.3
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://www.qt.io
License LGPL-2.1-with-Qt-Company-Qt-exception-1.1 or LGPL-3.0-only
Maintainer -
Download size 2.71 MB
Installed size 11.29 MB
Qt is a set of libraries for developing applications.
The Qt 3D Render module contains functionality to support 2D and 3D
rendering using Qt 3D.

Alternatives

Package Version Architecture Repository
libQt53DRender5-5.12.3-1.1.i586.rpm 5.12.3 i586 openSUSE Oss
libQt53DRender5-5.12.3-1.1.x86_64.rpm 5.12.3 x86_64 KDE 5
libQt53DRender5-5.12.3-1.1.i586.rpm 5.12.3 i586 KDE 5
libQt53DRender5-5.12.3-ku.1.1.x86_64.rpm 5.12.3 x86_64 KDE Unstable
libQt53DRender5-5.12.3-ku.1.1.i586.rpm 5.12.3 i586 KDE Unstable
libQt53DRender5 - - -

Requires

Name Value
/sbin/ldconfig -
libQt53DAnimation.so.5()(64bit) -
libQt53DAnimation.so.5(Qt_5)(64bit) -
libQt53DCore.so.5()(64bit) -
libQt53DCore.so.5(Qt_5)(64bit) -
libQt53DExtras.so.5()(64bit) -
libQt53DExtras.so.5(Qt_5)(64bit) -
libQt5Concurrent.so.5()(64bit) -
libQt5Concurrent.so.5(Qt_5)(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Core.so.5(Qt_5.12.3_PRIVATE_API)(64bit) -
libQt5Core5 >= 5.12.3
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Gui.so.5(Qt_5.12.3_PRIVATE_API)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.4)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.27)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.19)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
libQt53DRender.so.5()(64bit) -
libQt53DRender.so.5(Qt_5)(64bit) -
libQt53DRender.so.5(Qt_5.0)(64bit) -
libQt53DRender.so.5(Qt_5.1)(64bit) -
libQt53DRender.so.5(Qt_5.10)(64bit) -
libQt53DRender.so.5(Qt_5.11)(64bit) -
libQt53DRender.so.5(Qt_5.12)(64bit) -
libQt53DRender.so.5(Qt_5.12.3_PRIVATE_API)(64bit) -
libQt53DRender.so.5(Qt_5.2)(64bit) -
libQt53DRender.so.5(Qt_5.3)(64bit) -
libQt53DRender.so.5(Qt_5.4)(64bit) -
libQt53DRender.so.5(Qt_5.5)(64bit) -
libQt53DRender.so.5(Qt_5.6)(64bit) -
libQt53DRender.so.5(Qt_5.7)(64bit) -
libQt53DRender.so.5(Qt_5.8)(64bit) -
libQt53DRender.so.5(Qt_5.9)(64bit) -
libQt53DRender5 = 5.12.3-1.1
libQt53DRender5(x86-64) = 5.12.3-1.1
libQt53DRenderer5 = 5.12.3
libassimpsceneimport.so()(64bit) -
libdefaultgeometryloader.so()(64bit) -
libgltfgeometryloader.so()(64bit) -
libgltfsceneexport.so()(64bit) -
libgltfsceneimport.so()(64bit) -

Obsoletes

Name Value
libQt53DRenderer5 < 5.12.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libQt53DRender5-5.12.3-1.1.x86_64.rpm
Source Package libqt5-qt3d-5.12.3-1.1.src.rpm

Install Howto

Install libQt53DRender5 rpm package:

# zypper install libQt53DRender5

Files

Path
/usr/lib64/libQt53DRender.so.5
/usr/lib64/libQt53DRender.so.5.12
/usr/lib64/libQt53DRender.so.5.12.3
/usr/lib64/qt5/plugins/geometryloaders/libdefaultgeometryloader.so
/usr/lib64/qt5/plugins/geometryloaders/libgltfgeometryloader.so
/usr/lib64/qt5/plugins/sceneparsers/libassimpsceneimport.so
/usr/lib64/qt5/plugins/sceneparsers/libgltfsceneexport.so
/usr/lib64/qt5/plugins/sceneparsers/libgltfsceneimport.so
/usr/share/doc/packages/libQt53DRender5/LICENSE.GPL
/usr/share/doc/packages/libQt53DRender5/LICENSE.GPL2
/usr/share/doc/packages/libQt53DRender5/LICENSE.GPL3
/usr/share/doc/packages/libQt53DRender5/LICENSE.GPL3-EXCEPT
/usr/share/doc/packages/libQt53DRender5/LICENSE.GPLv3
/usr/share/doc/packages/libQt53DRender5/LICENSE.LGPL3
/usr/share/doc/packages/libQt53DRender5/LICENSE.LGPLv3

Changelog

2019-04-18 - fabian@ritter-vogt.de
- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.3/?h=v5.12.3
2019-03-17 - wbauer@tmo.at
- Drop use-Assimp-namespace-to-fix-build-for-big-endian.patch,
merged upstream (since 5.11.0-beta1 already)
- Adjust filelist for Leap 42.3 to fix the build, assimp is only
compiled with gcc5 or higher now
2019-03-14 - fabian@ritter-vogt.de
- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.2/?h=5.12.2
2019-02-01 - fabian@ritter-vogt.de
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.1/?h=v5.12.1
2018-12-06 - fabian@ritter-vogt.de
- Update to 5.12.0:
* New feature release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.0/?h=v5.12.0
2018-12-03 - fabian@ritter-vogt.de
- Update to 5.12.0-rc2:
* New bugfix release
* Only important bugfixes
- Changelog for Qt 5.12.0:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.0/?h=5.12.0
2018-11-22 - fabian@ritter-vogt.de
- Update to 5.12.0-rc:
* New bugfix release
* No changelog available
2018-11-08 - fabian@ritter-vogt.de
- Update to 5.12.0-beta4:
* New bugfix release
* No changelog available
2018-10-26 - fabian@ritter-vogt.de
- Update to 5.12.0-beta3:
* New bugfix release
* No changelog available
2018-10-17 - fabian@ritter-vogt.de
- Update to 5.12.0-beta2:
* New bugfix release
* No changelog available

See Also

Package Description
libQt5Bluetooth5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-5.12.3-1.1.i586.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-imports-5.12.3-1.1.i586.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-imports-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bootstrap-devel-static-32bit-5.12.3-1.1.x86_64.rpm Qt Bootstrap module
libQt5Bootstrap-devel-static-5.12.3-1.1.i586.rpm Qt Bootstrap module
libQt5Bootstrap-devel-static-5.12.3-1.1.x86_64.rpm Qt Bootstrap module
libQt5Charts5-5.12.3-1.1.i586.rpm Qt 5 Charts Library
libQt5Charts5-5.12.3-1.1.x86_64.rpm Qt 5 Charts Library
libQt5Charts5-designer-5.12.3-1.1.i586.rpm Designer plugin for the Qt 5 Charts library
libQt5Charts5-designer-5.12.3-1.1.x86_64.rpm Designer plugin for the Qt 5 Charts library
libQt5Charts5-devel-5.12.3-1.1.i586.rpm Development files for the Qt 5 Charts Library
libQt5Charts5-devel-5.12.3-1.1.x86_64.rpm Development files for the Qt 5 Charts Library
libQt5Concurrent-devel-32bit-5.12.3-1.1.x86_64.rpm Development files for the Qt5 Concurrent library
Advertisement
Advertisement