libQt53DRender5-32bit-5.12.3-1.1.x86_64.rpm


Advertisement

Description

libQt53DRender5-32bit - Qt 5 3D Addon

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libQt53DRender5-32bit-5.12.3-1.1.x86_64.rpm
Package name libQt53DRender5-32bit
Package version 5.12.3
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://www.qt.io
License LGPL-2.1-with-Qt-Company-Qt-exception-1.1 or LGPL-3.0-only
Maintainer -
Download size 2.88 MB
Installed size 10.97 MB
Qt is a set of libraries for developing applications.
The Qt 3D Render module contains functionality to support 2D and 3D
rendering using Qt 3D.

Alternatives

Package Version Architecture Repository
libQt53DRender5-32bit-5.12.3-1.1.x86_64.rpm 5.12.3 x86_64 KDE 5
libQt53DRender5-32bit-5.12.3-ku.1.1.x86_64.rpm 5.12.3 x86_64 KDE Unstable
libQt53DRender5-32bit - - -

Requires

Name Value
libQt53DAnimation.so.5 -
libQt53DAnimation.so.5(Qt_5) -
libQt53DCore.so.5 -
libQt53DCore.so.5(Qt_5) -
libQt53DExtras.so.5 -
libQt53DExtras.so.5(Qt_5) -
libQt5Concurrent.so.5 -
libQt5Concurrent.so.5(Qt_5) -
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.12) -
libQt5Core.so.5(Qt_5.12.3_PRIVATE_API) -
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libQt5Gui.so.5(Qt_5.12.3_PRIVATE_API) -
libc.so.6(GLIBC_2.7) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.4) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libm.so.6(GLIBC_2.27) -
libm.so.6(GLIBC_2.29) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.1) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.19) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libz.so.1 -

Provides

Name Value
libQt53DRender.so.5 -
libQt53DRender.so.5(Qt_5) -
libQt53DRender.so.5(Qt_5.0) -
libQt53DRender.so.5(Qt_5.1) -
libQt53DRender.so.5(Qt_5.10) -
libQt53DRender.so.5(Qt_5.11) -
libQt53DRender.so.5(Qt_5.12) -
libQt53DRender.so.5(Qt_5.12.3_PRIVATE_API) -
libQt53DRender.so.5(Qt_5.2) -
libQt53DRender.so.5(Qt_5.3) -
libQt53DRender.so.5(Qt_5.4) -
libQt53DRender.so.5(Qt_5.5) -
libQt53DRender.so.5(Qt_5.6) -
libQt53DRender.so.5(Qt_5.7) -
libQt53DRender.so.5(Qt_5.8) -
libQt53DRender.so.5(Qt_5.9) -
libQt53DRender5-32bit = 5.12.3-1.1
libQt53DRender5-32bit(x86-32) = 5.12.3-1.1
libassimpsceneimport.so -
libdefaultgeometryloader.so -
libgltfgeometryloader.so -
libgltfsceneexport.so -
libgltfsceneimport.so -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libQt53DRender5-32bit-5.12.3-1.1.x86_64.rpm
Source Package libqt5-qt3d-5.12.3-1.1.src.rpm

Install Howto

Install libQt53DRender5-32bit rpm package:

# zypper install libQt53DRender5-32bit

Files

Path
/usr/lib/libQt53DRender.so.5
/usr/lib/libQt53DRender.so.5.12
/usr/lib/libQt53DRender.so.5.12.3
/usr/lib/qt5/
/usr/lib/qt5/plugins/
/usr/lib/qt5/plugins/geometryloaders/libdefaultgeometryloader.so
/usr/lib/qt5/plugins/geometryloaders/libgltfgeometryloader.so
/usr/lib/qt5/plugins/sceneparsers/libassimpsceneimport.so
/usr/lib/qt5/plugins/sceneparsers/libgltfsceneexport.so
/usr/lib/qt5/plugins/sceneparsers/libgltfsceneimport.so

Changelog

2019-04-18 - fabian@ritter-vogt.de
- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.3/?h=v5.12.3
2019-03-17 - wbauer@tmo.at
- Drop use-Assimp-namespace-to-fix-build-for-big-endian.patch,
merged upstream (since 5.11.0-beta1 already)
- Adjust filelist for Leap 42.3 to fix the build, assimp is only
compiled with gcc5 or higher now
2019-03-14 - fabian@ritter-vogt.de
- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.2/?h=5.12.2
2019-02-01 - fabian@ritter-vogt.de
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.1/?h=v5.12.1
2018-12-06 - fabian@ritter-vogt.de
- Update to 5.12.0:
* New feature release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.0/?h=v5.12.0
2018-12-03 - fabian@ritter-vogt.de
- Update to 5.12.0-rc2:
* New bugfix release
* Only important bugfixes
- Changelog for Qt 5.12.0:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.0/?h=5.12.0
2018-11-22 - fabian@ritter-vogt.de
- Update to 5.12.0-rc:
* New bugfix release
* No changelog available
2018-11-08 - fabian@ritter-vogt.de
- Update to 5.12.0-beta4:
* New bugfix release
* No changelog available
2018-10-26 - fabian@ritter-vogt.de
- Update to 5.12.0-beta3:
* New bugfix release
* No changelog available
2018-10-17 - fabian@ritter-vogt.de
- Update to 5.12.0-beta2:
* New bugfix release
* No changelog available

See Also

Package Description
libQt53DRender5-5.12.3-1.1.i586.rpm Qt 5 3D Addon
libQt53DRender5-5.12.3-1.1.x86_64.rpm Qt 5 3D Addon
libQt5Bluetooth5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-5.12.3-1.1.i586.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-imports-5.12.3-1.1.i586.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-imports-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bootstrap-devel-static-32bit-5.12.3-1.1.x86_64.rpm Qt Bootstrap module
libQt5Bootstrap-devel-static-5.12.3-1.1.i586.rpm Qt Bootstrap module
libQt5Bootstrap-devel-static-5.12.3-1.1.x86_64.rpm Qt Bootstrap module
libQt5Charts5-5.12.3-1.1.i586.rpm Qt 5 Charts Library
libQt5Charts5-5.12.3-1.1.x86_64.rpm Qt 5 Charts Library
libQt5Charts5-designer-5.12.3-1.1.i586.rpm Designer plugin for the Qt 5 Charts library
libQt5Charts5-designer-5.12.3-1.1.x86_64.rpm Designer plugin for the Qt 5 Charts library
libQt5Charts5-devel-5.12.3-1.1.i586.rpm Development files for the Qt 5 Charts Library
Advertisement
Advertisement