libQt53DQuickScene2D-devel-5.12.3-1.1.x86_64.rpm


Advertisement

Description

libQt53DQuickScene2D-devel - Development files for the Qt 5 3D Quick Scene 2D library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libQt53DQuickScene2D-devel-5.12.3-1.1.x86_64.rpm
Package name libQt53DQuickScene2D-devel
Package version 5.12.3
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/X11
Homepage https://www.qt.io
License LGPL-2.1-with-Qt-Company-Qt-exception-1.1 or LGPL-3.0-only
Maintainer -
Download size 39.16 KB
Installed size 170.43 KB
Development files for the Qt 5 3D Quick Scene 2D library.

Alternatives

Package Version Architecture Repository
libQt53DQuickScene2D-devel-5.12.3-1.1.i586.rpm 5.12.3 i586 openSUSE Oss
libQt53DQuickScene2D-devel-5.12.3-1.1.x86_64.rpm 5.12.3 x86_64 KDE 5
libQt53DQuickScene2D-devel-5.12.3-1.1.i586.rpm 5.12.3 i586 KDE 5
libQt53DQuickScene2D-devel-5.12.3-ku.1.1.x86_64.rpm 5.12.3 x86_64 KDE Unstable
libQt53DQuickScene2D-devel-5.12.3-ku.1.1.i586.rpm 5.12.3 i586 KDE Unstable
libQt53DQuickScene2D-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libQt53DQuickScene2D5 = 5.12.3
pkgconfig(Qt53DCore) -
pkgconfig(Qt53DQuick) -
pkgconfig(Qt53DRender) -
pkgconfig(Qt5Core) -
pkgconfig(Qt5Gui) -
pkgconfig(Qt5Qml) -

Provides

Name Value
cmake(Qt53DQuickScene2D) = 5.12.3
libQt53DQuickScene2D-devel = 5.12.3-1.1
libQt53DQuickScene2D-devel(x86-64) = 5.12.3-1.1
pkgconfig(Qt53DQuickScene2D) = 5.12.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libQt53DQuickScene2D-devel-5.12.3-1.1.x86_64.rpm
Source Package libqt5-qt3d-5.12.3-1.1.src.rpm

Install Howto

Install libQt53DQuickScene2D-devel rpm package:

# zypper install libQt53DQuickScene2D-devel

Files

Path
/usr/include/qt5/Qt3DQuickScene2D/QScene2D
/usr/include/qt5/Qt3DQuickScene2D/Qt3DQuickScene2D
/usr/include/qt5/Qt3DQuickScene2D/Qt3DQuickScene2DDepends
/usr/include/qt5/Qt3DQuickScene2D/Qt3DQuickScene2DVersion
/usr/include/qt5/Qt3DQuickScene2D/qscene2d.h
/usr/include/qt5/Qt3DQuickScene2D/qt3dquickscene2d_global.h
/usr/include/qt5/Qt3DQuickScene2D/qt3dquickscene2dversion.h
/usr/lib64/libQt53DQuickScene2D.prl
/usr/lib64/libQt53DQuickScene2D.so
/usr/lib64/cmake/Qt53DQuickScene2D/Qt53DQuickScene2DConfig.cmake
/usr/lib64/cmake/Qt53DQuickScene2D/Qt53DQuickScene2DConfigVersion.cmake
/usr/lib64/pkgconfig/Qt53DQuickScene2D.pc
/usr/lib64/qt5/mkspecs/modules/qt_lib_3dquickscene2d.pri
/usr/lib64/qt5/mkspecs/modules/qt_lib_3dquickscene2d_private.pri
/usr/share/doc/packages/libQt53DQuickScene2D-devel/LICENSE.GPL
/usr/share/doc/packages/libQt53DQuickScene2D-devel/LICENSE.GPL2
/usr/share/doc/packages/libQt53DQuickScene2D-devel/LICENSE.GPL3
/usr/share/doc/packages/libQt53DQuickScene2D-devel/LICENSE.GPL3-EXCEPT
/usr/share/doc/packages/libQt53DQuickScene2D-devel/LICENSE.GPLv3
/usr/share/doc/packages/libQt53DQuickScene2D-devel/LICENSE.LGPL3
/usr/share/doc/packages/libQt53DQuickScene2D-devel/LICENSE.LGPLv3

Changelog

2019-04-18 - fabian@ritter-vogt.de
- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.3/?h=v5.12.3
2019-03-17 - wbauer@tmo.at
- Drop use-Assimp-namespace-to-fix-build-for-big-endian.patch,
merged upstream (since 5.11.0-beta1 already)
- Adjust filelist for Leap 42.3 to fix the build, assimp is only
compiled with gcc5 or higher now
2019-03-14 - fabian@ritter-vogt.de
- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.2/?h=5.12.2
2019-02-01 - fabian@ritter-vogt.de
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.1/?h=v5.12.1
2018-12-06 - fabian@ritter-vogt.de
- Update to 5.12.0:
* New feature release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.0/?h=v5.12.0
2018-12-03 - fabian@ritter-vogt.de
- Update to 5.12.0-rc2:
* New bugfix release
* Only important bugfixes
- Changelog for Qt 5.12.0:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.0/?h=5.12.0
2018-11-22 - fabian@ritter-vogt.de
- Update to 5.12.0-rc:
* New bugfix release
* No changelog available
2018-11-08 - fabian@ritter-vogt.de
- Update to 5.12.0-beta4:
* New bugfix release
* No changelog available
2018-10-26 - fabian@ritter-vogt.de
- Update to 5.12.0-beta3:
* New bugfix release
* No changelog available
2018-10-17 - fabian@ritter-vogt.de
- Update to 5.12.0-beta2:
* New bugfix release
* No changelog available

See Also

Package Description
libQt53DQuickScene2D5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 3D Addon
libQt53DQuickScene2D5-5.12.3-1.1.i586.rpm Qt 5 3D Addon
libQt53DQuickScene2D5-5.12.3-1.1.x86_64.rpm Qt 5 3D Addon
libQt53DRender-devel-5.12.3-1.1.i586.rpm Development files for the Qt 5 Renderer 3D library
libQt53DRender-devel-5.12.3-1.1.x86_64.rpm Development files for the Qt 5 Renderer 3D library
libQt53DRender5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 3D Addon
libQt53DRender5-5.12.3-1.1.i586.rpm Qt 5 3D Addon
libQt53DRender5-5.12.3-1.1.x86_64.rpm Qt 5 3D Addon
libQt5Bluetooth5-32bit-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-5.12.3-1.1.i586.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-imports-5.12.3-1.1.i586.rpm Qt 5 Bluez Addon
libQt5Bluetooth5-imports-5.12.3-1.1.x86_64.rpm Qt 5 Bluez Addon
libQt5Bootstrap-devel-static-32bit-5.12.3-1.1.x86_64.rpm Qt Bootstrap module
libQt5Bootstrap-devel-static-5.12.3-1.1.i586.rpm Qt Bootstrap module
Advertisement
Advertisement