libKF5WindowSystem5-5.57.0-1.1.x86_64.rpm


Advertisement

Description

libKF5WindowSystem5 - KDE Access to window manager

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libKF5WindowSystem5-5.57.0-1.1.x86_64.rpm
Package name libKF5WindowSystem5
Package version 5.57.0
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/GUI/KDE
Homepage https://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 154.01 KB
Installed size 469.78 KB
Convenience access to certain properties and features of the window manager.
KWindowSystem provides information about the state of the window manager and
allows asking the window manager to change the using a more high-level
interface than the NETWinInfo/NETRootInfo low-level classes.

Alternatives

Package Version Architecture Repository
libKF5WindowSystem5-5.58.0git.20190502T100945~dff8842-ku.34.1.x86_64.rpm 5.58.0git.20190502T100945~dff8842 x86_64 KDE Frameworks Unstable
libKF5WindowSystem5-5.58.0git.20190502T100945~dff8842-ku.34.1.i586.rpm 5.58.0git.20190502T100945~dff8842 i586 KDE Frameworks Unstable
libKF5WindowSystem5-5.57.0-190.2.x86_64.rpm 5.57.0 x86_64 KDE Frameworks 5
libKF5WindowSystem5-5.57.0-190.2.i586.rpm 5.57.0 i586 KDE Frameworks 5
libKF5WindowSystem5-5.57.0-1.1.i586.rpm 5.57.0 i586 openSUSE Oss
libKF5WindowSystem5 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libQt5Widgets5 >= 5.12.2
libQt5X11Extras.so.5()(64bit) -
libQt5X11Extras.so.5(Qt_5)(64bit) -
libQt5X11Extras5 >= 5.12.2
libX11.so.6()(64bit) -
libXfixes.so.3()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libxcb-keysyms.so.1()(64bit) -
libxcb.so.1()(64bit) -

Provides

Name Value
libKF5WindowSystem.so.5()(64bit) -
libKF5WindowSystem5 = 5.57.0-1.1
libKF5WindowSystem5(x86-64) = 5.57.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libKF5WindowSystem5-5.57.0-1.1.x86_64.rpm
Source Package kwindowsystem-5.57.0-1.1.src.rpm

Install Howto

Install libKF5WindowSystem5 rpm package:

# zypper install libKF5WindowSystem5

Files

Path
/etc/xdg/kwindowsystem.categories
/usr/lib64/libKF5WindowSystem.so.5
/usr/lib64/libKF5WindowSystem.so.5.57.0
/usr/lib64/qt5/plugins/kf5/
/usr/lib64/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemWaylandPlugin.so
/usr/lib64/qt5/plugins/kf5/org.kde.kwindowsystem.platforms/KF5WindowSystemX11Plugin.so
/usr/share/licenses/libKF5WindowSystem5/COPYING.LIB

Changelog

2019-04-14 - lbeltrame@kde.org
- Update to 5.57.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.57.0.php
- Changes since 5.56.0:
* Use debug categories here
* port to std::sort
* Send blur/background contrast in device pixels (kde#404923)
* [autotests] Fix KWindowInfoX11Test::testState
2019-03-10 - lbeltrame@kde.org
- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0
2019-02-15 - alarrosa@suse.com
- Downgrade the Qt version requirement to build with 5.9
2019-02-10 - lbeltrame@kde.org
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* autotests: fix it, since nobody else did, grmbl
2019-01-14 - lbeltrame@kde.org
- Update to 5.54.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.54.0.php
- Changes since 5.53.0:
* No code changes since 5.53.0
2018-12-09 - lbeltrame@kde.org
- Update to 5.53.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.53.0.php
- Changes since 5.52.0:
* autotests: cast to int so that the values appear.
* Use isEmpty()
* Remove qt include prefix
* normalize signal/slot
2018-11-11 - lbeltrame@kde.org
- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* don't assign variable to itself
* Add categories file here
* Use qEnvironmentVariableIsEmpty
* Remove unused variable
* Do not compare iterators returned from two separate returned copies
* Call reserve() on Qt containers if fill size is known before
2018-10-16 - Luca Beltrame <lbeltrame@kde.org>
- Run spec-cleaner
2018-10-15 - lbeltrame@kde.org
- Update to 5.51.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.51.0.php
- Changes since 5.50.0:
* Use _NET_WM_WINDOW_TYPE_COMBO instead of _NET_WM_WINDOW_TYPE_COMBOBOX
* API dox: 0 -> nullptr
* Use QString's multi-arg with multiple string args
2018-09-13 - lbeltrame@kde.org
- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

See Also

Package Description
libKF5WindowSystem5-lang-5.57.0-1.1.noarch.rpm Translations for package kwindowsystem
libKF5XmlGui5-32bit-5.57.0-1.2.x86_64.rpm Framework for managing menu and toolbar actions
libKF5XmlGui5-5.57.0-1.2.i586.rpm Framework for managing menu and toolbar actions
libKF5XmlGui5-5.57.0-1.2.x86_64.rpm Framework for managing menu and toolbar actions
libKF5XmlGui5-lang-5.57.0-1.2.noarch.rpm Translations for package kxmlgui
libKF5XmlRpcClient5-32bit-5.57.0-1.1.x86_64.rpm Library containing simple XML-RPC Client support
libKF5XmlRpcClient5-5.57.0-1.1.i586.rpm Library containing simple XML-RPC Client support
libKF5XmlRpcClient5-5.57.0-1.1.x86_64.rpm Library containing simple XML-RPC Client support
libKF5XmlRpcClient5-lang-5.57.0-1.1.noarch.rpm Translations for package kxmlrpcclient5
libKGantt2-2.6.1-1.4.i586.rpm Gantt chart implementation for kdiagram
libKGantt2-2.6.1-1.4.x86_64.rpm Gantt chart implementation for kdiagram
libKPimGAPIBlogger5-19.04.0-1.1.i586.rpm Extension for accessing Google data
libKPimGAPIBlogger5-19.04.0-1.1.x86_64.rpm Extension for accessing Google data
libKPimGAPICalendar5-19.04.0-1.1.i586.rpm Extension for accessing Google data
libKPimGAPICalendar5-19.04.0-1.1.x86_64.rpm Extension for accessing Google data
Advertisement
Advertisement