libKF5WidgetsAddons5-5.57.0-1.1.x86_64.rpm


Advertisement

Description

libKF5WidgetsAddons5 - Large set of desktop widgets

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libKF5WidgetsAddons5-5.57.0-1.1.x86_64.rpm
Package name libKF5WidgetsAddons5
Package version 5.57.0
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/GUI/KDE
Homepage https://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 1.11 MB
Installed size 4.34 MB
This repository contains add-on widgets and classes for applications
that use the Qt Widgets module. If you are porting applications from
KDE Platform 4 "kdeui" library, you will find many of its classes here.

Alternatives

Package Version Architecture Repository
libKF5WidgetsAddons5-5.58.0git.20190426T214928~f03650e-36.2.x86_64.rpm 5.58.0git.20190426T214928~f03650e x86_64 KDE Frameworks Unstable
libKF5WidgetsAddons5-5.58.0git.20190426T214928~f03650e-36.2.i586.rpm 5.58.0git.20190426T214928~f03650e i586 KDE Frameworks Unstable
libKF5WidgetsAddons5-5.57.0-182.2.x86_64.rpm 5.57.0 x86_64 KDE Frameworks 5
libKF5WidgetsAddons5-5.57.0-182.2.i586.rpm 5.57.0 i586 KDE Frameworks 5
libKF5WidgetsAddons5-5.57.0-1.1.i586.rpm 5.57.0 i586 openSUSE Oss
libKF5WidgetsAddons5 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libQt5Widgets5 >= 5.12.2
libc.so.6(GLIBC_2.14)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libKF5WidgetsAddons.so.5()(64bit) -
libKF5WidgetsAddons5 = 5.57.0-1.1
libKF5WidgetsAddons5(x86-64) = 5.57.0-1.1

Obsoletes

Name Value
libKF5WidgetsAddons4 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libKF5WidgetsAddons5-5.57.0-1.1.x86_64.rpm
Source Package kwidgetsaddons-5.57.0-1.1.src.rpm

Install Howto

Install libKF5WidgetsAddons5 rpm package:

# zypper install libKF5WidgetsAddons5

Files

Path
/usr/lib64/libKF5WidgetsAddons.so.5
/usr/lib64/libKF5WidgetsAddons.so.5.57.0
/usr/share/doc/packages/libKF5WidgetsAddons5/README.md
/usr/share/kf5/kcharselect/kcharselect-data
/usr/share/licenses/libKF5WidgetsAddons5/COPYING
/usr/share/licenses/libKF5WidgetsAddons5/COPYING.LIB

Changelog

2019-04-14 - lbeltrame@kde.org
- Update to 5.57.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.57.0.php
- Changes since 5.56.0:
* Port std::sort
* Make KFontRequester consistent
* Update kcharselect-data to Unicode 12.0
2019-03-10 - lbeltrame@kde.org
- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Remove deprecated method
* Port deprecated methods
* Use correct KStandardGuiItem "no" icon
2019-02-15 - alarrosa@suse.com
- Add 0001-Do-not-use-AnimationDuration-if-Qt-lt-5.10.patch to build with
Qt 5.9
- Downgrade the Qt version requirement to build with 5.9
2019-02-10 - lbeltrame@kde.org
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix zero as nullptr constant warning
* [KWidgetsAddons] Do not use light font styles for headings (3/3)
* KRatingPainter: Delete copy constructor and assignment operator
* delete copy constructor and assignment operator of some internal classes
* Remove Qt version check
2019-01-14 - lbeltrame@kde.org
- Update to 5.54.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.54.0.php
- Changes since 5.53.0:
* Port to for(...:...) + use reserve
* [KMessageBox] Fix minimum dialog size when details are requested (kde#401466)
2018-12-09 - lbeltrame@kde.org
- Update to 5.53.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.53.0.php
- Changes since 5.52.0:
* Use isEmpty()
* Add level api from Kirigami.Heading
* [KActionMenu] Add apidox to addAction()
2018-11-11 - lbeltrame@kde.org
- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Have more include guards match file the name
* Include own header first
* Include own _p header as second
* API dox: fix typo
* Use more explicit constructors with internal classes
* API dox: fix "Since" note of KPageWidgetItem::isHeaderVisible
* Use more new style connect()
* Do not mix const & non-const iterators
* Use normalized signatures with Q_ARG()
* Do not return a value in a void function
* Use Q_OBJECT with all QObject subclasses (helps debugging introspection)
* Use QString::remove(foo) over QString::replace(foo, "")
* Use emit properly and for all signals
* More const ref arg passing
* Use QString(), not QStringLiteral("") (where isNull() not relevant)
* add a new property headerVisible
* Remove unused variables
* Call reserve() on Qt containers if fill size is known before
2018-10-16 - Luca Beltrame <lbeltrame@kde.org>
- Run spec-cleaner
2018-10-15 - lbeltrame@kde.org
- Update to 5.51.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.51.0.php
- Changes since 5.50.0:
* Remove misleading use of KDE_INSTALL_PYTHONBINDINGSDIR
* [KCollapsibleGroupBox] Respect style's widget animation duration (kde#397103)
* Remove obsolete Qt version check
* Use QString's multi-arg with multiple string args
* Fix minor EBN issues
2018-09-13 - lbeltrame@kde.org
- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Create a first example of the use of KMessageBox
* Fix two bugs in KMessageWidget
* [KMessageBox] Call style for icon
* Add workaround for labels with word-wrapping

See Also

Package Description
libKF5WidgetsAddons5-lang-5.57.0-1.1.noarch.rpm Translations for package kwidgetsaddons
libKF5WindowSystem5-32bit-5.57.0-1.1.x86_64.rpm KDE Access to window manager
libKF5WindowSystem5-5.57.0-1.1.i586.rpm KDE Access to window manager
libKF5WindowSystem5-5.57.0-1.1.x86_64.rpm KDE Access to window manager
libKF5WindowSystem5-lang-5.57.0-1.1.noarch.rpm Translations for package kwindowsystem
libKF5XmlGui5-32bit-5.57.0-1.2.x86_64.rpm Framework for managing menu and toolbar actions
libKF5XmlGui5-5.57.0-1.2.i586.rpm Framework for managing menu and toolbar actions
libKF5XmlGui5-5.57.0-1.2.x86_64.rpm Framework for managing menu and toolbar actions
libKF5XmlGui5-lang-5.57.0-1.2.noarch.rpm Translations for package kxmlgui
libKF5XmlRpcClient5-32bit-5.57.0-1.1.x86_64.rpm Library containing simple XML-RPC Client support
libKF5XmlRpcClient5-5.57.0-1.1.i586.rpm Library containing simple XML-RPC Client support
libKF5XmlRpcClient5-5.57.0-1.1.x86_64.rpm Library containing simple XML-RPC Client support
libKF5XmlRpcClient5-lang-5.57.0-1.1.noarch.rpm Translations for package kxmlrpcclient5
libKGantt2-2.6.1-1.4.i586.rpm Gantt chart implementation for kdiagram
libKGantt2-2.6.1-1.4.x86_64.rpm Gantt chart implementation for kdiagram
Advertisement
Advertisement