libKF5SyntaxHighlighting5-5.57.0-1.1.x86_64.rpm


Advertisement

Description

libKF5SyntaxHighlighting5 - Syntax highlighting engine and library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libKF5SyntaxHighlighting5-5.57.0-1.1.x86_64.rpm
Package name libKF5SyntaxHighlighting5
Package version 5.57.0
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/GUI/KDE
Homepage https://www.kde.org
License LGPL-2.1-or-later AND GPL-2.0-only AND GPL-2.0-or-later AND GPL-3.0-only AND MIT AND BSD-3-Clause AND Artistic-1.0
Maintainer -
Download size 1.31 MB
Installed size 1.51 MB
This is a tier1/functional version of the Kate syntax highlighting engine.
It's not tied to a particular output format or editor engine.

Alternatives

Package Version Architecture Repository
libKF5SyntaxHighlighting5-5.58.0git.20190416T090221~fc7b81e-62.4.x86_64.rpm 5.58.0git.20190416T090221~fc7b81e x86_64 KDE Frameworks Unstable
libKF5SyntaxHighlighting5-5.58.0git.20190416T090221~fc7b81e-62.4.i586.rpm 5.58.0git.20190416T090221~fc7b81e i586 KDE Frameworks Unstable
libKF5SyntaxHighlighting5-5.57.0-88.2.x86_64.rpm 5.57.0 x86_64 KDE Frameworks 5
libKF5SyntaxHighlighting5-5.57.0-88.2.i586.rpm 5.57.0 i586 KDE Frameworks 5
libKF5SyntaxHighlighting5-5.57.0-1.1.i586.rpm 5.57.0 i586 openSUSE Oss
libKF5SyntaxHighlighting5 - - -

Requires

Name Value
/sbin/ldconfig -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libKF5SyntaxHighlighting.so.5()(64bit) -
libKF5SyntaxHighlighting5 = 5.57.0-1.1
libKF5SyntaxHighlighting5(x86-64) = 5.57.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libKF5SyntaxHighlighting5-5.57.0-1.1.x86_64.rpm
Source Package syntax-highlighting-5.57.0-1.1.src.rpm

Install Howto

Install libKF5SyntaxHighlighting5 rpm package:

# zypper install libKF5SyntaxHighlighting5

Files

Path
/usr/lib64/libKF5SyntaxHighlighting.so.5
/usr/lib64/libKF5SyntaxHighlighting.so.5.57.0
/usr/share/doc/packages/libKF5SyntaxHighlighting5/README.md
/usr/share/licenses/libKF5SyntaxHighlighting5/COPYING

Changelog

2019-04-14 - lbeltrame@kde.org
- Update to 5.57.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.57.0.php
- Changes since 5.56.0:
* Add syntax definition for Elm language to syntax-highlighting
* AppArmor & SELinux: remove one indentation in XML files
* Doxygen: don't use black color in tags
* Allow line end context switches in empty lines (kde#405903)
* Fix endRegion folding in rules with beginRegion+endRegion (use length=0) (kde#405585)
* Add extensions to groovy highlighting (kde#403072)
* Add Smali syntax highlighting file
* Add "." as weakDeliminator in Octave syntax file and update tests
* Remove deprecated method
* Logcat: fix dsError color with underline="0"
* fix highlighter crash for broken hl file
2019-03-10 - lbeltrame@kde.org
- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Too many changes to list here
2019-02-15 - alarrosa@suse.com
- Downgrade the Qt version requirement to build with 5.9
2019-02-10 - lbeltrame@kde.org
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix end of folding region in rules with lookAhead=true
* AsciiDoc: Fix highlighting of include directive
* Add AsciiDoc support
* Fixed Bug Which Caused Infinite Loop While Highlighting Kconfig Files
* check for endless context switches
* Ruby: fix RegExp after ": " and fix/improve detection of HEREDOC (kde#361875, kde#358273)
* delete copy constructor and assignment operator of some internal classes
* Haskell: Make = a special symbol
2019-01-14 - lbeltrame@kde.org
- Update to 5.54.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.54.0.php
- Changes since 5.53.0:
* Update php syntax support
* WML: fix embedded Lua code & use new default styles
* highlight token strings and delimited strings
* fixups for `extern` and `pragma`
* Highlight CUDA .cu and .cuh files as C++
* TypeScript & TS/JS React: improve types detection, fix float-points & other improvements/fixes
* Haskell: Highlight empty comments after 'import'
* WML: fix infinite loop in contexts switch & only highlight tags with valid names (kde#402720)
* BrightScript: Add workaround for QtCreator 'endsub' highlighting
* improve highlighting of complex numbers (kde#402002)
* BrightScript: Remove unused keyword list 'end'
* increment file version
* add attributes `shared` and `__gshared`
* stay in context Linkage2/Pragma2 until closing paren
* BrightScript: Add function/sub folding
2018-12-09 - lbeltrame@kde.org
- Update to 5.53.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.53.0.php
- Changes since 5.52.0:
* fix unit tests
* BrightScript: Allow sub to be unnamed
* Add highlighting file for Wayland Debug Traces
* Add syntax highlighting for TypeScript & TypeScript React
* Rust & Yacc/Bison: improve comments
* Prolog & Lua: fix shebang
* Fix language load after including keywords from this language in another file
* Add BrightScript syntax
* debchangelog: add Disco Dingo

See Also

Package Description
libKF5SyntaxHighlighting5-lang-5.57.0-1.1.noarch.rpm Translations for package syntax-highlighting
libKF5TextWidgets5-32bit-5.57.0-1.1.x86_64.rpm KDE Text editing widgets
libKF5TextWidgets5-5.57.0-1.1.i586.rpm KDE Text editing widgets
libKF5TextWidgets5-5.57.0-1.1.x86_64.rpm KDE Text editing widgets
libKF5TextWidgets5-lang-5.57.0-1.1.noarch.rpm Translations for package ktextwidgets
libKF5ThreadWeaver5-32bit-5.57.0-1.1.x86_64.rpm KDE Helper for multithreaded programming
libKF5ThreadWeaver5-5.57.0-1.1.i586.rpm KDE Helper for multithreaded programming
libKF5ThreadWeaver5-5.57.0-1.1.x86_64.rpm KDE Helper for multithreaded programming
libKF5Tnef5-19.04.0-1.1.i586.rpm KDE PIM Libraries: TNEF Support
libKF5Tnef5-19.04.0-1.1.x86_64.rpm KDE PIM Libraries: TNEF Support
libKF5Torrent6-2.1-1.5.i586.rpm Torrent Downloading Library
libKF5Torrent6-2.1-1.5.x86_64.rpm Torrent Downloading Library
libKF5UnitConversion5-32bit-5.57.0-1.1.x86_64.rpm Converting physical units
libKF5UnitConversion5-5.57.0-1.1.i586.rpm Converting physical units
libKF5UnitConversion5-5.57.0-1.1.x86_64.rpm Converting physical units
Advertisement
Advertisement