kimageformats-32bit-5.57.0-1.1.x86_64.rpm


Advertisement

Description

kimageformats-32bit - Image format plugins for Qt

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename kimageformats-32bit-5.57.0-1.1.x86_64.rpm
Package name kimageformats-32bit
Package version 5.57.0
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/GUI/KDE
Homepage https://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 90.21 KB
Installed size 317.12 KB
This framework provides additional image format plugins for QtGui.  As
such it is not required for the compilation of any other software, but
may be a runtime requirement for Qt-based software to support certain
image formats.

Alternatives

Package Version Architecture Repository
kimageformats-32bit-5.58.0git.20190501T015142~1a9b5d6-ku.27.2.x86_64.rpm 5.58.0git.20190501T015142~1a9b5d6 x86_64 KDE Frameworks Unstable
kimageformats-32bit-5.57.0-172.2.x86_64.rpm 5.57.0 x86_64 KDE Frameworks 5
kimageformats-32bit - - -

Requires

Name Value
libHalf.so.24 -
libIex-2_3.so.24 -
libIlmImf-2_3.so.24 -
libKF5Archive.so.5 -
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.12) -
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libm.so.6 -
libm.so.6(GLIBC_2.27) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(GLIBCXX_3.4) -

Provides

Name Value
kimageformats-32bit = 5.57.0-1.1
kimageformats-32bit(x86-32) = 5.57.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package kimageformats-32bit-5.57.0-1.1.x86_64.rpm
Source Package kimageformats-5.57.0-1.1.src.rpm

Install Howto

Install kimageformats-32bit rpm package:

# zypper install kimageformats-32bit

Files

Path
/usr/lib/qt5/
/usr/lib/qt5/plugins/
/usr/lib/qt5/plugins/imageformats/kimg_exr.so
/usr/lib/qt5/plugins/imageformats/kimg_kra.so
/usr/lib/qt5/plugins/imageformats/kimg_ora.so
/usr/lib/qt5/plugins/imageformats/kimg_pcx.so
/usr/lib/qt5/plugins/imageformats/kimg_pic.so
/usr/lib/qt5/plugins/imageformats/kimg_psd.so
/usr/lib/qt5/plugins/imageformats/kimg_ras.so
/usr/lib/qt5/plugins/imageformats/kimg_rgb.so
/usr/lib/qt5/plugins/imageformats/kimg_tga.so
/usr/lib/qt5/plugins/imageformats/kimg_xcf.so

Changelog

2019-04-14 - lbeltrame@kde.org
- Update to 5.57.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.57.0.php
- Changes since 5.56.0:
* Fix compilation
* ora:kra: qstrcmp -> memcmp
* autotests: Also exercise canRead
* Fix RGBHandler::canRead
* xcf: Don't crash with files with unsupported layer modes
2019-03-10 - lbeltrame@kde.org
- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* ras: fix crash on broken files
* Use auto here too
* compile without foreach
* ras: protect the palette QVector too
* ras: tweak max file check
* xcf: Fix uninitialized memory use on broken documents
* add const, helps understand the function better
* ras: tweak max size that "fits" in a QVector
* ras: don't assert because we try to allicate a huge vector
* ras: Protect against divide by zero
* xcf: Don't divide by 0
* tga: fail gracefully if readRawData errors
* ras: fail gracefully on height*width*bpp > length
2019-02-15 - alarrosa@suse.com
- Downgrade the Qt version requirement to build with 5.9
2019-02-10 - lbeltrame@kde.org
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Too many changes to list here
- Dropped patches, now upstream:
* 0001-Fix-various-OOB-reads-and-writes-in-kimg_tga-and-kim.patch
2019-01-31 - Fabian Vogt <fabian@ritter-vogt.de>
- Add ghostscript requirement to the -eps subpackage
2019-01-28 - Fabian Vogt <fabian@ritter-vogt.de>
- Add patch to fix buffer overflows (boo#1123281):
* 0001-Fix-various-OOB-reads-and-writes-in-kimg_tga-and-kim.patch
2019-01-23 - Fabian Vogt <fabian@ritter-vogt.de>
- Split out the eps plugin into an independant subpackage (bsc#1117336)
- Remove unnecessary ldconfig calls
2019-01-14 - lbeltrame@kde.org
- Update to 5.54.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.54.0.php
- Changes since 5.53.0:
* No code changes since 5.53.0
2018-12-09 - lbeltrame@kde.org
- Update to 5.53.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.53.0.php
- Changes since 5.52.0:
* Use gimp to export simple-rgba-gimp-2.8.10.xcf to png again
2018-11-11 - lbeltrame@kde.org
- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Fix minor EBN issues

See Also

Package Description
kimageformats-5.57.0-1.1.i586.rpm Image format plugins for Qt
kimageformats-5.57.0-1.1.x86_64.rpm Image format plugins for Qt
kimageformats-eps-5.57.0-1.1.i586.rpm EPS image format plugin for Qt
kimageformats-eps-5.57.0-1.1.x86_64.rpm EPS image format plugin for Qt
kimagemapeditor-19.04.0-1.1.i586.rpm HTML Image Map Editor
kimagemapeditor-19.04.0-1.1.x86_64.rpm HTML Image Map Editor
kimagemapeditor-lang-19.04.0-1.1.noarch.rpm Translations for package kimagemapeditor
kimap-devel-19.04.0-1.1.i586.rpm KDE PIM Libraries: Build Environment
kimap-devel-19.04.0-1.1.x86_64.rpm KDE PIM Libraries: Build Environment
kimap-lang-19.04.0-1.1.noarch.rpm Translations for package kimap
kinfocenter5-5.15.4-2.1.i586.rpm Utility that provides information about a computer system
kinfocenter5-5.15.4-2.1.x86_64.rpm Utility that provides information about a computer system
kinfocenter5-lang-5.15.4-2.1.noarch.rpm Translations for package kinfocenter5
kinit-32bit-5.57.0-1.1.x86_64.rpm Helper library to speed up start of applications on KDE workspaces
kinit-5.57.0-1.1.i586.rpm Helper library to speed up start of applications on KDE workspaces
Advertisement
Advertisement