kcmutils-devel-5.57.0-1.1.i586.rpm


Advertisement

Description

kcmutils-devel - Build environment for kcmutils, a set of classes to work with KCModules

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename kcmutils-devel-5.57.0-1.1.i586.rpm
Package name kcmutils-devel
Package version 5.57.0
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/KDE
Homepage https://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 38.38 KB
Installed size 58.20 KB
KCMUtils provides various classes to work with KCModules. KCModules can be
created with the KConfigWidgets framework. Development files.

Alternatives

Package Version Architecture Repository
kcmutils-devel-5.58.0git.20190418T164227~21b1cd9-ku.39.5.x86_64.rpm 5.58.0git.20190418T164227~21b1cd9 x86_64 KDE Frameworks Unstable
kcmutils-devel-5.58.0git.20190418T164227~21b1cd9-ku.39.5.i586.rpm 5.58.0git.20190418T164227~21b1cd9 i586 KDE Frameworks Unstable
kcmutils-devel-5.57.0-171.3.x86_64.rpm 5.57.0 x86_64 KDE Frameworks 5
kcmutils-devel-5.57.0-171.3.i586.rpm 5.57.0 i586 KDE Frameworks 5
kcmutils-devel-5.57.0-1.1.x86_64.rpm 5.57.0 x86_64 openSUSE Oss
kcmutils-devel - - -

Requires

Name Value
extra-cmake-modules -
kconfigwidgets-devel >= 5.57
kservice-devel >= 5.57
libKF5KCMUtils5 = 5.57.0

Provides

Name Value
cmake(KF5KCMUtils) = 5.57.0
kcmutils-devel = 5.57.0-1.1
kcmutils-devel(x86-32) = 5.57.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package kcmutils-devel-5.57.0-1.1.i586.rpm
Source Package kcmutils-5.57.0-1.1.src.rpm

Install Howto

Install kcmutils-devel rpm package:

# zypper install kcmutils-devel

Files

Path
/usr/include/KF5/kcmutils_version.h
/usr/include/KF5/KCMUtils/KCModuleContainer
/usr/include/KF5/KCMUtils/KCModuleInfo
/usr/include/KF5/KCMUtils/KCModuleLoader
/usr/include/KF5/KCMUtils/KCModuleProxy
/usr/include/KF5/KCMUtils/KCMultiDialog
/usr/include/KF5/KCMUtils/KPluginSelector
/usr/include/KF5/KCMUtils/kcmodulecontainer.h
/usr/include/KF5/KCMUtils/kcmoduleinfo.h
/usr/include/KF5/KCMUtils/kcmoduleloader.h
/usr/include/KF5/KCMUtils/kcmoduleproxy.h
/usr/include/KF5/KCMUtils/kcmultidialog.h
/usr/include/KF5/KCMUtils/kcmutils_export.h
/usr/include/KF5/KCMUtils/kpluginselector.h
/usr/include/KF5/KCMUtils/ksettings/Dialog
/usr/include/KF5/KCMUtils/ksettings/Dispatcher
/usr/include/KF5/KCMUtils/ksettings/PluginPage
/usr/include/KF5/KCMUtils/ksettings/dialog.h
/usr/include/KF5/KCMUtils/ksettings/dispatcher.h
/usr/include/KF5/KCMUtils/ksettings/pluginpage.h
/usr/lib/libKF5KCMUtils.so
/usr/lib/cmake/KF5KCMUtils/KF5KCMUtilsConfig.cmake
/usr/lib/cmake/KF5KCMUtils/KF5KCMUtilsConfigVersion.cmake
/usr/lib/cmake/KF5KCMUtils/KF5KCMUtilsTargets-none.cmake
/usr/lib/cmake/KF5KCMUtils/KF5KCMUtilsTargets.cmake
/usr/lib/qt5/mkspecs/modules/qt_KCMUtils.pri

Changelog

2019-04-14 - lbeltrame@kde.org
- Update to 5.57.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.57.0.php
- Changes since 5.56.0:
* [KCModuleLoader] Pass args to created KQuickAddons::ConfigModule
* Pass focus to child searchbar when KPluginSelector is focused
* [KCMUTILS] compile without foreach
* Improve the KCM error message
* Add runtime guard that pages are KCMs in KCMultiDialog (kde#405440)
- Dropped patches, now upstream:
* Add-runtime-guard-that-pages-are-KCMs-in-KCMultiDialog.patch
2019-03-20 - wbauer@tmo.at
- Add Add-runtime-guard-that-pages-are-KCMs-in-KCMultiDialog.patch
to fix Kontact crash when opening its settings (kde#405440)
2019-03-10 - lbeltrame@kde.org
- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods
* Use KCM name in KCM header
* Add missing ifndef KCONFIGWIDGETS_NO_KAUTH
* Fix build without kauth
* Adapt to changes in kconfigwidgets
* Revert "Add missing dependency on KAuth"
* Add missing dependency on KAuth
* Sync QML module padding to reflect system setting pages
2019-02-15 - alarrosa@suse.com
- Downgrade the Qt version requirement to build with 5.9
2019-02-10 - lbeltrame@kde.org
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* [kcmutils] Add ellipsis to search labels in KPluginSelector
2019-01-14 - lbeltrame@kde.org
- Update to 5.54.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.54.0.php
- Changes since 5.53.0:
* initialize variable + minor optimization
* make use of the new currentIndex api of QML kcms
2018-12-09 - lbeltrame@kde.org
- Update to 5.53.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.53.0.php
- Changes since 5.52.0:
* Use isEmpty
* Perfect alignment between QML and QWidget KCM titles
* Add context to kcmodule connection to lambdas (kde#397894)
2018-11-11 - lbeltrame@kde.org
- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* remove deleted method
* support for multi pages kcms
2018-10-16 - Luca Beltrame <lbeltrame@kde.org>
- Run spec-cleaner
2018-10-15 - lbeltrame@kde.org
- Update to 5.51.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.51.0.php
- Changes since 5.50.0:
* manage return events
* MAke sure to build with strict compile flags
* Manually resize KCMUtilDialog to sizeHint()
- Dropped patches, now upstream:
* 0001-Manually-resize-KCMUtilDialog-to-sizeHint.patch

See Also

Package Description
kcodecs-devel-32bit-5.57.0-1.1.x86_64.rpm Header files for kcodecs, a method collection for string manipulation
kcodecs-devel-5.57.0-1.1.i586.rpm Header files for kcodecs, a method collection for string manipulation
kcodecs-devel-5.57.0-1.1.x86_64.rpm Header files for kcodecs, a method collection for string manipulation
kcolorchooser-19.04.0-1.1.i586.rpm Color Chooser
kcolorchooser-19.04.0-1.1.x86_64.rpm Color Chooser
kcolorchooser-lang-19.04.0-1.1.noarch.rpm Translations for package kcolorchooser
kcompletion-devel-32bit-5.57.0-1.1.x86_64.rpm Header files for kcompletion, a widget collection with completion support
kcompletion-devel-5.57.0-1.1.i586.rpm Header files for kcompletion, a widget collection with completion support
kcompletion-devel-5.57.0-1.1.x86_64.rpm Header files for kcompletion, a widget collection with completion support
kconf_update5-5.57.0-1.1.i586.rpm Configuration file access
kconf_update5-5.57.0-1.1.x86_64.rpm Configuration file access
kconfig-devel-32bit-5.57.0-1.1.x86_64.rpm KConfig Development files
kconfig-devel-5.57.0-1.1.i586.rpm KConfig Development files
kconfig-devel-5.57.0-1.1.x86_64.rpm KConfig Development files
kconfigwidgets-devel-32bit-5.57.0-1.1.x86_64.rpm Widgets for configuration dialogs: Build Environment
Advertisement
Advertisement