graphviz-tcl-2.40.1+git20190410.b0871968d-1.1.i586.rpm


Advertisement

Description

graphviz-tcl - Tcl extension tools for graphviz

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename graphviz-tcl-2.40.1+git20190410.b0871968d-1.1.i586.rpm
Package name graphviz-tcl
Package version 2.40.1+git20190410.b0871968d
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/Tcl
Homepage http://www.graphviz.org/
License EPL-1.0
Maintainer -
Download size 772.50 KB
Installed size 2.09 MB
The graphviz-tcl package contains the various tcl packages (extensions)
for the graphviz tools.

Alternatives

Package Version Architecture Repository
graphviz-tcl-2.40.1+git20190410.b0871968d-1.1.x86_64.rpm 2.40.1+git20190410.b0871968d x86_64 openSUSE Oss
graphviz-tcl - - -

Requires

Name Value
/sbin/ldconfig -
graphviz = 2.40.1+git20190410.b0871968d
libc.so.6(GLIBC_2.27) -
libcairo.so.2 -
libcgraph.so.6 -
libexpat.so.1 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgd.so.3 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgts-0.7.so.5 -
libgvc.so.6 -
libltdl.so.7 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.15) -
libpango-1.0.so.0 -
libpangocairo-1.0.so.0 -
libpangoft2-1.0.so.0 -
libpathplan.so.4 -
libpthread.so.0 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libz.so.1 -
tcl >= 8.3
tk -

Provides

Name Value
graphviz-tcl = 2.40.1+git20190410.b0871968d-1.1
graphviz-tcl(x86-32) = 2.40.1+git20190410.b0871968d-1.1
libgdtclft.so.0 -
libgv_tcl.so -
libtcldot.so.0 -
libtcldot_builtin.so.0 -
libtclplan.so.0 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package graphviz-tcl-2.40.1+git20190410.b0871968d-1.1.i586.rpm
Source Package graphviz-addons-2.40.1+git20190410.b0871968d-1.1.src.rpm

Install Howto

Install graphviz-tcl rpm package:

# zypper install graphviz-tcl

Files

Path
/usr/lib/libgdtclft.so
/usr/lib/libgdtclft.so.0
/usr/lib/libgdtclft.so.0.0.0
/usr/lib/libgv_tcl.so
/usr/lib/libtcldot.so
/usr/lib/libtcldot.so.0
/usr/lib/libtcldot.so.0.0.0
/usr/lib/libtcldot_builtin.so
/usr/lib/libtcldot_builtin.so.0
/usr/lib/libtcldot_builtin.so.0.0.0
/usr/lib/libtclplan.so
/usr/lib/libtclplan.so.0
/usr/lib/libtclplan.so.0.0.0
/usr/lib/tcl8.6/
/usr/lib/tcl8.6/graphviz/libgdtclft.so
/usr/lib/tcl8.6/graphviz/libgdtclft.so.0
/usr/lib/tcl8.6/graphviz/libgdtclft.so.0.0.0
/usr/lib/tcl8.6/graphviz/libgv_tcl.so
/usr/lib/tcl8.6/graphviz/libtcldot.so
/usr/lib/tcl8.6/graphviz/libtcldot.so.0
/usr/lib/tcl8.6/graphviz/libtcldot.so.0.0.0
/usr/lib/tcl8.6/graphviz/libtcldot_builtin.so
/usr/lib/tcl8.6/graphviz/libtcldot_builtin.so.0
/usr/lib/tcl8.6/graphviz/libtcldot_builtin.so.0.0.0
/usr/lib/tcl8.6/graphviz/libtclplan.so
/usr/lib/tcl8.6/graphviz/libtclplan.so.0
/usr/lib/tcl8.6/graphviz/libtclplan.so.0.0.0
/usr/lib/tcl8.6/graphviz/pkgIndex.tcl
/usr/share/man/man3/gdtclft.3tcl.gz
/usr/share/man/man3/gv.3tcl.gz
/usr/share/man/man3/tcldot.3tcl.gz
/usr/share/tcl/graphviz/pkgIndex.tcl

Changelog

2019-04-16 - Christian Vögl <christian.voegl@suse.com>
- Disabled Visio plugin
2019-04-15 - Atri Bhattacharya <badshah400@gmail.com>
- Use %%python3_sitearch macro to package python3 modules.
- use correct ruby version (2.5) for openSUSE 15.1 and earlier.
2019-04-02 - Christian Vögl <christian.voegl@suse.com>
- Now using master branch of upstream, as there have been no releases for
over two years
* this should fix CVE-2019-11023 (boo#1132091)
- Removed  graphviz-qt5.patch (now in upstream)
- Removed reproducible.patch (now in upstream)
- graphviz-smyrna-link_against_glu.patch changed to be applicable to current files
- graphviz-no_strict_aliasing.patch changed to be applicable to current files
- Added graphviz-fix-ruby-version.patch to remove hardcoded dependency on ruby 1.9
- graphviz.spec updated for new version
- created _service file
2018-11-30 - jbrielmaier@suse.de
- use pkg-config with correct parameter, reported by Werner Fink
2018-11-29 - jbrielmaier@suse.de
- Support dynamic move to Guile 2.2, part of boo#1117121:
- Replace conditional pkgconfig(guile-2.[02]) BuildRequires with
guile-devel: The package name is unchanged, which allows the
distro projects to move wihout step-locking changes.
- Patch configure.ac to look for guile-2.2 if guile 2.2 is being
used.
- order inputs alphabetically
2018-11-16 - trenn@suse.de
- Fixed double file declaration in graphviz and graphviz-addons (x11)
- Mark license files with %license instead of %doc
2018-10-25 - trenn@suse.de
- Build with gts support (bsc#1108978, bsc#1108976)
SLE12 flavors do not provide gts, so explicitly exclude
gts support there.
2018-07-30 - bwiedemann@suse.com
- Extend reproducible.patch to make build reproducible (boo#1041534)
2018-03-27 - stefan.bruens@rwth-aachen.de
- Build with PHP5 for Leap 42.x and earlier, PHP7 requires swig 3.0.11
Drop graphviz-plugins-fix_install_dirs.patch, use sed script to
fix directories, same as for Lua
2018-03-27 - stefan.bruens@rwth-aachen.de
- Do not delete dotty/lefty/lneato man pages which are part of
the x11 subpackage, built from the addons package/spec.
(No changelog entry).

See Also

Package Description
graphviz-x11-2.40.1+git20190410.b0871968d-1.1.i586.rpm Graph editors based on X11
graphviz-x11-2.40.1+git20190410.b0871968d-1.1.x86_64.rpm Graph editors based on X11
grc-1.11.1-1.4.noarch.rpm Generic colouriser for everything
grep-3.3-2.1.i586.rpm Print lines matching a pattern
grep-3.3-2.1.x86_64.rpm Print lines matching a pattern
grep-lang-3.3-2.1.noarch.rpm Translations for package grep
grepmail-5.3104-2.3.noarch.rpm Search Mailboxes for a Particular E-Mail
grfcodec-6.0.6-2.8.i586.rpm A suite of programs to modify Transport Tycoon Deluxe's GRF files
grfcodec-6.0.6-2.8.x86_64.rpm A suite of programs to modify Transport Tycoon Deluxe's GRF files
gri-2.12.23-21.2.i586.rpm A language for scientific illustration
gri-2.12.23-21.2.x86_64.rpm A language for scientific illustration
grilo-devel-0.3.7-1.2.i586.rpm Framework for browsing and searching media content -- Development Files
grilo-devel-0.3.7-1.2.x86_64.rpm Framework for browsing and searching media content -- Development Files
grilo-lang-0.3.7-1.2.noarch.rpm Translations for package grilo
grilo-plugin-dleyna-0.3.8-2.3.i586.rpm dLeyna/DLNA plugin for the Grilo media framework
Advertisement
Advertisement