graphviz-python-2.40.1+git20190410.b0871968d-1.1.i586.rpm


Advertisement

Description

graphviz-python - Python Extension for Graphviz

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename graphviz-python-2.40.1+git20190410.b0871968d-1.1.i586.rpm
Package name graphviz-python
Package version 2.40.1+git20190410.b0871968d
Package release 1.1
Package architecture i586
Package type rpm
Category Productivity/Graphics/Visualization/Graph
Homepage http://www.graphviz.org/
License EPL-1.0
Maintainer -
Download size 54.14 KB
Installed size 426.76 KB
The graphviz-python package contains the Python extension for the
graphviz tools.

Alternatives

Package Version Architecture Repository
graphviz-python-2.40.1+git20190410.b0871968d-1.1.x86_64.rpm 2.40.1+git20190410.b0871968d x86_64 openSUSE Oss
graphviz-python - - -

Requires

Name Value
graphviz = 2.40.1+git20190410.b0871968d
libc.so.6(GLIBC_2.4) -
libcgraph.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgvc.so.6 -
libpython2.7.so.1.0 -
libpython3.7m.so.1.0 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
python -
python(abi) = 2.7
python(abi) = 3.7

Provides

Name Value
graphviz-python = 2.40.1+git20190410.b0871968d-1.1
graphviz-python(x86-32) = 2.40.1+git20190410.b0871968d-1.1
libgv_python2.so -
libgv_python3.so -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package graphviz-python-2.40.1+git20190410.b0871968d-1.1.i586.rpm
Source Package graphviz-addons-2.40.1+git20190410.b0871968d-1.1.src.rpm

Install Howto

Install graphviz-python rpm package:

# zypper install graphviz-python

Files

Path
/usr/lib/graphviz/python2/_gv.so
/usr/lib/graphviz/python2/gv.py
/usr/lib/graphviz/python2/libgv_python2.so
/usr/lib/graphviz/python3/_gv.so
/usr/lib/graphviz/python3/gv.py
/usr/lib/graphviz/python3/libgv_python3.so
/usr/lib/python2.7/site-packages/_gv.so
/usr/lib/python2.7/site-packages/gv.py
/usr/lib/python3.7/site-packages/_gv.so
/usr/lib/python3.7/site-packages/gv.py
/usr/share/man/man3/gv.3python.gz

Changelog

2019-04-16 - Christian Vögl <christian.voegl@suse.com>
- Disabled Visio plugin
2019-04-15 - Atri Bhattacharya <badshah400@gmail.com>
- Use %%python3_sitearch macro to package python3 modules.
- use correct ruby version (2.5) for openSUSE 15.1 and earlier.
2019-04-02 - Christian Vögl <christian.voegl@suse.com>
- Now using master branch of upstream, as there have been no releases for
over two years
* this should fix CVE-2019-11023 (boo#1132091)
- Removed  graphviz-qt5.patch (now in upstream)
- Removed reproducible.patch (now in upstream)
- graphviz-smyrna-link_against_glu.patch changed to be applicable to current files
- graphviz-no_strict_aliasing.patch changed to be applicable to current files
- Added graphviz-fix-ruby-version.patch to remove hardcoded dependency on ruby 1.9
- graphviz.spec updated for new version
- created _service file
2018-11-30 - jbrielmaier@suse.de
- use pkg-config with correct parameter, reported by Werner Fink
2018-11-29 - jbrielmaier@suse.de
- Support dynamic move to Guile 2.2, part of boo#1117121:
- Replace conditional pkgconfig(guile-2.[02]) BuildRequires with
guile-devel: The package name is unchanged, which allows the
distro projects to move wihout step-locking changes.
- Patch configure.ac to look for guile-2.2 if guile 2.2 is being
used.
- order inputs alphabetically
2018-11-16 - trenn@suse.de
- Fixed double file declaration in graphviz and graphviz-addons (x11)
- Mark license files with %license instead of %doc
2018-10-25 - trenn@suse.de
- Build with gts support (bsc#1108978, bsc#1108976)
SLE12 flavors do not provide gts, so explicitly exclude
gts support there.
2018-07-30 - bwiedemann@suse.com
- Extend reproducible.patch to make build reproducible (boo#1041534)
2018-03-27 - stefan.bruens@rwth-aachen.de
- Build with PHP5 for Leap 42.x and earlier, PHP7 requires swig 3.0.11
Drop graphviz-plugins-fix_install_dirs.patch, use sed script to
fix directories, same as for Lua
2018-03-27 - stefan.bruens@rwth-aachen.de
- Do not delete dotty/lefty/lneato man pages which are part of
the x11 subpackage, built from the addons package/spec.
(No changelog entry).

See Also

Package Description
graphviz-ruby-2.40.1+git20190410.b0871968d-1.1.i586.rpm Ruby Extension for Graphviz
graphviz-ruby-2.40.1+git20190410.b0871968d-1.1.x86_64.rpm Ruby Extension for Graphviz
graphviz-smyrna-2.40.1+git20190410.b0871968d-1.1.i586.rpm Large graph viewer
graphviz-smyrna-2.40.1+git20190410.b0871968d-1.1.x86_64.rpm Large graph viewer
graphviz-tcl-2.40.1+git20190410.b0871968d-1.1.i586.rpm Tcl extension tools for graphviz
graphviz-tcl-2.40.1+git20190410.b0871968d-1.1.x86_64.rpm Tcl extension tools for graphviz
graphviz-x11-2.40.1+git20190410.b0871968d-1.1.i586.rpm Graph editors based on X11
graphviz-x11-2.40.1+git20190410.b0871968d-1.1.x86_64.rpm Graph editors based on X11
grc-1.11.1-1.4.noarch.rpm Generic colouriser for everything
grep-3.3-2.1.i586.rpm Print lines matching a pattern
grep-3.3-2.1.x86_64.rpm Print lines matching a pattern
grep-lang-3.3-2.1.noarch.rpm Translations for package grep
grepmail-5.3104-2.3.noarch.rpm Search Mailboxes for a Particular E-Mail
grfcodec-6.0.6-2.8.i586.rpm A suite of programs to modify Transport Tycoon Deluxe's GRF files
grfcodec-6.0.6-2.8.x86_64.rpm A suite of programs to modify Transport Tycoon Deluxe's GRF files
Advertisement
Advertisement