gpgme-1.13.0-1.1.x86_64.rpm


Advertisement

Description

gpgme - Programmatic library interface to GnuPG

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename gpgme-1.13.0-1.1.x86_64.rpm
Package name gpgme
Package version 1.13.0
Package release 1.1
Package architecture x86_64
Package type rpm
Category Productivity/Security
Homepage http://www.gnupg.org/related_software/gpgme/
License LGPL-2.1-or-later AND GPL-3.0-or-later
Maintainer -
Download size 347.66 KB
Installed size 915.03 KB
GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG
easier for applications. It provides a high-level crypto API for
encryption, decryption, signing, signature verification, and key
management. It uses GnuPG as its back-end.

Alternatives

Package Version Architecture Repository
gpgme-1.13.0-162.5.x86_64.rpm 1.13.0 x86_64 KDE Applications Unstable
gpgme-1.13.0-162.5.i586.rpm 1.13.0 i586 KDE Applications Unstable
gpgme-1.13.0-3.3.x86_64.rpm 1.13.0 x86_64 KDE 5
gpgme-1.13.0-3.3.i586.rpm 1.13.0 i586 KDE 5
gpgme-1.13.0-1.1.i586.rpm 1.13.0 i586 openSUSE Oss
gpgme-1.13.0-ku.3.1.x86_64.rpm 1.13.0 x86_64 KDE Unstable
gpgme-1.13.0-ku.3.1.i586.rpm 1.13.0 i586 KDE Unstable
gpgme - - -

Requires

Name Value
info -
libassuan.so.0()(64bit) -
libassuan.so.0(LIBASSUAN_1.0)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgpg-error.so.0()(64bit) -
libgpg-error.so.0(GPG_ERROR_1.0)(64bit) -
libgpgme.so.11()(64bit) -
libgpgme.so.11(GPGME_1.0)(64bit) -
libgpgme.so.11(GPGME_1.1)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -

Provides

Name Value
gpgme = 1.13.0-1.1
gpgme(x86-64) = 1.13.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gpgme-1.13.0-1.1.x86_64.rpm
Source Package gpgme-1.13.0-1.1.src.rpm

Install Howto

Install gpgme rpm package:

# zypper install gpgme

Files

Path
/usr/bin/gpgme-json
/usr/bin/gpgme-tool
/usr/share/common-lisp/
/usr/share/common-lisp/source/
/usr/share/common-lisp/source/gpgme/gpgme-grovel.lisp
/usr/share/common-lisp/source/gpgme/gpgme-package.lisp
/usr/share/common-lisp/source/gpgme/gpgme.asd
/usr/share/common-lisp/source/gpgme/gpgme.lisp
/usr/share/doc/packages/gpgme/AUTHORS
/usr/share/doc/packages/gpgme/ChangeLog
/usr/share/doc/packages/gpgme/ChangeLog-2011
/usr/share/doc/packages/gpgme/NEWS
/usr/share/doc/packages/gpgme/README
/usr/share/doc/packages/gpgme/THANKS
/usr/share/doc/packages/gpgme/TODO
/usr/share/doc/packages/gpgme/VERSION
/usr/share/info/gpgme.info-1.gz
/usr/share/info/gpgme.info-2.gz
/usr/share/info/gpgme.info.gz
/usr/share/licenses/gpgme/COPYING
/usr/share/licenses/gpgme/COPYING.LESSER

Changelog

2019-03-31 - Andreas Stieger <andreas.stieger@gmx.de>
- gpgme 1.13.0:
* Support GPGME_AUDITLOG_DIAG for gpgsm
* New context flag "trust-model".
* Aligned the gpgrt-config code with our other libaries
* Auto-check for all installed Python versions
* Fixed generating card key in the C++ bindings
* Fixed a segv due to bad parameters in genkey
* Fixed crash if the plaintext is ignored in a CMS verify
* Fixed test suite problems related to dtags
* Fixed bunch of python bugs
* Several fixes to the Common Lisp bindings
* Fixed minor bugs in gpgme-json
* Require trace level 8 to dump all I/O data
* The compiler must now support variadic macros
- drop gpgme-key-expirity.patch, included upstream
2019-01-09 - Tomá? Chvátal <tchvatal@suse.com>
- Regen keys in Qt tests to not expire bsc#1121051:
* gpgme-key-expirity.patch
2018-10-09 - Tomá? Chvátal <tchvatal@suse.com>
- Fix the build on ix86 as we disable one test there that should
not work, sadly just sed is employed as the infrastructure for
testing is not smart enough for comfy test filtering
2018-10-08 - Karol Babioch <kbabioch@suse.com>
- Update to 1.12.0:
* Enhanced the JSON based interface tool gpgme-json to support Native
Messaging as well as new Javascript code to support the browser
site.  See lang/js/README for details.
* Major overhaul of the Python language bindings documentation
* Even for old versions of gpg a missing MDC will now lead to a
decryption failure
* Added context flag "auto-key-locate" to control the
behavior of GPGME_KEYLIST_MODE_LOCATE
* New data function to create a data object from an estream
* Add more interfaces to the C++ binding
* Improved error codes on decryption failure
* Lots of minor fixes
* Interface changes
2018-04-20 - astieger@suse.com
- update to 1.11.1:
* Fixed build problems in the 1.11.0 releas
drop gpgme-1.11-fix-gpgme-json-rpath.patch,
drop gpgme-1.11-fix-tests.patch
* Added C++ interfaces which were planned for 1.11.0
2018-04-19 - kbabioch@suse.com
- Update to 1.11
* New encryption API to support direct key specification including
hidden recipients option and taking keys from a file.  This also
allows to enforce the use of a subkey.
* New encryption flag for the new API to enforce the use of plain
mail addresses (addr-spec).
* The import API can now tell whether v3 keys are skipped. These
old and basically broken keys are not anymore supported by GnuPG
2.1.
* The decrypt and verify API will now return the MIME flag as
specified by RFC-4880bis.
* The offline mode now has an effect on gpg by disabling all
network access.
* A failed OpenPGP verification how returns the fingerprint of the
intended key if a recent gpg version was used for signature
creation.
* Various minor fixes.
- Dropped patch 0001-core-Tweak-STATUS_FAILURE-handling.patch, since
it is included upstream now.
- add gpgme-1.11-fix-gpgme-json-rpath.patch to remove rpath
- add gpgme-1.11-fix-tests.patch to fix tests
2018-04-16 - astieger@suse.com
- bsc#1089497: Address failure handling issues when using gpg 2.2.6
via gpgme, as used by libzypp
Add 0001-core-Tweak-STATUS_FAILURE-handling.patch
2018-01-08 - tchvatal@suse.com
- Tweak up the python conditional to allow us finegraining and
selecting only py2 or py3 if needed

See Also

Package Description
gpgmepp5-16.08.3-2.7.i586.rpm C++ bindings/wrapper for gpgme
gpgmepp5-16.08.3-2.7.x86_64.rpm C++ bindings/wrapper for gpgme
gpgmepp5-32bit-16.08.3-2.7.x86_64.rpm C++ bindings/wrapper for gpgme
gpgmepp5-devel-16.08.3-2.7.i586.rpm C++ bindings/wrapper for gpgme: Build Environment
gpgmepp5-devel-16.08.3-2.7.x86_64.rpm C++ bindings/wrapper for gpgme: Build Environment
gpgmepp5-devel-32bit-16.08.3-2.7.x86_64.rpm C++ bindings/wrapper for gpgme: Build Environment
gphoto-2.5.20-1.2.i586.rpm A Digital Camera Utility
gphoto-2.5.20-1.2.x86_64.rpm A Digital Camera Utility
gphotofs-0.5-7.12.i586.rpm User Level File System for gphoto-Based Cameras
gphotofs-0.5-7.12.x86_64.rpm User Level File System for gphoto-Based Cameras
gpick-0.2.5-10.3.i586.rpm Advanced color picker writen in GTK+
gpick-0.2.5-10.3.x86_64.rpm Advanced color picker writen in GTK+
gpick-lang-0.2.5-10.3.noarch.rpm Translations for package gpick
gpicview-0.2.5-1.5.i586.rpm LXDE Photo Viewer
gpicview-0.2.5-1.5.x86_64.rpm LXDE Photo Viewer
Advertisement
Advertisement