glib2-devel-2.56.0-1.1.i586.rpm


Advertisement

Description

glib2-devel - Development files for glib, a general-purpose utility library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package name glib2-devel
Package version 2.56.0
Package release 1.1
Package architecture i586
Package type rpm
Installed size 27.53 MB
Download size 3.07 MB
Official Mirror widehat.opensuse.org
GLib is a general-purpose utility library, which provides many useful
data types, macros, type conversions, string utilities, file utilities,
a main loop abstraction, and so on.
This package contains the development files for GLib.

Alternatives

Package Version Architecture Repository
glib2-devel-2.58.1-597.4.i586.rpm 2.58.1 i586 GNOME Next
glib2-devel-2.58.1-597.4.x86_64.rpm 2.58.1 x86_64 GNOME Next
glib2-devel-2.58.1-379.4.i586.rpm 2.58.1 i586 GNOME Factory
glib2-devel-2.58.1-379.4.x86_64.rpm 2.58.1 x86_64 GNOME Factory
glib2-devel-2.56.0-1.1.x86_64.rpm 2.56.0 x86_64 openSUSE Oss
glib2-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
/usr/bin/python3 -
glib2-tools = 2.56.0
glibc-devel -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgio-2.0.so.0 -
libgio-2_0-0 = 2.56.0
libglib-2.0.so.0 -
libglib-2_0-0 = 2.56.0
libgmodule-2_0-0 = 2.56.0
libgobject-2.0.so.0 -
libgobject-2_0-0 = 2.56.0
libgthread-2_0-0 = 2.56.0
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
pkgconfig -
pkgconfig(gio-2.0) -
pkgconfig(glib-2.0) -
pkgconfig(gmodule-no-export-2.0) -
pkgconfig(gobject-2.0) -
pkgconfig(libpcre) -
python3-xml -
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

Provides

Name Value
glib2-devel = 2.56.0-1.1
glib2-devel(x86-32) = 2.56.0-1.1
glib2-doc = 2.19.6
pkgconfig(gio-2.0) = 2.56.0
pkgconfig(gio-unix-2.0) = 2.56.0
pkgconfig(glib-2.0) = 2.56.0
pkgconfig(gmodule-2.0) = 2.56.0
pkgconfig(gmodule-export-2.0) = 2.56.0
pkgconfig(gmodule-no-export-2.0) = 2.56.0
pkgconfig(gobject-2.0) = 2.56.0
pkgconfig(gthread-2.0) = 2.56.0

Obsoletes

Name Value
glib2-doc < 2.19.6

Download

Type URL
Binary Package glib2-devel-2.56.0-1.1.i586.rpm
Source Package glib2-2.56.0-1.1.src.rpm

Install Howto

Install glib2-devel rpm package:

# zypper install glib2-devel

Files

Path
/etc/rpm/macros.glib2
/usr/bin/gdbus-codegen
/usr/bin/glib-compile-resources
/usr/bin/glib-genmarshal
/usr/bin/glib-gettextize
/usr/bin/glib-mkenums
/usr/bin/gobject-query
/usr/bin/gtester
/usr/bin/gtester-report

See Also

Package Description
glib2-devel-32bit-2.56.0-1.1.x86_64.rpm Development files for glib, a general-purpose utility library
glib2-devel-static-2.56.0-1.1.i586.rpm Static libraries for glib, a general-purpose utility library
glib2-devel-static-2.56.0-1.1.x86_64.rpm Static libraries for glib, a general-purpose utility library
glib2-lang-2.56.0-1.1.noarch.rpm Translations for package glib2
glib2-tools-2.56.0-1.1.i586.rpm Tools from glib2, a general-purpose utility library
glib2-tools-2.56.0-1.1.x86_64.rpm Tools from glib2, a general-purpose utility library
glib2-tools-32bit-2.56.0-1.1.x86_64.rpm Tools from glib2, a general-purpose utility library
glibc-2.27-2.1.i586.rpm Standard Shared Libraries (from the GNU C Library)
glibc-2.27-2.1.i686.rpm Standard Shared Libraries (from the GNU C Library)
glibc-2.27-2.1.x86_64.rpm Standard Shared Libraries (from the GNU C Library)
glibc-32bit-2.27-2.1.x86_64.rpm Standard Shared Libraries (from the GNU C Library)
glibc-devel-2.27-2.1.i586.rpm Include Files and Libraries Mandatory for Development
glibc-devel-2.27-2.1.i686.rpm Include Files and Libraries Mandatory for Development
glibc-devel-2.27-2.1.x86_64.rpm Include Files and Libraries Mandatory for Development
glibc-devel-32bit-2.27-2.1.x86_64.rpm Include Files and Libraries Mandatory for Development
Advertisement
Advertisement