firebird-utils-3.0.4.33054-1.5.i586.rpm


Advertisement

Description

firebird-utils - Firebird RDBMS management utilities

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename firebird-utils-3.0.4.33054-1.5.i586.rpm
Package name firebird-utils
Package version 3.0.4.33054
Package release 1.5
Package architecture i586
Package type rpm
Category Productivity/Databases/Servers
Homepage http://www.firebirdsql.org/
License SUSE-IDPL-1.0 AND SUSE-IBPL-1.0
Maintainer -
Download size 1.03 MB
Installed size 4.35 MB
This package provides for Firebird RDBMS management.
Firebird is a relational database offering many ANSI SQL standard
features that runs on Linux, Windows, and a variety of Unix platforms.
Firebird offers excellent concurrency, high performance, and powerful
language support for stored procedures and triggers. It has been used
in production systems, under a variety of names, since 1981.

Alternatives

Package Version Architecture Repository
firebird-utils-3.0.4.33054-117.32.x86_64.rpm 3.0.4.33054 x86_64 Database
firebird-utils-3.0.4.33054-117.32.i586.rpm 3.0.4.33054 i586 Database
firebird-utils-3.0.4.33054-1.5.x86_64.rpm 3.0.4.33054 x86_64 openSUSE Oss
firebird-utils - - -

Requires

Name Value
firebird = 3.0.4.33054
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libc.so.6(GLIBC_2.28) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libedit.so.0 -
libfbclient.so.2 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.29) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -

Provides

Name Value
firebird-superserver:/usr/bin/gbak -
firebird-utils = 3.0.4.33054-1.5
firebird-utils(x86-32) = 3.0.4.33054-1.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package firebird-utils-3.0.4.33054-1.5.i586.rpm
Source Package firebird-3.0.4.33054-1.5.src.rpm

Install Howto

Install firebird-utils rpm package:

# zypper install firebird-utils

Files

Path
/usr/bin/fbsvcmgr
/usr/bin/fbtracemgr
/usr/bin/gbak
/usr/bin/gfix
/usr/bin/gpre
/usr/bin/gsec
/usr/bin/gsplit
/usr/bin/gstat-fb
/usr/bin/isql-fb
/usr/bin/nbackup
/usr/bin/qli

Changelog

2018-11-21 - mkubecek@suse.cz
- update to upstream version 3.0.4
* add support for SRP authentication using SHA-256
* ODS (database file format) version raised to 12.2 on some
architectures (including i586, not x86_64); new version will be
able to open existing ODS 12.0 created on the same architecture
but for database transfer between architectures, backup/restore
is always recommended
* context variables WIRE_COMPRESSED and WIRE_ENCRYPTED were added
to the SYSTEM namespace to report compression and encryption
status, respectively, of the current connection (CORE-5913)
* enhanced reporting of errors when dynamic library fails to load
(CORE-5908)
* include funciton name when UDF causes "Arithmetic exception,
numeric overflow, or string truncation" error (CORE-5876)
* context variables LOCALTIME and LOCALTIMESTAMP (synonyms for
CURRENT_TIME and CURRENT_TIMESTAMP) for compatibility with 4.0
(CORE-5853)
* read-only restriction for system tables was relaxed to permit
CREATE, ALTER and DROP operations on their indexes (CORE-5746)
* fix unauthorized BLOB access vulnerability (CORE-5801)
* for a full list of bugfixes and improvements see
http://www.firebirdsql.org/file/documentation/release_notes/html/en/3_0/rnfb30-general.html#rnfb30-general-v304
- drop patches included in new upstream release:
Make-it-build-with-icu60.patch
An-attempt-to-fix-CORE-5764-need-feedback-on-snapsho.patch
Fixed-a-code-somewhy-accepted-by-gcc6.patch
- refresh patches:
work-around-g-problem-in-SLE11.patch
use-C-98-on-SLE11.patch
2018-07-04 - mkubecek@suse.cz
- replace unicode-handle-the-ICU-version-hack-from-SuSE.patch
with more general upstream solution:
* An-attempt-to-fix-CORE-5764-need-feedback-on-snapsho.patch
* Fixed-a-code-somewhy-accepted-by-gcc6.patch
- unicode-handle-new-SUSE-ICU-version-hack.patch:
search also for "suse%d.%d" soname pattern to fix build after
upcoming ICU update (bsc#1095425)
2018-03-28 - mkubecek@suse.cz
- move firebitd.xinetd back to firebird-server subpackage on SLE15
- provide /etc/xinetd.d directory on Tumbleweed and Leap 15.0 as
xinetd is no longer guaranteed to be present there; this solution
(suggested by Dimstar) is less painful than either having
firebird-server depend on xinetd or splitting a new subpackage
firebird-server-classic.
2018-03-23 - mkubecek@suse.cz
- patch xinetd config file unconditionally; previous change would
result in unpatched xinetd config file installed on Tumbleweed
so that the service would be enabled by default and firebird
binary run as root
2018-03-22 - fcrozat@suse.com
- Do no ship xinetd file on SLE15 (bsc#1084459).

See Also

Package Description
firefox-uget-integrator-1.0.0-2.1.i586.rpm Integration of uGet with Firefox
firefox-uget-integrator-1.0.0-2.1.x86_64.rpm Integration of uGet with Firefox
firehol-3.1.6-1.2.noarch.rpm Tools to build stateful firewalls and traffic shaping
firehol-doc-3.1.6-1.2.noarch.rpm FireHOL documentation
firejail-0.9.58-1.1.i586.rpm Linux namepaces sandbox program
firejail-0.9.58-1.1.x86_64.rpm Linux namepaces sandbox program
firescope-0.2-89.12.i586.rpm Read linux kernel logs over firewire
firescope-0.2-89.12.x86_64.rpm Read linux kernel logs over firewire
firewall-applet-0.6.3-4.1.noarch.rpm Firewall panel applet
firewall-config-0.6.3-4.1.noarch.rpm Firewall configuration application
firewall-macros-0.6.3-4.1.noarch.rpm FirewallD RPM macros
firewalld-0.6.3-4.1.noarch.rpm A firewall daemon with D-Bus interface providing a dynamic firewall
firewalld-lang-0.6.3-4.1.noarch.rpm Translations for package firewalld
firewalld-rpcbind-helper-0.2-1.2.noarch.rpm Tool for static port assignment of NFSv3, ypserv, ypbind services
fish-3.0.2-2.1.i586.rpm The "friendly interactive shell"
Advertisement
Advertisement