envoy-proxy-1.8.0+git20181105-4.1.x86_64.rpm


Advertisement

Description

envoy-proxy - L7 proxy and communication bus

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename envoy-proxy-1.8.0+git20181105-4.1.x86_64.rpm
Package name envoy-proxy
Package version 1.8.0+git20181105
Package release 4.1
Package architecture x86_64
Package type rpm
Category Productivity/Networking/Web/Proxy
Homepage https://www.envoyproxy.io/
License Apache-2.0
Maintainer -
Download size 4.14 MB
Installed size 18.36 MB
Envoy is an L7 proxy and communication bus designed for large modern service
oriented architectures.

Alternatives

Package Version Architecture Repository
envoy-proxy - - -

Requires

Name Value
ld-linux-x86-64.so.2()(64bit) -
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) -
libabsl_base_libbase.so.0()(64bit) -
libabsl_base_libdynamic_annotations.so.0()(64bit) -
libabsl_base_libexception_safety_testing.so.0()(64bit) -
libabsl_base_libmalloc_internal.so.0()(64bit) -
libabsl_base_libspinlock_wait.so.0()(64bit) -
libabsl_base_libthrow_delegate.so.0()(64bit) -
libabsl_container_libhash_generator_testing.so.0()(64bit) -
libabsl_container_libraw_hash_set.so.0()(64bit) -
libabsl_debugging_libdebugging_internal.so.0()(64bit) -
libabsl_debugging_libdemangle_internal.so.0()(64bit) -
libabsl_debugging_libstacktrace.so.0()(64bit) -
libabsl_debugging_libsymbolize.so.0()(64bit) -
libabsl_hash_libcity.so.0()(64bit) -
libabsl_hash_libhash.so.0()(64bit) -
libabsl_numeric_libint128.so.0()(64bit) -
libabsl_strings_libinternal.so.0()(64bit) -
libabsl_strings_libstr_format_internal.so.0()(64bit) -
libabsl_strings_libstrings.so.0()(64bit) -
libabsl_synchronization_libgraphcycles_internal.so.0()(64bit) -
libabsl_synchronization_libper_thread_sem_test_common.so.0()(64bit) -
libabsl_synchronization_libsynchronization.so.0()(64bit) -
libabsl_time_internal_cctz_libcivil_time.so.0()(64bit) -
libabsl_time_internal_cctz_libtime_zone.so.0()(64bit) -
libabsl_time_libtest_util.so.0()(64bit) -
libabsl_time_libtime.so.0()(64bit) -
libabsl_types_libbad_any_cast_impl.so.0()(64bit) -
libabsl_types_libbad_optional_access.so.0()(64bit) -
libabsl_types_liboptional.so.0()(64bit) -
libc.so.6(GLIBC_2.18)(64bit) -
libcares.so.2()(64bit) -
libcircllhist.so.0.0.1()(64bit) -
libcrypto.so.0()(64bit) -
libcrypto.so.1.1()(64bit) -
libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) -
libdd_opentracing.so.0()(64bit) -
libdecrepit.so.0()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libevent-2.1.so.6()(64bit) -
libevent_pthreads-2.1.so.6()(64bit) -
libfmt.so.5()(64bit) -
libgtest.so()(64bit) -
libhttp_parser.so.2.7.1()(64bit) -
libjwt_verify_lib.so.0()(64bit) -
libluajit-5.1.so.2()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libnghttp2.so.14()(64bit) -
libprofiler.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.12)(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libpthread.so.0(GLIBC_2.3.3)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libssl.so.0()(64bit) -
libssl.so.1.1()(64bit) -
libssl.so.1.1(OPENSSL_1_1_0)(64bit) -
libtcmalloc.so.4()(64bit) -
libxxhash.so.0()(64bit) -
libyaml-cpp.so.0.6()(64bit) -
libz.so.1()(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
envoy-proxy = 1.8.0+git20181105-4.1
envoy-proxy(x86-64) = 1.8.0+git20181105-4.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package envoy-proxy-1.8.0+git20181105-4.1.x86_64.rpm
Source Package envoy-proxy-1.8.0+git20181105-4.1.src.rpm

Install Howto

Install envoy-proxy rpm package:

# zypper install envoy-proxy

Files

Path
/usr/bin/envoy-proxy
/usr/share/doc/packages/envoy-proxy/README.md
/usr/share/licenses/envoy-proxy/LICENSE

Changelog

2019-04-04 - Jan Engelhardt <jengelh@inai.de>
- openssl-devel should be pkgconfig(openssl)
2019-03-19 - Michal Rostecki <mrostecki@opensuse.org>
- Add patch which allows to use grpc 1.19.x.
* 0001-bazel-transport-sockets-Update-grpc-to-1.19.1.patch
- Use source packages of grpc-httpjson-transcoding, opentracing-cpp
and lightstep-tracer-cpp. (boo#1129568)
2019-03-12 - Bernhard Wiedemann <bwiedemann@suse.com>
- Use fixed date for reproducible builds (boo#1047218)
2019-02-26 - Micha? Rostecki <mrostecki@opensuse.org>
- Add upstream patch which allows to use spdlog 1.3.x.
* 0001-Upgrade-gabime-spdlog-dependency-to-1.3.0-5604.patch
2019-02-20 - Micha? Rostecki <mrostecki@opensuse.org>
- Add upstream patch which fixes build with Bazel 0.22.0.
* 0001-Remove-deprecated-Blaze-PACKAGE_NAME-macro-5330.patch
- Fix build with the newest bazel-rules-go.
2019-02-14 - Micha? Rostecki <mrostecki@opensuse.org>
- Stop bundling libraries and dependencies, use shared libraries
and *-source packages instead.
2018-10-31 - Micha? Rostecki <mrostecki@suse.de>
- Initial version 1.8.0+git20181105

See Also

Package Description
envy24control-0.6.0-17.1.i586.rpm Control tool for Envy24 (ice1712) based soundcards
envy24control-0.6.0-17.1.x86_64.rpm Control tool for Envy24 (ice1712) based soundcards
eog-3.32.1-1.1.i586.rpm Image Viewer for GNOME
eog-3.32.1-1.1.x86_64.rpm Image Viewer for GNOME
eog-devel-3.32.1-1.1.i586.rpm Development files for eog, an image viewer
eog-devel-3.32.1-1.1.x86_64.rpm Development files for eog, an image viewer
eog-lang-3.32.1-1.1.noarch.rpm Translations for package eog
eog-plugin-exif-display-3.26.3-1.2.i586.rpm Eog exif-display plugin
eog-plugin-exif-display-3.26.3-1.2.x86_64.rpm Eog exif-display plugin
eog-plugin-export-to-folder-3.26.3-1.2.i586.rpm Eog export to folder plugin
eog-plugin-export-to-folder-3.26.3-1.2.x86_64.rpm Eog export to folder plugin
eog-plugin-fit-to-width-3.26.3-1.2.i586.rpm Eog fit to width plugin
eog-plugin-fit-to-width-3.26.3-1.2.x86_64.rpm Eog fit to width plugin
eog-plugin-fullscreenbg-3.26.3-1.2.i586.rpm Eog fullscreenbg plugin
eog-plugin-fullscreenbg-3.26.3-1.2.x86_64.rpm Eog fullscreenbg plugin
Advertisement
Advertisement