ell-devel-0.18-1.1.i586.rpm


Advertisement

Description

ell-devel - Development files for the ELL wireless setup/crypto library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ell-devel-0.18-1.1.i586.rpm
Package name ell-devel
Package version 0.18
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage https://01.org/ell
License LGPL-2.1-or-later
Maintainer -
Download size 29.39 KB
Installed size 104.04 KB
The "Embedded Linux Library" implements an API for wireless
cryptography actions by using the kernel crypto API.
This subpackage contains libraries and header files for developing
applications that want to make use of ell.

Alternatives

Package Version Architecture Repository
ell-devel-0.18-1.1.x86_64.rpm 0.18 x86_64 openSUSE Oss
ell-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libell0 = 0.18

Provides

Name Value
ell-devel = 0.18-1.1
ell-devel(x86-32) = 0.18-1.1
pkgconfig(ell) = 0.18

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ell-devel-0.18-1.1.i586.rpm
Source Package ell-0.18-1.1.src.rpm

Install Howto

Install ell-devel rpm package:

# zypper install ell-devel

Files

Path
/usr/include/ell/base64.h
/usr/include/ell/cert.h
/usr/include/ell/checksum.h
/usr/include/ell/cipher.h
/usr/include/ell/dbus-client.h
/usr/include/ell/dbus-service.h
/usr/include/ell/dbus.h
/usr/include/ell/dhcp.h
/usr/include/ell/dir.h
/usr/include/ell/ecc.h
/usr/include/ell/ecdh.h
/usr/include/ell/ell.h
/usr/include/ell/file.h
/usr/include/ell/genl.h
/usr/include/ell/hashmap.h
/usr/include/ell/hwdb.h
/usr/include/ell/idle.h
/usr/include/ell/io.h
/usr/include/ell/key.h
/usr/include/ell/log.h
/usr/include/ell/main.h
/usr/include/ell/net.h
/usr/include/ell/netlink.h
/usr/include/ell/pem.h
/usr/include/ell/pkcs5.h
/usr/include/ell/plugin.h
/usr/include/ell/queue.h
/usr/include/ell/random.h
/usr/include/ell/ringbuf.h
/usr/include/ell/settings.h
/usr/include/ell/signal.h
/usr/include/ell/string.h
/usr/include/ell/strv.h
/usr/include/ell/test.h
/usr/include/ell/time.h
/usr/include/ell/timeout.h
/usr/include/ell/tls.h
/usr/include/ell/uintset.h
/usr/include/ell/utf8.h
/usr/include/ell/util.h
/usr/include/ell/uuid.h
/usr/lib/libell.so
/usr/lib/pkgconfig/ell.pc

Changelog

2019-04-04 - Alexei Sorokin <sor.alexei@meowr.ru>
- Update to version 0.18:
* Fix an issue with handling revocation of keys.
* Add support for the TLS Signature Algorithms extension.
* Add support for the TLS version range configuration.
* Add support for time utility functions.
- Remove unsigned-char.patch: fixed upstream.
2019-03-15 - Jan Engelhardt <jengelh@inai.de>
- Update to new upstream release 0.17
* Added support for TLS Supported Groups extension, TLS Hello
extension feature, and for ECC and ECDH functionality.
2019-01-31 - schwab@suse.de
- unsigned-char.patch: don't depend on signedness of char
2018-12-13 - Jan Engelhardt <jengelh@inai.de>
- Update to new upstream release 0.16
* Add support for watchdog notification handling from systemd.
* Add support for generic X.509 certificate utilities.
* Add support for using AEAD ciphers for TLS.
2018-11-18 - Jan Engelhardt <jengelh@inai.de>
- Update to new upstream release 0.15
* Fix an issue with signals not being registered properly.
2018-11-13 - Jan Engelhardt <jengelh@inai.de>
- Update to new upstream release 0.14
* Fix issue with TLS failure handling.
* Fix issue with loading empty settings file.
* Fix issue with generic netlink message sizes.
* Add support for filesystem watch functionality.
* Fix issue with missing filesystem watch notifications.
* Fix issue with buffer overrun and PBKDF2 support.
* Add support for string argument parsing.
* Fix issue with D-Bus subpath comparisons in object tree walk.
* Fix issue with D-Bus InterfacesAdded on new ObjectManager
addition.
* Fix issue with verifying total length of certificates.
* Fix issue with loading v2 and v3 formatted hwdb.bin files.
* Fix issue with handling EPOLLHUP and EPOLLERR in IO watch.
* Fix issue with closing of the fd inside IO watch handlers.
* Fix issue with initialization of struct keyctl_dh_params.
* Fix issue with unexported public API symbols.
* Fix issue with handling netlink error return values.
* Fix issue with handling hashmap removing of last entry.
* Fix issue with handling zero-length secret for PRF.
* Add support for directory watch interface.
* Fix issue with return value of l_getrandom_is_supported.
* Fix issue with supporting l_genl_family_set_unicast_handler.
* Fix issue with utilizing single shared signalfd file descriptor.
2018-06-05 - seife+obs@b1-systems.com
- update to version 0.5 (released 2018-05-05)
- ell >= 0.3 is required for new bluez versions
- ver 0.5:
- Fix issue with missing exported debug symbols.
- Add support for DHCP client library.
- ver 0.4:
- Fix issue with propagate AEAD cipher failures.
- Fix issue with AAD length and AEAD result reads.
- ver 0.3:
- Fix issue with IO handling and re-entrancy.
- Add support for D-Bus client proxy interface.
- ver 0.2:
- Add support for mainloop integration functions.
- Add support for PKCS#5 key derivation functions.
- Add support for additional checksum and cipher types.
- ver 0.1:
- Initial public release.
2016-11-11 - jengelh@inai.de
- Initial package (version 0~1304) for build.opensuse.org

See Also

Package Description
elua-1.20.7-14.6.i586.rpm LuaJIT bindings for the efl
elua-1.20.7-14.6.x86_64.rpm LuaJIT bindings for the efl
emacs-26.2-1.1.i586.rpm GNU Emacs Base Package
emacs-26.2-1.1.x86_64.rpm GNU Emacs Base Package
emacs-apel-10.8-2.3.noarch.rpm A Portable Emacs Library
emacs-auctex-12.1-2.4.noarch.rpm AUC TeX: An Emacs Extension
emacs-color-theme-6.6.0-1.4.noarch.rpm Color themes for emacs
emacs-completion-golang-0.0.0+git20161123.5070dac-2.4.i586.rpm Golang autocompletion files for Emacs
emacs-completion-golang-0.0.0+git20161123.5070dac-2.4.x86_64.rpm Golang autocompletion files for Emacs
emacs-el-26.2-1.1.noarch.rpm Several Lisp Files for GNU Emacs
emacs-flim-1.14.9-1.5.noarch.rpm An Emacs Library for MIME
emacs-info-26.2-1.1.noarch.rpm Info files for GNU Emacs
emacs-nox-26.2-1.1.i586.rpm GNU Emacs-nox: An Emacs Binary without X Window System Support
emacs-nox-26.2-1.1.x86_64.rpm GNU Emacs-nox: An Emacs Binary without X Window System Support
emacs-plugin-devhelp-3.32.0-1.1.i586.rpm Devhelp plugin for Emacs
Advertisement
Advertisement