debootstrap-1.0.97-1.2.noarch.rpm


Advertisement

Description

debootstrap - Bootstrap a basic Debian system

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename debootstrap-1.0.97-1.2.noarch.rpm
Package name debootstrap
Package version 1.0.97
Package release 1.2
Package architecture noarch
Package type rpm
Category Development/Tools/Other
Homepage https://packages.debian.org/debootstrap
License MIT
Maintainer -
Download size 78.24 KB
Installed size 277.95 KB
debootstrap is used to create a Debian base system from scratch,
without requiring the availability of dpkg or apt. It does this
by downloading .deb files from a mirror site, and carefully
unpacking them into a directory which can eventually be chrooted
into.

Alternatives

Package Version Architecture Repository
debootstrap - - -

Requires

Name Value
wget -

Provides

Name Value
debootstrap = 1.0.97-1.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package debootstrap-1.0.97-1.2.noarch.rpm
Source Package debootstrap-1.0.97-1.2.src.rpm

Install Howto

Install debootstrap rpm package:

# zypper install debootstrap

Files

Path
/usr/sbin/debootstrap
/usr/share/debootstrap/functions
/usr/share/debootstrap/scripts/aequorea
/usr/share/debootstrap/scripts/artful
/usr/share/debootstrap/scripts/bartholomea
/usr/share/debootstrap/scripts/bionic
/usr/share/debootstrap/scripts/breezy
/usr/share/debootstrap/scripts/bullseye
/usr/share/debootstrap/scripts/buster
/usr/share/debootstrap/scripts/chromodoris
/usr/share/debootstrap/scripts/dapper
/usr/share/debootstrap/scripts/dasyatis
/usr/share/debootstrap/scripts/debian-common
/usr/share/debootstrap/scripts/edgy
/usr/share/debootstrap/scripts/etch
/usr/share/debootstrap/scripts/etch-m68k
/usr/share/debootstrap/scripts/feisty
/usr/share/debootstrap/scripts/gutsy
/usr/share/debootstrap/scripts/hardy
/usr/share/debootstrap/scripts/hoary
/usr/share/debootstrap/scripts/hoary.buildd
/usr/share/debootstrap/scripts/intrepid
/usr/share/debootstrap/scripts/jaunty
/usr/share/debootstrap/scripts/jessie
/usr/share/debootstrap/scripts/jessie-kfreebsd
/usr/share/debootstrap/scripts/kali
/usr/share/debootstrap/scripts/kali-dev
/usr/share/debootstrap/scripts/kali-last-snapshot
/usr/share/debootstrap/scripts/kali-rolling
/usr/share/debootstrap/scripts/karmic
/usr/share/debootstrap/scripts/lenny
/usr/share/debootstrap/scripts/lucid
/usr/share/debootstrap/scripts/maverick
/usr/share/debootstrap/scripts/natty
/usr/share/debootstrap/scripts/oldoldstable
/usr/share/debootstrap/scripts/oldstable
/usr/share/debootstrap/scripts/oneiric
/usr/share/debootstrap/scripts/potato
/usr/share/debootstrap/scripts/precise
/usr/share/debootstrap/scripts/quantal
/usr/share/debootstrap/scripts/raring
/usr/share/debootstrap/scripts/sarge
/usr/share/debootstrap/scripts/sarge.buildd
/usr/share/debootstrap/scripts/sarge.fakechroot
/usr/share/debootstrap/scripts/saucy
/usr/share/debootstrap/scripts/sid
/usr/share/debootstrap/scripts/squeeze
/usr/share/debootstrap/scripts/stable
/usr/share/debootstrap/scripts/stretch
/usr/share/debootstrap/scripts/testing
/usr/share/debootstrap/scripts/trusty
/usr/share/debootstrap/scripts/unstable
/usr/share/debootstrap/scripts/utopic
/usr/share/debootstrap/scripts/vivid
/usr/share/debootstrap/scripts/warty
/usr/share/debootstrap/scripts/warty.buildd
/usr/share/debootstrap/scripts/wheezy
/usr/share/debootstrap/scripts/wily
/usr/share/debootstrap/scripts/woody
/usr/share/debootstrap/scripts/woody.buildd
/usr/share/debootstrap/scripts/xenial
/usr/share/debootstrap/scripts/yakkety
/usr/share/debootstrap/scripts/zesty
/usr/share/doc/packages/debootstrap/README
/usr/share/doc/packages/debootstrap/TODO
/usr/share/doc/packages/debootstrap/changelog
/usr/share/licenses/debootstrap/copyright
/usr/share/man/man8/debootstrap.8.gz

Changelog

2017-06-28 - sor.alexei@meowr.ru.
- Update version to 1.0.97 (changes since 1.0.90):
* Avoid the "type" shell command (deb#860545).
* Add (Ubuntu) bionic as a symlink to gutsy.
* scripts/gutsy: Incorporate changes from Ubuntu:
+ Synch from scripts/sid.
+ Fix debootstrap --variant=fakechroot failure because
initscripts is no longer part of the base system.
* Use force_md5 for breezy, dapper and edgy (deb#659360,
deb#676373). Now you can create Ubuntu breezy/dapper/edgy chroot.
* Change repository URI for old Ubuntu releases (deb#676370,
deb#839073).
Archived Ubuntu releases are at old-releases.ubuntu.com/ubuntu
* Set correct keyring and default mirror for old debian releases.
Now you can fetch popato/woody/sarge/etch/lenny/squeeze if you
want (deb#891404, deb#600647, deb#792729).
* Avoid pre-exist directory causes failure (deb#864734).
* Split common code from scripts/sid to scripts/debian-common and
share it between distributions (deb#798562).
* Don't let host PATH leak into the target commands. It works on
chroots that have different PATH like Arch Linux and Fedora
(deb#718632, deb#770658, deb#890418).
* Escape spaces to fix debootstrap on path contains space fails
(deb#586158, deb#762431).
* Add warning if file specified via --keyring does not exist
(deb#754318, deb#775474).
* Avoid unnecessary keyring warning with --second-stage option
(deb#734324).
* Output warning if falling back to sha1 (deb#775444).
* Prevent unintended removal with --print-debs option
(deb#833525).
* Add scripts for Kali Linux (deb#798564).
* Improve manpage description for --{unpack,make}-tarball options
(deb#563647).
* Fix multiple components usage for --foreign/--second-stage
(deb#806780).
* Try to auto-detect proxy if available
(e.g. squid-deb-proxy-client) (deb#732628).
* Handle existing /dev (deb#872577).
* Create /dev/console as same as previous (deb#872059).
* Do not ignore HTTPS mirror setting (deb#893954).
* Improve manpage "what is calls a Debian base system" (deb#872948).
* Improve the error message when download fails (deb#866401).
* Use wget --non-verbose option instead of --quiet.
* Improve error message on Release signed by unknown key
(deb#698677).
* Add a --cache-dir feature (deb#844118)
It is enabled by default and uses /var/cache/apt/archives as a
default value.
* Use arch-test if installed to check whether second stage is
possible (deb#826709).
* Fix boostrapping libvirt LXC containers (deb#890419).
* Use "command -v apt-config" to check for apt-config's presence
(deb#895466).
* Drop default value for the --cache-dir parameter.
* Forbid the usage of non-empty directories with --print-debs and
- -make-tarball.
* Do not use HTTPS for the Kali bootstrap script.
- Add a missing wget depenendency.

See Also

Package Description
dee-devel-1.2.7+bzr20170616-2.10.i586.rpm Development files for dee
dee-devel-1.2.7+bzr20170616-2.10.x86_64.rpm Development files for dee
deepin-editor-1.2.6.3-1.2.i586.rpm A text editor for the Deepin environment
deepin-editor-1.2.6.3-1.2.x86_64.rpm A text editor for the Deepin environment
deepin-editor-lang-1.2.6.3-1.2.noarch.rpm Translations for package deepin-editor
deepin-movie-3.2.17-1.1.i586.rpm Deepin Video Players
deepin-movie-3.2.17-1.1.x86_64.rpm Deepin Video Players
deepin-movie-devel-3.2.17-1.1.i586.rpm Development tools for deepin movie
deepin-movie-devel-3.2.17-1.1.x86_64.rpm Development tools for deepin movie
deepin-movie-lang-3.2.17-1.1.noarch.rpm Translations for package deepin-movie
deepin-music-libnetease-meta-search-3.1.17.1-1.1.i586.rpm Libnetease integration for the Deepin Music Player
deepin-music-libnetease-meta-search-3.1.17.1-1.1.x86_64.rpm Libnetease integration for the Deepin Music Player
deepin-music-player-3.1.17.1-1.1.i586.rpm Deepin Music Player
deepin-music-player-3.1.17.1-1.1.x86_64.rpm Deepin Music Player
deepin-system-monitor-1.4.8.1-1.1.i586.rpm A more user-friendly system monitor
Advertisement
Advertisement