cups-pk-helper-0.2.6-3.3.i586.rpm


Advertisement

Description

cups-pk-helper - PolicyKit helper to configure cups with fine-grained privileges

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename cups-pk-helper-0.2.6-3.3.i586.rpm
Package name cups-pk-helper
Package version 0.2.6
Package release 3.3
Package architecture i586
Package type rpm
Category Hardware/Printing
Homepage http://www.freedesktop.org/software/cups-pk-helper/releases/
License GPL-2.0-or-later
Maintainer -
Download size 66.18 KB
Installed size 245.24 KB
This package provides a PolicyKit helper to configure cups with
fine-grained privileges. For example, it's possible to let users
enable/disable printers without requiring a password, while still
requiring a password for editing printer settings.

Alternatives

Package Version Architecture Repository
cups-pk-helper-0.2.6-48.24.x86_64.rpm 0.2.6 x86_64 GNOME Next
cups-pk-helper-0.2.6-48.24.i586.rpm 0.2.6 i586 GNOME Next
cups-pk-helper-0.2.6-45.18.x86_64.rpm 0.2.6 x86_64 GNOME Factory
cups-pk-helper-0.2.6-45.18.i586.rpm 0.2.6 i586 GNOME Factory
cups-pk-helper-0.2.6-3.3.x86_64.rpm 0.2.6 x86_64 openSUSE Oss
cups-pk-helper - - -

Requires

Name Value
cups -
libc.so.6(GLIBC_2.4) -
libcups.so.2 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libpolkit-gobject-1.so.0 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -

Provides

Name Value
cups-pk-helper = 0.2.6-3.3
cups-pk-helper(x86-32) = 0.2.6-3.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package cups-pk-helper-0.2.6-3.3.i586.rpm
Source Package cups-pk-helper-0.2.6-3.3.src.rpm

Install Howto

Install cups-pk-helper rpm package:

# zypper install cups-pk-helper

Files

Path
/etc/dbus-1/system.d/org.opensuse.CupsPkHelper.Mechanism.conf
/usr/lib/cups-pk-helper-mechanism
/usr/share/dbus-1/system-services/org.opensuse.CupsPkHelper.Mechanism.service
/usr/share/doc/packages/cups-pk-helper/AUTHORS
/usr/share/doc/packages/cups-pk-helper/NEWS
/usr/share/doc/packages/cups-pk-helper/README
/usr/share/licenses/cups-pk-helper/COPYING
/usr/share/polkit-1/actions/org.opensuse.cupspkhelper.mechanism.policy

Changelog

2018-02-28 - dimstar@opensuse.org
- Modernize spec-file by calling spec-cleaner
2016-02-18 - dimstar@opensuse.org
- Update to version 0.2.6:
+ Enable UTF-8 chars in names and texts (bsc#1033742, rh#982727).
+ Introduce CPH_PATH_MAX.
+ Add function for printer renaming.
+ Updated translations.
2013-06-16 - zaitor@opensuse.org
- Update to version 0.2.5:
+ Revert "Be stricter when validating printer names".
+ Updated translations.
2012-11-28 - dimstar@opensuse.org
- Add cups requires: Without cups being installed, cups-pk-helper
can't do any of its tasks (bnc#783865).
2012-10-13 - zaitor@opensuse.org
- Update to version 0.2.4:
+ Fix detection of CUPS version.
2012-10-12 - vuntz@opensuse.org
- Update to version 0.2.3:
+ Fix security flaw in cupsGetFile/cupsPutFile wrappers
(CVE-2012-4510, bnc#783488)
+ Escape printer/class names before putting them in URIs
+ Be stricter when validating printer names
+ Fix build with CUPS >= 1.6
+ New/updated translations.
2012-03-16 - praful.johari@gmail.com
- Update to version 0.2.2:
+ Add PrinterAddOption D-Bus method.
+ Set requesting-user-name tag in requests.
+ Code cleanups.
+ Build fixes and improvements.
+ New/updated translations.
2011-09-26 - vuntz@opensuse.org
- Update to version 0.2.1:
+ Do not pass ppd file if empty when adding a printer.
+ Accept NULL for ppd file as valid when adding a printer.
+ Allow inactive/any users to authenticate.
+ Updated translations.
2011-09-18 - jengelh@medozas.de
- Remove redundant tags/sections from specfile
- Use %_smp_mflags for parallel build
2011-07-25 - vuntz@opensuse.org
- Update to version 0.2.0:
+ Port to GDBus.
+ Stop using deprecated polkit API.
+ Drop gthread handling.
+ Add org.freedesktop.DBus.Deprecated annotation to JobCancel.
+ Code cleanups.
+ Build system improvements.
+ Updated translations.
- Remove dbus-1-glib-devel BuildRequires, now unneeded.

See Also

Package Description
cups-pk-helper-lang-0.2.6-3.3.noarch.rpm Translations for package cups-pk-helper
cura-3.6.0-1.2.noarch.rpm 3D printer control software
cura-engine-3.6.0-2.1.i586.rpm 3D printer control software
cura-engine-3.6.0-2.1.x86_64.rpm 3D printer control software
cura-engine-lulzbot-3.6.5-1.1.i586.rpm 3D printer control software
cura-engine-lulzbot-3.6.5-1.1.x86_64.rpm 3D printer control software
cura-fdm-materials-3.6.0-1.2.noarch.rpm FDM material database
cura-lulzbot-3.6.5-1.1.noarch.rpm 3D printer control software
cura1-lulzbot-21.06-1.4.i586.rpm 3D printing software aimed at RepRaps, Ultimaker and LulzBot
cura1-lulzbot-21.06-1.4.x86_64.rpm 3D printing software aimed at RepRaps, Ultimaker and LulzBot
curl-7.64.1-1.1.i586.rpm A Tool for Transferring Data from URLs
curl-7.64.1-1.1.x86_64.rpm A Tool for Transferring Data from URLs
curlftpfs-0.9.2-63.10.i586.rpm Filesystem for mounting FTP hosts using FUSE and libcurl
curlftpfs-0.9.2-63.10.x86_64.rpm Filesystem for mounting FTP hosts using FUSE and libcurl
cutecom-0.51.0-1.2.i586.rpm A graphical serial terminal
Advertisement
Advertisement