courier-authlib-0.68.0-2.1.x86_64.rpm


Advertisement

Description

courier-authlib - Courier authentication library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename courier-authlib-0.68.0-2.1.x86_64.rpm
Package name courier-authlib
Package version 0.68.0
Package release 2.1
Package architecture x86_64
Package type rpm
Category Productivity/Networking/Email/Servers
Homepage http://www.courier-mta.org/imap/
License SUSE-GPL-3.0-with-openssl-exception
Maintainer -
Download size 134.39 KB
Installed size 485.57 KB
The Courier authentication library provides authentication services for
other Courier applications.

Alternatives

Package Version Architecture Repository
courier-authlib-0.68.0-2.1.i586.rpm 0.68.0 i586 openSUSE Oss
courier-authlib - - -

Requires

Name Value
/usr/bin/expect -
/usr/bin/perl -
coreutils -
expect -
libc.so.6(GLIBC_2.15)(64bit) -
libcrypt.so.1()(64bit) -
libcrypt.so.1(XCRYPT_2.0)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgdbm.so.6()(64bit) -
libltdl.so.7()(64bit) -
libpam.so.0()(64bit) -
libpam.so.0(LIBPAM_1.0)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
systemd -

Provides

Name Value
config(courier-authlib) = 0.68.0-2.1
courier-authlib = 0.68.0-2.1
courier-authlib(x86-64) = 0.68.0-2.1
libauthcustom.so()(64bit) -
libauthpam.so()(64bit) -
libcourierauth.so()(64bit) -
libcourierauthcommon.so()(64bit) -
libcourierauthsasl.so()(64bit) -
libcourierauthsaslclient.so()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package courier-authlib-0.68.0-2.1.x86_64.rpm
Source Package courier-authlib-0.68.0-2.1.src.rpm

Install Howto

Install courier-authlib rpm package:

# zypper install courier-authlib

Files

Path
/etc/authlib/authdaemonrc.dist
/etc/authlib/authldaprc.dist
/etc/authlib/authmysqlrc.dist
/etc/authlib/authpgsqlrc.dist
/etc/authlib/authsqliterc.dist
/run/courier-authlib/
/usr/lib/courier-authlib/authdaemond
/usr/lib/courier-authlib/authmigrate
/usr/lib/courier-authlib/authsystem.passwd
/usr/lib/courier-authlib/makedatprog
/usr/lib/courier-authlib/sysconftool
/usr/lib/systemd/system/courier-authdaemon.service
/usr/lib/tmpfiles.d/courier-authlib.conf
/usr/lib64/libauthcustom.so
/usr/lib64/libauthpam.so
/usr/lib64/libcourierauth.so
/usr/lib64/libcourierauthcommon.so
/usr/lib64/libcourierauthsasl.so
/usr/lib64/libcourierauthsaslclient.so
/usr/sbin/authdaemond
/usr/sbin/authenumerate
/usr/sbin/authpasswd
/usr/sbin/authtest
/usr/sbin/courierlogger
/usr/sbin/rccourier-authdaemon
/usr/share/doc/packages/courier-authlib/AUTHORS
/usr/share/doc/packages/courier-authlib/COPYING
/usr/share/doc/packages/courier-authlib/COPYING.GPL
/usr/share/doc/packages/courier-authlib/ChangeLog
/usr/share/doc/packages/courier-authlib/NEWS
/usr/share/doc/packages/courier-authlib/README
/usr/share/doc/packages/courier-authlib/README.authdebug.html
/usr/share/doc/packages/courier-authlib/README.authmysql.html
/usr/share/doc/packages/courier-authlib/README.authpostgres.html
/usr/share/doc/packages/courier-authlib/README.authsqlite.html
/usr/share/doc/packages/courier-authlib/README.html
/usr/share/doc/packages/courier-authlib/README_authlib.html
/usr/share/doc/packages/courier-authlib/authldap.schema
/usr/share/man/man1/authpasswd.1.gz
/usr/share/man/man1/authtest.1.gz
/usr/share/man/man1/courierlogger.1.gz

Changelog

2019-04-09 - Christophe Giboudeaux <christophe@krop.fr>
- Add the missing dependencies for Tumbleweed.
2017-12-04 - suse+build@de-korte.org
- update to 0.68.0
* authldaplib.cpp: Rewrite authldap in modern C++. Autodetect
and automatically reload authldaprc when it is changed. No server
restart is required.
* authldaplib.cpp (operator): Fix compilation warning.
* checkpassword.c (do_authcheckpassword): Check for a null return
value from crypt().
* authsqlite, authmysql, authpgsql: Rewrite these modules in
modern C++. Autodetect and automatically reload the configuration
file when it's changed, no server restart is needed.
* userdb/userdbpw.c (main): Use bcrypt_gensalt() on OpenBSD
* courierauth.h: Move declarations from cramlib.h into courierauth.h,
exporting them as part of the public API.
* configure.ac: Rebuild against updated courier-unicode API.
2017-04-11 - jengelh@inai.de
- Drop redundant %clean section. Dissolve %__-type macros.
2017-03-17 - kukuk@suse.com
- Don't install init script if we use systemd
2017-02-18 - kukuk@suse.com
- Don't call insserv if we use systemd
2016-05-16 - chris@computersalat.de
- udpate to 0.66.4
* authgetconfig.c (authgetconfig): avoid invalid memory read.
2015-08-05 - chris@computersalat.de
- update to 0.66.3
* authdaemon.c: auth_callback_default_autocreate, default callback
used by clients that autocreates a home directory, if one does not
exist already.
- update to 0.66.2
* Update to courier-unicode 1.2.
* liblock, couriertls: fix compilation for OpenBSD -- based on a
patch from Giovanni Bechis <giovanni@paclan.it>.
* checkpassword.c (safe_strcmp): Fix bug introduced in 2014-04-27.
* courier.spec.in: Update to use systemd macros.
* Check for NULL return value from crypt().
* Factored out the unicode library into a separate package.
- add BuildRequires courier-unicode-devel
- fix deps (SLE_11_SP4) to build againts pgsql >= 9.1
2014-11-09 - Led <ledest@gmail.com>
- fix bashism in preun script
2014-07-31 - dimstar@opensuse.org
- Rename rpmlintrc to %{name}-rpmlintrc.
Follow the packaging guidelines.
2014-03-18 - chris@computersalat.de
- fix missing LOGGEROPTS in authdaemonrc
* added patch courier-authlib-authdaemonrc.patch

See Also

Package Description
courier-authlib-devel-0.68.0-2.1.i586.rpm Development libraries for the Courier authentication library
courier-authlib-devel-0.68.0-2.1.x86_64.rpm Development libraries for the Courier authentication library
courier-authlib-ldap-0.68.0-2.1.i586.rpm LDAP support for the Courier authentication library
courier-authlib-ldap-0.68.0-2.1.x86_64.rpm LDAP support for the Courier authentication library
courier-authlib-mysql-0.68.0-2.1.i586.rpm MySQL support for the Courier authentication library
courier-authlib-mysql-0.68.0-2.1.x86_64.rpm MySQL support for the Courier authentication library
courier-authlib-pgsql-0.68.0-2.1.i586.rpm PostgreSQL support for the Courier authentication library
courier-authlib-pgsql-0.68.0-2.1.x86_64.rpm PostgreSQL support for the Courier authentication library
courier-authlib-pipe-0.68.0-2.1.i586.rpm Pipe support for the Courier authentication library
courier-authlib-pipe-0.68.0-2.1.x86_64.rpm Pipe support for the Courier authentication library
courier-authlib-sqlite-0.68.0-2.1.i586.rpm SQLite support for the Courier authentication library
courier-authlib-sqlite-0.68.0-2.1.x86_64.rpm SQLite support for the Courier authentication library
courier-authlib-userdb-0.68.0-2.1.i586.rpm Userdb support for the Courier authentication library
courier-authlib-userdb-0.68.0-2.1.x86_64.rpm Userdb support for the Courier authentication library
courier-imap-4.18.2-2.2.i586.rpm An IMAP and POP3 Server for Maildir MTAs
Advertisement
Advertisement