corosync-2.4.4-3.6.i586.rpm


Advertisement

Description

corosync - The Corosync Cluster Engine and Application Programming Interfaces

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename corosync-2.4.4-3.6.i586.rpm
Package name corosync
Package version 2.4.4
Package release 3.6
Package architecture i586
Package type rpm
Category Productivity/Clustering/HA
Homepage http://corosync.github.io/corosync/
License BSD-3-Clause
Maintainer -
Download size 198.72 KB
Installed size 465.89 KB
This package contains the Corosync Cluster Engine Executive, several default
APIs and libraries, default configuration files, and an init script.

Alternatives

Package Version Architecture Repository
corosync-2.4.4-3.6.x86_64.rpm 2.4.4 x86_64 openSUSE Oss
corosync - - -

Requires

Name Value
/bin/bash -
/sbin/chkconfig -
/usr/sbin/useradd -
libc.so.6(GLIBC_2.28) -
libcfg.so.6 -
libcfg.so.6(COROSYNC_CFG_0.82) -
libcfg6 = 2.4.4-3.6
libcmap.so.4 -
libcmap.so.4(COROSYNC_CMAP_1.0) -
libcmap4 = 2.4.4-3.6
libcorosync_common.so.4 -
libcorosync_common4 = 2.4.4-3.6
libcpg.so.4 -
libcpg.so.4(COROSYNC_CPG_1.0) -
libcpg4 = 2.4.4-3.6
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libqb.so.20 -
libquorum.so.5 -
libquorum.so.5(COROSYNC_QUORUM_1.0) -
libquorum5 = 2.4.4-3.6
libsam4 = 2.4.4-3.6
libtotem_pg.so.5 -
libtotem_pg5 = 2.4.4-3.6
libvotequorum.so.8 -
libvotequorum.so.8(COROSYNC_VOTEQUORUM_1.0) -
libvotequorum8 = 2.4.4-3.6
mozilla-nss-tools -
systemd -

Provides

Name Value
config(corosync) = 2.4.4-3.6
corosync = 2.4.4-3.6
corosync(x86-32) = 2.4.4-3.6

Conflicts

Name Value
openais <= 0.89
openais < 1.2
openais-devel <= 0.89

Obsoletes

Name Value
openais < 1.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package corosync-2.4.4-3.6.i586.rpm
Source Package corosync-2.4.4-3.6.src.rpm

Install Howto

Install corosync rpm package:

# zypper install corosync

Files

Path
/etc/corosync/
/etc/corosync/uidgid.d/
/usr/bin/corosync-blackbox
/usr/lib/corosync/upgrade.sh
/usr/lib/systemd/system/corosync-notifyd.service
/usr/lib/systemd/system/corosync.service
/usr/lib/tmpfiles.d/corosync-notifyd
/usr/sbin/corosync
/usr/sbin/corosync-cfgtool
/usr/sbin/corosync-cmapctl
/usr/sbin/corosync-cpgtool
/usr/sbin/corosync-keygen
/usr/sbin/corosync-notifyd
/usr/sbin/corosync-quorumtool
/usr/sbin/rccorosync
/usr/sbin/rccorosync-notifyd
/usr/share/corosync/corosync
/usr/share/corosync/corosync-notifyd
/usr/share/doc/corosync/AUTHORS
/usr/share/doc/corosync/INSTALL
/usr/share/doc/corosync/LICENSE
/usr/share/doc/corosync/README.recovery
/usr/share/doc/corosync/SECURITY
/usr/share/doc/packages/corosync/LICENSE
/usr/share/doc/packages/corosync/SECURITY
/usr/share/doc/packages/corosync/corosync.conf.example
/usr/share/doc/packages/corosync/corosync.conf.example.udpu
/usr/share/fillup-templates/sysconfig.corosync
/usr/share/man/man5/corosync.conf.5.gz
/usr/share/man/man5/votequorum.5.gz
/usr/share/man/man8/cmap_keys.8.gz
/usr/share/man/man8/corosync-blackbox.8.gz
/usr/share/man/man8/corosync-cfgtool.8.gz
/usr/share/man/man8/corosync-cmapctl.8.gz
/usr/share/man/man8/corosync-cpgtool.8.gz
/usr/share/man/man8/corosync-keygen.8.gz
/usr/share/man/man8/corosync-notifyd.8.gz
/usr/share/man/man8/corosync-quorumtool.8.gz
/usr/share/man/man8/corosync.8.gz
/usr/share/man/man8/corosync_overview.8.gz
/var/lib/corosync/
/var/log/cluster/

Changelog

2018-05-02 - bliu@suse.com
- cpg: Inform clients about left nodes during pause(bsc#1091593)
Added: 0012-cpg-Inform-clients-about-left-nodes-during-pause.patch
2018-04-26 - bliu@suse.com
- NSS_NoDB_Init: the parameter is reserved, must be NULL(bsc#1090996)
Added: 0011-NSS_NoDB_Init-the-parameter-is-reserved-must-be-NULL.patch
2018-04-17 - bliu@suse.com
- corosync-2.4.4 is available now(bsc#1089836)
man:fix in corosync-qdevice.8
quorumtool: remove duplicated help message
cfg: nodeid should be unsigned int
coroparse: Use readdir instead of readdir_r
wd: fix snprintf warnings
Fix compile errors in qdevice on FreeBSD
qdevice: mv free(str) after port validation
Fix various typos
Fix typo: recomended -> recommended
man: support SOURCE_DATE_EPOCH
configure: add --with-initconfigdir option
Use static case blocks to determine distro flavor
Use RuntimeDirectory instead of tmpfiles.d
coroparse: Do not convert empty uid, gid to 0
sam: Fix snprintf compiler warnings
quorumtool: Use full buffer size in snprintf
man: Add note about qdevice parallel cmds start
sync: Remove unneeded determine sync code
sync: Call sync_init of all services at once
corosync.conf: publicize nodelist.node.name
totemudp[u]: Drop truncated packets on receive
logging: Make blackbox configurable
logging: Close before and open blackbox after fork
init: Quote subshell result properly
blackbox: Quote subshell result properly
qdevice: quote certutils scripts properly
sam_test_agent: Remove unused assignment
qdevice: Fix NULL pointer dereference
quorumtool: Don't set our_flags without v_handle
qdevice: Nodelist is set into string not array
qdevice: Check if user_data can be dereferenced
qdevice: Add safer wrapper of strtoll
qdevice: Replace strtol by strtonum
qnetd: Replace strtol by strtonum
main: Set errno before calling of strtol
totemcrypto: Implement bad crypto header guess
cpg: Use list_del instead of qb_list_del
totemcrypto: Check length of the packet
totemsrp: Implement sanity checks of received msgs
totemsrp: Check join and leave msg length
totemudp: Check lenght of message to sent
qdevice msgio: Fix reading of msg longer than i32
logsys: Avoid redundant callsite section checking
man: corosync-qdevice: fix formatting vs. punctuation
man: corosync-qdevice: some more stylistics
man: fix cpg_mcast_joined.3.in
libcpg: Fix issue with partial big packet assembly
totempg: Fix fragmentation segfault
totempg: use iovec[i].iov_len instead of copy_len
totempg: Fix corrupted messages
cpg: Handle fragmented message sending interrupt
corosync.aug: Add missing options
systemd: Delete unnecessary soft_margin
Added:
corosync-2.4.4.tar.gz
0010-qdevice-net-instance.c-optarg-should-be-str.patch
Deleted:
0007-sync-Call-sync_init-of-all-services-at-once.patch
0008-wd-fix-snprintf-warnings.patch
0009-add-config-for-corosync-qnetd.patch
0010-qdevice-mv-free-str-after-port-validation.patch
0011-libcpg-Fix-issue-with-partial-big-packet-assembly.patch
0012-totemudp-u-Drop-truncated-packets-on-receive.patch
0013-logging-Make-blackbox-configurable.patch
0014-logging-Close-before-and-open-blackbox-after-fork.patch
0015-coverity-fixes.patch
0018-bsc#1089346-corosync-Integer-overflow-in-totemcrypto.patch
corosync-2.4.3.tar.gz
Renamed:
0009-add-config-for-corosync-qnetd.patch -> 0007-add-config-for-corosync-qnetd.patch
0016-bsc#1083561-upgrade-from-1-x-y.patch -> 0008-bsc#1083561-upgrade-from-1-x-y.patch
0017-bsc#1088619-add-version.patch -> 0009-bsc#1088619-add-version.patch
2018-04-13 - bliu@suse.com
-  (CVE-2018-1084) VUL-0: CVE-2018-1084: corosync: Integer overflow in totemcrypto(bsc#1089346)
Added: 0018-bsc#1089346-corosync-Integer-overflow-in-totemcrypto.patch
2018-04-10 - bliu@suse.com
- UNKNOWN version in corosync pkg-config(bsc#1088619)
Added: 0017-bsc#1088619-add-version.patch

See Also

Package Description
corosync-qdevice-2.4.4-3.6.i586.rpm The Corosync Cluster Engine Qdevice
corosync-qdevice-2.4.4-3.6.x86_64.rpm The Corosync Cluster Engine Qdevice
corosync-qnetd-2.4.4-3.6.i586.rpm The Corosync Cluster Engine Qdevice Network Daemon
corosync-qnetd-2.4.4-3.6.x86_64.rpm The Corosync Cluster Engine Qdevice Network Daemon
corosync-testagents-2.4.4-3.6.i586.rpm The Corosync Cluster Engine Test Agents
corosync-testagents-2.4.4-3.6.x86_64.rpm The Corosync Cluster Engine Test Agents
courier-authlib-0.68.0-2.1.i586.rpm Courier authentication library
courier-authlib-0.68.0-2.1.x86_64.rpm Courier authentication library
courier-authlib-devel-0.68.0-2.1.i586.rpm Development libraries for the Courier authentication library
courier-authlib-devel-0.68.0-2.1.x86_64.rpm Development libraries for the Courier authentication library
courier-authlib-ldap-0.68.0-2.1.i586.rpm LDAP support for the Courier authentication library
courier-authlib-ldap-0.68.0-2.1.x86_64.rpm LDAP support for the Courier authentication library
courier-authlib-mysql-0.68.0-2.1.i586.rpm MySQL support for the Courier authentication library
courier-authlib-mysql-0.68.0-2.1.x86_64.rpm MySQL support for the Courier authentication library
courier-authlib-pgsql-0.68.0-2.1.i586.rpm PostgreSQL support for the Courier authentication library
Advertisement
Advertisement