conky-1.10.8-1.4.i586.rpm


Advertisement

Description

conky - Lightweight System Monitor

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename conky-1.10.8-1.4.i586.rpm
Package name conky
Package version 1.10.8
Package release 1.4
Package architecture i586
Package type rpm
Category System/Monitoring
Homepage https://github.com/brndnmtthws/conky
License GPL-3.0-or-later AND LGPL-3.0-or-later AND MIT
Maintainer -
Download size 383.20 KB
Installed size 1.18 MB
Conky is an advanced, highly configurable system monitor for X.
This package is built with support for:
- xmms2

Alternatives

Package Version Architecture Repository
conky-1.11.4-9.2.i586.rpm 1.11.4 i586 Packman
conky-1.11.4-9.2.x86_64.rpm 1.11.4 x86_64 Packman
conky-1.10.8-1.4.x86_64.rpm 1.10.8 x86_64 openSUSE Oss
conky - - -

Requires

Name Value
/bin/bash -
/usr/bin/lua5.1 -
fontawesome-fonts -
imlib2-loaders -
libImlib2.so.1 -
libX11.so.6 -
libXdamage.so.1 -
libXext.so.6 -
libXfixes.so.3 -
libXft.so.2 -
libXinerama.so.1 -
libc.so.6(GLIBC_2.28) -
libcairo.so.2 -
libcurl.so.4 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libgobject-2.0.so.0 -
libical.so.3 -
libircclient.so.1 -
libiw.so.30 -
liblua5.1.so.5 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libm.so.6(GLIBC_2.27) -
libmariadb.so.3 -
libmariadb.so.3(libmysqlclient_18) -
libmicrohttpd.so.12 -
libncurses.so.6 -
libncurses.so.6(NCURSEST6_5.7.20081102) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpulse.so.0 -
libpulse.so.0(PULSE_0) -
librsvg-2.so.2 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.3) -
libstdc++.so.6(CXXABI_1.3.5) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.22) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libtinfo.so.6 -
libtinfo.so.6(NCURSES6_TINFO_5.7.20081102) -
libtolua++-5.1.so.1 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.6.0) -

Provides

Name Value
config(conky) = 1.10.8-1.4
conky = 1.10.8-1.4
conky(x86-32) = 1.10.8-1.4
conky-cairo = 1.10.8
conky-imlib2 = 1.10.8
libcairo.so -
libcairo_imlib2_helper.so -
libimlib2.so -
librsvg.so -

Obsoletes

Name Value
conky-cairo < 1.10.8
conky-imlib2 < 1.10.8

Download

Type URL
Mirror widehat.opensuse.org
Binary Package conky-1.10.8-1.4.i586.rpm
Source Package conky-1.10.8-1.4.src.rpm

Install Howto

Install conky rpm package:

# zypper install conky

Files

Path
/etc/conky/conky.conf
/etc/conky/conky_no_x11.conf
/etc/conky/convert.lua
/usr/bin/conky
/usr/bin/conkyconf
/usr/lib/conky/libcairo.so
/usr/lib/conky/libcairo_imlib2_helper.so
/usr/lib/conky/libimlib2.so
/usr/lib/conky/librsvg.so
/usr/share/doc/packages/conky/AUTHORS
/usr/share/doc/packages/conky/COPYING
/usr/share/doc/packages/conky/ChangeLog
/usr/share/doc/packages/conky/NEWS
/usr/share/doc/packages/conky/README.SUSE
/usr/share/doc/packages/conky/README.md
/usr/share/doc/packages/conky/TODO
/usr/share/man/man1/conky.1.gz

Changelog

2018-03-05 - adam.majer@suse.de
- New upstream version 1.10.8
+ fixed segfault when HOME is unset
+ Fix segfault when kernel reports non-sequential SMP CPU indices
+ Provide support to query active port on PulseAudio's default sink
+ enable persistent view of irc messages
+ Fix SEGV in a CPU hotplug environment
+ GPLv3 is the default license
+ Support multiple include paths for libbircclient
- conky-1.10.4-ncurses.patch: comment out - doesn't seem to be needed
- conky-1.10.0-libircclient.patch: removed, upstreamed.
- conky.luamm.patch: removed, upstreamed.
- libical3.patch: adds support for libical 3.x
2018-03-03 - jengelh@inai.de
- Explicitly request old libical
2017-12-12 - pgajdos@suse.com
- fix build for SLE 15: buildrequire also Xdamage
- make more clear when xmms2 support is compiled in
- use pkgconfig()-style buildrequires for X libraries, package
is build for suse_version >= 1315, so they are defined
- fix 0%{is_opensuse} to 0%{?is_opensuse} on one placeand remove
is_opensuse definition, which is in my opinion useless afterwards
2017-12-10 - i@marguerite.su
- use modular Xorg libaries if possible
- make suse is_opensuse is defined
2017-11-29 - pgajdos@suse.com
- build with SLE 15
2017-11-15 - pgajdos@suse.com
- change default system configuration
- add /usr/bin/conkyconf
- add README.SUSE
- require fontawesome-fonts for icons
- fate: #323638
2017-07-27 - joerg.lorenzen@ki.tng.de
- BuildRequires libtolua++-5_1-devel on Leap.
2017-06-20 - olaf@aepfle.de
- Fix build with conky.luamm.patch
2017-03-21 - olaf@aepfle.de
- Remove more timestamps from binaries
2017-03-02 - olaf@aepfle.de
- Add buildconditional for audacious, cmus, libXNVCtrl, xmms2
- Remove unused BuildRequires, convert to pkgconfig()

See Also

Package Description
conky-doc-1.10.8-1.4.i586.rpm Documentation for conky
conky-doc-1.10.8-1.4.x86_64.rpm Documentation for conky
conman-0.3.0-1.2.i586.rpm The Console Manager
conman-0.3.0-1.2.x86_64.rpm The Console Manager
connman-1.35-3.4.i586.rpm Connection Manager
connman-1.35-3.4.x86_64.rpm Connection Manager
connman-client-1.35-3.4.i586.rpm Client script for connman (Connection Manager)
connman-client-1.35-3.4.x86_64.rpm Client script for connman (Connection Manager)
connman-devel-1.35-3.4.i586.rpm Development files for Connection Manager
connman-devel-1.35-3.4.x86_64.rpm Development files for Connection Manager
connman-doc-1.35-3.4.i586.rpm Connman reference man pages
connman-doc-1.35-3.4.x86_64.rpm Connman reference man pages
connman-nmcompat-1.35-3.4.i586.rpm NetworkManager compatibility for connman (Connection Manager)
connman-nmcompat-1.35-3.4.x86_64.rpm NetworkManager compatibility for connman (Connection Manager)
connman-plugin-hh2serial-gps-1.35-3.4.i586.rpm HH2Serial GPS plugin for connman (Connection Manager)
Advertisement
Advertisement