coccigrep-1.17+git.20180322-1.2.noarch.rpm


Advertisement

Description

coccigrep - Semantic grep tool for C, based on coccinelle

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename coccigrep-1.17+git.20180322-1.2.noarch.rpm
Package name coccigrep
Package version 1.17+git.20180322
Package release 1.2
Package architecture noarch
Package type rpm
Category Development/Libraries/C and C++
Homepage http://home.regit.org/software/coccigrep/
License GPL-3.0
Maintainer -
Download size 42.11 KB
Installed size 96.67 KB
coccigrep is a semantic grep for the C language based on coccinelle. It can be
used to find where a given structure is used in code files. coccigrep depends on
the spatch program which comes with coccinelle.

Alternatives

Package Version Architecture Repository
coccigrep - - -

Requires

Name Value
/usr/bin/python3 -
coccinelle -
python(abi) = 3.7
python3 -

Provides

Name Value
coccigrep = 1.17+git.20180322-1.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package coccigrep-1.17+git.20180322-1.2.noarch.rpm
Source Package coccigrep-1.17+git.20180322-1.2.src.rpm

Install Howto

Install coccigrep rpm package:

# zypper install coccigrep

Files

Path
/usr/bin/coccigrep
/usr/lib/python3.7/site-packages/coccigrep/__init__.py
/usr/lib/python3.7/site-packages/coccigrep/coccigrep.cfg
/usr/lib/python3.7/site-packages/coccigrep/coccigrep.py
/usr/lib/python3.7/site-packages/coccigrep-1.17-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/coccigrep-1.17-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/coccigrep-1.17-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/coccigrep-1.17-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/coccigrep-1.17-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/coccigrep/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/coccigrep/__pycache__/coccigrep.cpython-37.pyc
/usr/lib/python3.7/site-packages/coccigrep/data/deref.cocci
/usr/lib/python3.7/site-packages/coccigrep/data/func.cocci
/usr/lib/python3.7/site-packages/coccigrep/data/named.cocci
/usr/lib/python3.7/site-packages/coccigrep/data/set.cocci
/usr/lib/python3.7/site-packages/coccigrep/data/test.cocci
/usr/lib/python3.7/site-packages/coccigrep/data/used.cocci
/usr/share/doc/packages/coccigrep/ChangeLog
/usr/share/doc/packages/coccigrep/LICENSE
/usr/share/doc/packages/coccigrep/README.rst
/usr/share/man/man1/coccigrep.1.gz

Changelog

2018-06-18 - opensuse-packaging@opensuse.org
- Update to version 1.17+git.20180322:
* grep mode: fix multiline case
* fix typo in comment
* used: fix equality match
* allow multiple match on the same line
* fix grep mode display
* Update version to 1.17
* set only color in grep mode for tty
* color attribute in grep mode
* add grep mode for color
2016-10-31 - jslaby@suse.com
- package also LICENSE
2016-10-31 - jslaby@suse.com
- Update to version 20160815:
* forcing a type to be present was arbitrary
* vim plugin: fix interactive mode
* document void option usage in vim plugin
* Add python3 support
* Add support for python 3.4
* setup: use and complete install_requires
* Fix syntax error in python3 environment.
2015-01-15 - jslaby@suse.com
- update to 20150112
* python3 support added
- clean up .spec
* switch to python3
2014-09-15 - jslaby@suse.com
- update to latest snapshot (20140913)
* see ChangeLog for changes
2014-07-02 - jslaby@suse.com
- update to latest snapshot (20140217)
* see ChangeLog for changes
2013-08-17 - jslaby@suse.com
- update to latest snapshot (20130723)
* see ChangeLog for changes
2012-12-31 - jslaby@suse.com
- update to latest snapshot (20121222)
* see ChangeLog for changes
2012-09-12 - jslaby@suse.com
- update to latest snapshot (1347289051)
* see ChangeLog for changes
2012-08-21 - jslaby@suse.de
- initial package

See Also

Package Description
coccinelle-1.0.6-2.8.i586.rpm Semantic patch utility
coccinelle-1.0.6-2.8.x86_64.rpm Semantic patch utility
codec2-0.8.1-1.2.i586.rpm Low bit rate speech codec
codec2-0.8.1-1.2.x86_64.rpm Low bit rate speech codec
codec2-devel-0.8.1-1.2.i586.rpm Development library for codec2
codec2-devel-0.8.1-1.2.x86_64.rpm Development library for codec2
codec2-examples-0.8.1-1.2.noarch.rpm Example code for Codec 2
codelite-12.0-1.1.i586.rpm Code editor for C, C++, PHP and Node.js
codelite-12.0-1.1.x86_64.rpm Code editor for C, C++, PHP and Node.js
codespell-1.14.0-1.1.noarch.rpm Source code checker for common misspellings
cogl-devel-1.22.4+20190423.9bc253e9-1.1.i586.rpm Development files for the cogl GL/GLES abstraction/utility layer
cogl-devel-1.22.4+20190423.9bc253e9-1.1.x86_64.rpm Development files for the cogl GL/GLES abstraction/utility layer
cogl-lang-1.22.4+20190423.9bc253e9-1.1.noarch.rpm Translations for package cogl
collectd-5.7.2-5.3.i586.rpm Statistics Collection Daemon for filling RRD Files
collectd-5.7.2-5.3.x86_64.rpm Statistics Collection Daemon for filling RRD Files
Advertisement
Advertisement