cobbler-web-3.0+git20190222.9e502a9d-4.1.noarch.rpm


Advertisement

Description

cobbler-web - Web interface for Cobbler

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename cobbler-web-3.0+git20190222.9e502a9d-4.1.noarch.rpm
Package name cobbler-web
Package version 3.0+git20190222.9e502a9d
Package release 4.1
Package architecture noarch
Package type rpm
Category Productivity/Networking/Boot/Servers
Homepage https://cobbler.github.io/
License GPL-2.0-or-later
Maintainer -
Download size 157.16 KB
Installed size 1.29 MB
Web interface for Cobbler that allows visiting
http://server/cobbler_web to configure the install server.

Alternatives

Package Version Architecture Repository
cobbler-web - - -

Requires

Name Value
cobbler -
openssl -
python3-django -

Provides

Name Value
cobbler-web = 3.0+git20190222.9e502a9d-4.1
config(cobbler-web) = 3.0+git20190222.9e502a9d-4.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package cobbler-web-3.0+git20190222.9e502a9d-4.1.noarch.rpm
Source Package cobbler-3.0+git20190222.9e502a9d-4.1.src.rpm

Install Howto

Install cobbler-web rpm package:

# zypper install cobbler-web

Files

Path
/etc/apache2/conf.d/cobbler_web.conf
/srv/www/cobbler_webui_content/cobbler.js
/srv/www/cobbler_webui_content/favicon.png
/srv/www/cobbler_webui_content/index.html
/srv/www/cobbler_webui_content/jquery-ui.css
/srv/www/cobbler_webui_content/jquery-ui.min.js
/srv/www/cobbler_webui_content/jquery.min.js
/srv/www/cobbler_webui_content/jsGrowl.css
/srv/www/cobbler_webui_content/jsGrowl.js
/srv/www/cobbler_webui_content/jsGrowl_jquery.js
/srv/www/cobbler_webui_content/jsgrowl_close.png
/srv/www/cobbler_webui_content/jsgrowl_corners.png
/srv/www/cobbler_webui_content/jsgrowl_corners_hover.png
/srv/www/cobbler_webui_content/jsgrowl_middle_hover.png
/srv/www/cobbler_webui_content/jsgrowl_side_hover.png
/srv/www/cobbler_webui_content/logo-cobbler.png
/srv/www/cobbler_webui_content/style.css
/srv/www/cobbler_webui_content/tooltip.png
/srv/www/cobbler_webui_content/images/ui-bg_flat_0_aaaaaa_40x100.png
/srv/www/cobbler_webui_content/images/ui-bg_flat_75_ffffff_40x100.png
/srv/www/cobbler_webui_content/images/ui-bg_glass_55_fbf9ee_1x400.png
/srv/www/cobbler_webui_content/images/ui-bg_glass_65_ffffff_1x400.png
/srv/www/cobbler_webui_content/images/ui-bg_glass_75_dadada_1x400.png
/srv/www/cobbler_webui_content/images/ui-bg_glass_75_e6e6e6_1x400.png
/srv/www/cobbler_webui_content/images/ui-bg_glass_95_fef1ec_1x400.png
/srv/www/cobbler_webui_content/images/ui-bg_highlight-soft_75_cccccc_1x100.png
/srv/www/cobbler_webui_content/images/ui-icons_222222_256x240.png
/srv/www/cobbler_webui_content/images/ui-icons_2e83ff_256x240.png
/srv/www/cobbler_webui_content/images/ui-icons_454545_256x240.png
/srv/www/cobbler_webui_content/images/ui-icons_888888_256x240.png
/srv/www/cobbler_webui_content/images/ui-icons_cd0a0a_256x240.png
/usr/share/doc/packages/cobbler-web/AUTHORS
/usr/share/licenses/cobbler-web/COPYING

Changelog

2019-03-08 - Enno Gotthold <egotthold@suse.com>
- Added a patch which fixes an exception when login in with a non-root user.
- Added:
* fix-login-error.patch
2019-03-07 - jgonzalez@suse.com
- grub2-i386pc is not really required. Changed to recommended
to allow building for architectures other than x86_64
2019-03-07 - Jochen Breuer <jbreuer@suse.de>
- Adds SUSE Manager as a new SUSE distribution
- Added:
* adds_suse_manager_as_distro.diff
2019-03-01 - trenn@suse.de
- Checking bug fixes of released products are in latest develop pkg:
- remove fix-nameserver-search.fix; bug is invalid (bsc#1029276)
- > not needed anymore
- fix cobbler yaboot handling (bsc#968406, bsc#966622)
- > no yaboot support anymore
- support UEFI boot with cobbler generated tftp tree (bsc#1020376)
- > upstream
- Enabling PXE grub2 support for PowerPC (bsc#986978)
- > We have grub2 support for ppc64le
- (bsc#1048183) fix missing args and location for xen
- > is in
- no koan support anymore:
bsc#969541, bsc#924118, bsc#967523
- not installed (bsc#966841)
works.
- These still have to be looked at:
SUSE system as systemd only (bsc#952844)
handle list value for kernel options
correctly (bsc#973413)
entry in pxe menu (bsc#988889)
- This still has to be switched off (at least in internal cobbler versions):
Disabling 'get-loaders' command and 'check' fixed. bsc#973418
2019-02-28 - trenn@suse.de
- Add python3-requests and removed old python2 requires:
Requires:       python-PyYAML
Requires:       python-urlgrabber
(originally from jbreuer@suse.de)
- Add explicity require to tftp, so it is used for both SLE
and openSUSE (originally from jgonzalez@suse.com)
- Moved Recommends according to spec_cleaner
2019-02-25 - trenn@suse.de
- Require latest apache2-mod_wsgi-python3 package
This fixes interface to http://localhost/cblr/svc/...
- Use latest github cobbler/cobbler master branch in _service file
- cobblerd_needs_apache2_service_started.patch reverted, that is mainline
now:
D cobblerd_needs_apache2_service_started.patch
- Only recommend grub2-arm and grub2-ppc packages or we might not be
able to build on factory where arm/ppc might not be built
- Remove genders package requires. A genders file is generated, but
we do not need/use the genders package.
2019-02-19 - Ismail Dönmez <idonmez@suse.com>
- Cleanup with spec-cleaner
2019-02-14 - trenn@suse.de
- Update to latest cobbler version 3.0 mainline git HEAD version
and remove already integrated or not needed anymore patches:
D    cobbler-symlink.diff
D    detect-parallel-cobbler-sync.patch
D    escape-shell-parameters-provided-by-user-on-reposync.patch
D    fix_subprocess_sp_encoding.patch
D    fix-os-release.patch
D    disable_not_relevant_checks_bnc_828453.patch
D    update-outdated-apache-config-bsc956264.patch
D    cve-2018-10931-forbid-exposure-of-private-methods-in.patch
D    fix-broken-tests.diff
D    fix-manpage-creation.patch
D    do_not_use_grubby_compat_when_grub2_is_in_use.diff
D    fix_hardcoded_libpath_for_websession.patch
D    looking_for_cobbler_order_changed.diff
D    grubby-compat.diff
D    fix-restart-paravirt-xen.dif
D    koan_old_cobbler_compat.diff
D    fix_shebang.patch
D    catch_cheetah_exception.patch
D    fix-script-endpoint-security-bug-1030582.patch
D    cobbler_web_config.diff
D    fix-koan-port-guessing.dif
D    cobblerd_needs_apache2_service_started.patch
D    fix-powermanagement-status.dif
D    check-access-token-when-calling-modify_setting-api-e.patch
D    fix_sle_detection.patch
D    fix_test_create_systems.diff
D    fix_subprocess_sp_encoding.patch
D    cobbler-2.4.2-reprovision-rhel-on-suse-bnc883487.patch
2019-02-06 - trenn@suse.de
- Serial console support added, did some testing already
Things should start to work as expected
2019-01-29 - trenn@suse.de
- Add general grub2 support

See Also

Package Description
coccigrep-1.17+git.20180322-1.2.noarch.rpm Semantic grep tool for C, based on coccinelle
coccinelle-1.0.6-2.8.i586.rpm Semantic patch utility
coccinelle-1.0.6-2.8.x86_64.rpm Semantic patch utility
codec2-0.8.1-1.2.i586.rpm Low bit rate speech codec
codec2-0.8.1-1.2.x86_64.rpm Low bit rate speech codec
codec2-devel-0.8.1-1.2.i586.rpm Development library for codec2
codec2-devel-0.8.1-1.2.x86_64.rpm Development library for codec2
codec2-examples-0.8.1-1.2.noarch.rpm Example code for Codec 2
codelite-12.0-1.1.i586.rpm Code editor for C, C++, PHP and Node.js
codelite-12.0-1.1.x86_64.rpm Code editor for C, C++, PHP and Node.js
codespell-1.14.0-1.1.noarch.rpm Source code checker for common misspellings
cogl-devel-1.22.4+20190423.9bc253e9-1.1.i586.rpm Development files for the cogl GL/GLES abstraction/utility layer
cogl-devel-1.22.4+20190423.9bc253e9-1.1.x86_64.rpm Development files for the cogl GL/GLES abstraction/utility layer
cogl-lang-1.22.4+20190423.9bc253e9-1.1.noarch.rpm Translations for package cogl
collectd-5.7.2-5.3.i586.rpm Statistics Collection Daemon for filling RRD Files
Advertisement
Advertisement