cni-0.6.0-5.2.i586.rpm


Advertisement

Description

cni - Container Network Interface - networking for Linux containers

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename cni-0.6.0-5.2.i586.rpm
Package name cni
Package version 0.6.0
Package release 5.2
Package architecture i586
Package type rpm
Category System/Management
Homepage https://github.com/containernetworking/cni
License Apache-2.0
Maintainer -
Download size 1.90 MB
Installed size 4.76 MB
The CNI (Container Network Interface) project consists of a
specification and libraries for writing plugins to configure
network interfaces in Linux containers, along with a number of
supported plugins. CNI concerns itself only with network
connectivity of containers and removing allocated resources when
the container is deleted. Because of this focus, CNI has a wide
range of support and the specification is simple to implement.

Alternatives

Package Version Architecture Repository
cni-0.6.0-5.2.x86_64.rpm 0.6.0 x86_64 openSUSE Oss
cni - - -

Requires

Name Value
coreutils -
diffutils -
fillup -
grep -
libc.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.3.2) -
systemd -

Provides

Name Value
cni = 0.6.0-5.2
cni(x86-32) = 0.6.0-5.2
config(cni) = 0.6.0-5.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package cni-0.6.0-5.2.i586.rpm
Source Package cni-0.6.0-5.2.src.rpm

Install Howto

Install cni rpm package:

# zypper install cni

Files

Path
/etc/cni/
/etc/cni/net.d/99-loopback.conf.sample
/usr/lib/cni/noop
/usr/sbin/cnitool
/usr/share/doc/packages/cni/CONTRIBUTING.md
/usr/share/doc/packages/cni/DCO
/usr/share/doc/packages/cni/README.md
/usr/share/licenses/cni/LICENSE

Changelog

2018-06-05 - dcassany@suse.com
- Refactor %license usage to a simpler form
2018-06-04 - dcassany@suse.com
- Make use of %license macro
2018-04-04 - jmassaguerpla@suse.com
- Remove creating subvolumes. This should be in another package (kubernetes-kubelet)
2018-01-29 - kmacinnes@suse.com
- Use full/absolute path for mksubvolume
- Change snapper Requires to a Requires(post)
2018-01-18 - kmacinnes@suse.com
- Add snapper as a requirement, to provide mksubvolume
2018-01-15 - alvaro.saurin@suse.com
- Make /var/lib/cni writable
2017-12-19 - alvaro.saurin@suse.com
- Remove the dependency with the cni-plugins
- Recommend the cni-plugins
2017-08-28 - opensuse-packaging@opensuse.org
- Update to version 0.6.0:
* Conventions: add convention around chaining interfaces
* pkg/types: safer typecasting for TextUnmarshaler when loading args
* pkg/types: modify LoadArgs to return a named error when an unmarshalable condition is detected
* Update note about next Community Sync, 2017-06-21
* types: fix marshalling of omitted "interfaces" key in IPConfig JSON
* Update and document release process
* scripts/release.sh: Add in s390x architecture
* cnitool: add support for CNI_ARGS
* README plugins list: add Linen CNI plugin
2017-04-10 - opensuse-packaging@opensuse.org
- Update to version 0.5.2:
* Rename build script to avoid conflict with bazel
* Enable s390x build
* Update community sync detail
* Added entry for CNI-Genie
* travis: shift forward to Go 1.8 and 1.7
* spec/plugins: fix 'ip'->'ips' in the spec, bump to 0.3.1
* libcni: Improved error messages.
* libcni: Fixed tests that were checking error strings.
* Documentation: Added documentation for `cnitool`.
2017-03-23 - opensuse-packaging@opensuse.org
- Update to version 0.5.1:
* readme.md: Add link to community sync
* pkg/ip: do not leak types from vendored netlink package
* pkg/ip: SetupVeth returns net.Interface
* pkg/ip: improve docstring for SetupVeth
* Added Romana to list of CNI providers...
* plugins/meta/flannel: If net config is missing do not return err on DEL
* plugins/*: Don't error if the device doesn't exist

See Also

Package Description
cni-plugins-0.7.4-1.1.i586.rpm Container Network Interface plugins
cni-plugins-0.7.4-1.1.x86_64.rpm Container Network Interface plugins
cntlm-0.92.3-9.4.i586.rpm Fast NTLM authentication proxy with tunneling
cntlm-0.92.3-9.4.x86_64.rpm Fast NTLM authentication proxy with tunneling
cobbler-3.0+git20190222.9e502a9d-4.1.noarch.rpm Boot server configurator
cobbler-web-3.0+git20190222.9e502a9d-4.1.noarch.rpm Web interface for Cobbler
coccigrep-1.17+git.20180322-1.2.noarch.rpm Semantic grep tool for C, based on coccinelle
coccinelle-1.0.6-2.8.i586.rpm Semantic patch utility
coccinelle-1.0.6-2.8.x86_64.rpm Semantic patch utility
codec2-0.8.1-1.2.i586.rpm Low bit rate speech codec
codec2-0.8.1-1.2.x86_64.rpm Low bit rate speech codec
codec2-devel-0.8.1-1.2.i586.rpm Development library for codec2
codec2-devel-0.8.1-1.2.x86_64.rpm Development library for codec2
codec2-examples-0.8.1-1.2.noarch.rpm Example code for Codec 2
codelite-12.0-1.1.i586.rpm Code editor for C, C++, PHP and Node.js
Advertisement
Advertisement