cmpi-bindings-ruby-1.0.2-2.4.x86_64.rpm


Advertisement

Description

cmpi-bindings-ruby - Adapter to write and run CMPI-type CIM providers in Ruby

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename cmpi-bindings-ruby-1.0.2-2.4.x86_64.rpm
Package name cmpi-bindings-ruby
Package version 1.0.2
Package release 2.4
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage http://github.com/kkaempf/cmpi-bindings
License BSD-3-Clause AND CPL-1.0
Maintainer -
Download size 71.06 KB
Installed size 231.03 KB
Adapter to write and run CMPI-type CIM providers in Ruby

Alternatives

Package Version Architecture Repository
cmpi-bindings-ruby-1.0.2-2.4.i586.rpm 1.0.2 i586 openSUSE Oss
cmpi-bindings-ruby - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libruby2.6.so.2.6()(64bit) -

Provides

Name Value
cmpi-bindings = 1.0.2-2.4
cmpi-bindings-ruby = 1.0.2-2.4
cmpi-bindings-ruby(x86-64) = 1.0.2-2.4
librbCmpiProvider.so()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package cmpi-bindings-ruby-1.0.2-2.4.x86_64.rpm
Source Package cmpi-bindings-1.0.2-2.4.src.rpm

Install Howto

Install cmpi-bindings-ruby rpm package:

# zypper install cmpi-bindings-ruby

Files

Path
/usr/lib64/cmpi/librbCmpiProvider.so
/usr/lib64/ruby/vendor_ruby/2.6.0/cmpi.rb
/usr/lib64/ruby/vendor_ruby/2.6.0/cmpi/provider.rb
/usr/lib64/ruby/vendor_ruby/2.6.0/cmpi/providers/

Changelog

2018-08-08 - jengelh@inai.de
- Replace old $RPM_* shell vars by macros.
2018-05-29 - kkaempf@suse.com
- Update to 1.0.2
- disable ruby documentation for Ruby 2.5.0
(rdoc-6.0.1 breaks swig documentation hack)
2015-01-29 - kkaempf@suse.com
- Update to 1.0.1
- fix comment characters in .i files for swig 3.0.4
(dimstar@opensuse.org)
this includes cmpi-bindings-swig-3.0.patch
- improve documentation coverage
2015-01-26 - dimstar@opensuse.org
- Add cmpi-bindings-swig-3.0.patch: Fix build with SWIG 3.0.
2014-06-25 - kkaempf@suse.com
- Update to 1.0.0
- Transport CMPIStatus information from Ruby to CMPI API.
- Add Ruby classes representing CMPI error codes.
- Capture call results and raise proper exceptions.
- Fix Fedora 20 build
2014-02-05 - kkaempf@suse.com
- Update to 0.9.9
- Support rdoc from Ruby 2.1
2013-12-12 - kkaempf@suse.com
- Update to 0.9.8
- Create Ruby documentation
- Split off package cmpi-bindings-ruby-docs
- Fix Fedora 19 build
2013-10-09 - kkaempf@suse.com
- Update to 0.9.7
Catch and log Ruby exceptions caused by invoke method type
conversions.
2013-10-09 - kkaempf@suse.com
- Update to 0.9.6
Return correct status for failed method invocation in Ruby.
2013-09-26 - kkaempf@suse.com
- Drop explicit ruby(abi) requires (bnc#842433)

See Also

Package Description
cmpi-provider-register-1.1.0-2.2.noarch.rpm CIMOM neutral provider registration utility
cmpi-pywbem-base-0.2.0-25.5.noarch.rpm Base System Providers
cmpi-pywbem-power-management-0.2.0-24.5.noarch.rpm Power Management Providers
cmrt-devel-1.0.6-1.4.i586.rpm Development files for the C for Media Runtime
cmrt-devel-1.0.6-1.4.x86_64.rpm Development files for the C for Media Runtime
cmuclmtk-0.7-11.3.i586.rpm CMU-Cambridge Statistical Language Modeling toolkit
cmuclmtk-0.7-11.3.x86_64.rpm CMU-Cambridge Statistical Language Modeling toolkit
cmus-2.8.0~20190219.ge27e813-1.1.i586.rpm Text-mode music player
cmus-2.8.0~20190219.ge27e813-1.1.x86_64.rpm Text-mode music player
cmus-plugin-cdio-2.8.0~20190219.ge27e813-1.1.i586.rpm CDIO plugin for the C* Music Player
cmus-plugin-cdio-2.8.0~20190219.ge27e813-1.1.x86_64.rpm CDIO plugin for the C* Music Player
cmus-plugin-cue-2.8.0~20190219.ge27e813-1.1.i586.rpm CUE input plugin for the C* Music Player
cmus-plugin-cue-2.8.0~20190219.ge27e813-1.1.x86_64.rpm CUE input plugin for the C* Music Player
cmus-plugin-ffmpeg-2.8.0~20190219.ge27e813-1.1.i586.rpm FFmpeg input plugin for the C* Music Player
cmus-plugin-ffmpeg-2.8.0~20190219.ge27e813-1.1.x86_64.rpm FFmpeg input plugin for the C* Music Player
Advertisement
Advertisement