bookworm-1.1.1-1.2.i586.rpm


Advertisement

Description

bookworm - E-book reader

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename bookworm-1.1.1-1.2.i586.rpm
Package name bookworm
Package version 1.1.1
Package release 1.2
Package architecture i586
Package type rpm
Category Productivity/Office/Other
Homepage https://babluboy.github.io/bookworm
License GPL-3.0-or-later
Maintainer -
Download size 1.42 MB
Installed size 3.45 MB
An eBook reader for Elementary OS.
It uses poppler for decoding and read formats like EPUB, PDF, mobi, cbr, etc.

Alternatives

Package Version Architecture Repository
bookworm-1.1.1-1.2.x86_64.rpm 1.1.1 x86_64 openSUSE Oss
bookworm - - -

Requires

Name Value
/bin/bash -
/usr/bin/python2 -
html2text -
libc.so.6(GLIBC_2.4) -
libgdk-3.so.0 -
libgdk_pixbuf-2.0.so.0 -
libgee-0.8.so.2 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgranite.so.5 -
libgtk-3.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.1) -
libpango-1.0.so.0 -
libpoppler-glib.so.8 -
libsoup-2.4.so.1 -
libsqlite3.so.0 -
libwebkit2gtk-4.0.so.37 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
poppler-tools -

Provides

Name Value
application() -
application(com.github.babluboy.bookworm.desktop) -
bookworm = 1.1.1-1.2
bookworm(x86-32) = 1.1.1-1.2
metainfo() -
metainfo(com.github.babluboy.bookworm.appdata.xml) -
mimehandler(application/cbr) -
mimehandler(application/epub+zip) -
mimehandler(application/pdf) -
mimehandler(application/x-cbz) -
mimehandler(application/x-pdf) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package bookworm-1.1.1-1.2.i586.rpm
Source Package bookworm-1.1.1-1.2.src.rpm

Install Howto

Install bookworm rpm package:

# zypper install bookworm

Files

Path
/usr/bin/com.github.babluboy.bookworm
/usr/share/applications/com.github.babluboy.bookworm.desktop
/usr/share/bookworm/
/usr/share/bookworm/scripts/
/usr/share/bookworm/scripts/mobi_lib/mobi_dict.py
/usr/share/bookworm/scripts/mobi_lib/mobi_html.py
/usr/share/bookworm/scripts/mobi_lib/mobi_index.py
/usr/share/bookworm/scripts/mobi_lib/mobi_k8proc.py
/usr/share/bookworm/scripts/mobi_lib/mobi_ncx.py
/usr/share/bookworm/scripts/mobi_lib/mobi_opf.py
/usr/share/bookworm/scripts/mobi_lib/mobi_split.py
/usr/share/bookworm/scripts/mobi_lib/mobi_uncompress.py
/usr/share/bookworm/scripts/mobi_lib/mobi_unpack.py
/usr/share/bookworm/scripts/mobi_lib/mobi_utils.py
/usr/share/bookworm/scripts/tasks/com.github.babluboy.bookworm.search.sh
/usr/share/contractor/com.github.babluboy.bookworm.contract
/usr/share/doc/packages/bookworm/AUTHORS
/usr/share/doc/packages/bookworm/README.md
/usr/share/glib-2.0/schemas/com.github.babluboy.bookworm.gschema.xml
/usr/share/icons/hicolor/128x128/apps/com.github.babluboy.bookworm.svg
/usr/share/icons/hicolor/16x16/apps/com.github.babluboy.bookworm.svg
/usr/share/icons/hicolor/24x24/apps/com.github.babluboy.bookworm.svg
/usr/share/icons/hicolor/32x32/apps/com.github.babluboy.bookworm.svg
/usr/share/icons/hicolor/48x48/apps/com.github.babluboy.bookworm.svg
/usr/share/icons/hicolor/64x64/apps/com.github.babluboy.bookworm.svg
/usr/share/licenses/bookworm/LICENSE
/usr/share/metainfo/com.github.babluboy.bookworm.appdata.xml

Changelog

2018-10-16 - Alexei Podvalsky <avvissu@yandex.by>
- Update to 1.1.1:
* Updated version for libwebkit2gtk-4.0
2018-10-08 - Alexei Podvalsky <avvissu@yandex.by>
- Update to 1.1.0:
* Updated for Appcenter Juno release
* Fixed CSS causing overlapping text (Issue #210)
* Updated CSS to work for both Loki and Juno
* Removed stateful from SimpleAction on context menu (Issue
[#203])
* Added functionality for dictionary word lookup (Issue #185)
* Fix to prevent external links to be loaded on Bookworm (Issue
[#180])
* Changes to add icons/files to GResource (Issue #81)
* Added html2text to ReadMe for build instructions
* Merge pull request #204 from fabianfreyer/master
* Install scripts with group permissions
* Changes to add highlight colour to prefferences menu (Issue
[#202])
* Merge branch 'origin/master' into Weblate
* Update desktop entry to use standardised Keywords key.
* Fix spelling of 'successfully'.
- Remove obsolete macros
- Spec file cleanup
2018-02-16 - avvissu@yandex.by
- Update to 1.0.0:
* Updated snapcraft.yaml to fix DBUS issue
* Updated snapcraft to old data
* Update snapcraft.yaml
* Updated snapcraft for granite0.5
* changing icon path to data directory
* Added snapcraft badge
* Updated snapcraft for snap release
* Fixes for loading a book from right click in Files
* Fixed the issue of cover image being stretched (Issue #19)
* Adjusted scrollbar on the reading view to expand for easier
mouse grabing (Issue #175)
* Merge branch 'loki' of https://github.com/babluboy/bookworm
* Fix for table of contents not using anchors correctly (Isse
[#154])
* Added branding color (Issue #174)
* Used libxml for xml parsing for ePubs (Issue #169)
* Update README.md
* Added Paypal Badge
* Typo: ?comma seperated? ? comma-separated
* Fixed xml parsing issue for ToC with namespace (Issue #160)
* Updating travis to have trusty as the distribution
* Fixed the issue of long titles not wrapping on the default
cover (Issue #167)
* Moved default covers out of 256x256 folder
* Merge branch 'master' of https://github.com/babluboy/bookworm
2017-12-24 - avvissu@yandex.by
- Update to 0.9.9:
* Updated binary in appdata.xml to the RDNN executable name
* Replaced icon files with RDNN (#157)
* Updated RDNN executable change in contract and desktop files
* Fixed RDNN issues for desktop icon (#158)
* Renamed binary to match RDNN (#157)
* Fixed an issue of bookworm hanging if the watched folder is
not set
* Fixed the issue of covers getting different numbers when
moving from 0.9.2 to 0.9.5
* Improvements for Search and Annotation Highlighting
* Replaced nb.po with nb_NO.po and removed no.po
* Altered the design to discover books (Issue #104)
2017-12-19 - jengelh@inai.de
- Use improved find call execution.
- Ensure neutrality of description.
2017-12-04 - avvissu@yandex.by
- Add macros: icon_theme_cache_post{un}, desktop_database_post{un},
glib2_gsettings_schema_post{un}
2017-11-08 - avvissu@yandex.by
- Initial package

See Also

Package Description
bookworm-lang-1.1.1-1.2.noarch.rpm Translations for package bookworm
boomaga-1.3.0-1.4.i586.rpm Virtual Printer for Viewing a Document before Printing
boomaga-1.3.0-1.4.x86_64.rpm Virtual Printer for Viewing a Document before Printing
boomaga-lang-1.3.0-1.4.noarch.rpm Translations for package boomaga
boost-devel-1.69.0-1.1.noarch.rpm Development headers for Boost
boost-gnu-hpc-1.69.0-1.3.noarch.rpm Dependency package for boost_1_69_0-gnu-hpc
boost-gnu-hpc-devel-1.69.0-1.3.noarch.rpm Dependency package for boost_1_69_0-gnu-hpc-devel
boost-gnu-mvapich2-hpc-1.69.0-1.1.noarch.rpm Dependency package for boost_1_69_0-gnu-mvapich2-hpc
boost-gnu-mvapich2-hpc-devel-1.69.0-1.1.noarch.rpm Dependency package for boost_1_69_0-gnu-mvapich2-hpc-devel
boost-gnu-mvapich2-hpc-python2-1.69.0-1.1.noarch.rpm Dependency package for boost_1_69_0-gnu-mvapich2-hpc-python2
boost-gnu-mvapich2-hpc-python3-1.69.0-1.1.noarch.rpm Dependency package for boost_1_69_0-gnu-mvapich2-hpc-python3
boost-gnu-openmpi2-hpc-1.69.0-1.1.noarch.rpm Dependency package for boost_1_69_0-gnu-openmpi2-hpc
boost-gnu-openmpi2-hpc-devel-1.69.0-1.1.noarch.rpm Dependency package for boost_1_69_0-gnu-openmpi2-hpc-devel
boost-gnu-openmpi2-hpc-python2-1.69.0-1.1.noarch.rpm Dependency package for boost_1_69_0-gnu-openmpi2-hpc-python2
boost-gnu-openmpi2-hpc-python3-1.69.0-1.1.noarch.rpm Dependency package for boost_1_69_0-gnu-openmpi2-hpc-python3
Advertisement
Advertisement