bogofilter-sqlite3-1.2.4-13.1.x86_64.rpm


Advertisement

Description

bogofilter-sqlite3 - Bogofilter sqlite3 backend

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename bogofilter-sqlite3-1.2.4-13.1.x86_64.rpm
Package name bogofilter-sqlite3
Package version 1.2.4
Package release 13.1
Package architecture x86_64
Package type rpm
Category Productivity/Networking/Email/Utilities
Homepage http://bogofilter.sourceforge.net/
License GPL-2.0+
Maintainer -
Download size 151.14 KB
Installed size 621.39 KB
This package contains bogofilter build with the sqlite3 backend.

Alternatives

Package Version Architecture Repository
bogofilter-sqlite3-1.2.4-13.1.i586.rpm 1.2.4 i586 openSUSE Oss
bogofilter-sqlite3 - - -

Requires

Name Value
bogofilter-common = 1.2.4
libc.so.6(GLIBC_2.14)(64bit) -
libgsl.so.23()(64bit) -
libgslcblas.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.29)(64bit) -
libsqlite3.so.0()(64bit) -
update-alternatives -

Provides

Name Value
bogofilter-backend = 1.2.4-13.1
bogofilter-sqlite3 = 1.2.4-13.1
bogofilter-sqlite3(x86-64) = 1.2.4-13.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package bogofilter-sqlite3-1.2.4-13.1.x86_64.rpm
Source Package bogofilter-1.2.4-13.1.src.rpm

Install Howto

Install bogofilter-sqlite3 rpm package:

# zypper install bogofilter-sqlite3

Files

Path
/etc/alternatives/bf_compact
/etc/alternatives/bf_compact.1.gz
/etc/alternatives/bf_copy
/etc/alternatives/bf_copy.1.gz
/etc/alternatives/bf_tar
/etc/alternatives/bf_tar.1.gz
/etc/alternatives/bogofilter
/etc/alternatives/bogofilter.1.gz
/etc/alternatives/bogolexer
/etc/alternatives/bogolexer.1.gz
/etc/alternatives/bogotune
/etc/alternatives/bogotune.1.gz
/etc/alternatives/bogoutil
/etc/alternatives/bogoutil.1.gz
/usr/bin/bf_compact
/usr/bin/bf_compact-sqlite3
/usr/bin/bf_copy
/usr/bin/bf_copy-sqlite3
/usr/bin/bf_tar
/usr/bin/bf_tar-sqlite3
/usr/bin/bogofilter
/usr/bin/bogofilter-sqlite3
/usr/bin/bogolexer
/usr/bin/bogolexer-sqlite3
/usr/bin/bogotune
/usr/bin/bogotune-sqlite3
/usr/bin/bogoutil
/usr/bin/bogoutil-sqlite3
/usr/share/man/man1/bf_compact-sqlite3.1.gz
/usr/share/man/man1/bf_copy-sqlite3.1.gz
/usr/share/man/man1/bf_tar-sqlite3.1.gz
/usr/share/man/man1/bogofilter-sqlite3.1.gz
/usr/share/man/man1/bogolexer-sqlite3.1.gz
/usr/share/man/man1/bogotune-sqlite3.1.gz
/usr/share/man/man1/bogoutil-sqlite3.1.gz

Changelog

2019-03-13 - olaf@aepfle.de
- The previous change added strict versioned Requires from and to a
noarch subpkg. The release part can not be used in this case
because the noarch packages will most likely be shared across
architectures, and different architectures may have different
release numbers.
Relax the Requires again
2019-03-06 - olaf@aepfle.de
- Swallow old bogofilter pkgs in the db subpkg (bsc#1128219)
fix change from April 2015
- Require subpkgs from the very same build
2017-04-10 - mpluskal@suse.com
- Small spec file cleanup
- Adjust usage of update-alternatives
2017-02-09 - dimstar@opensuse.org
- Explicitly package _docdir, fix build with rpm 4.13.
2015-12-23 - p.drouand@gmail.com
- Replace tokyocabinet with kyotocabinet following kyotocabinet
upstream recommendations
* Replace libtokyocabinet-devel with libkyotocabinet-devel
* Add bogofilter-kyotocabinet.patch
* Rename tokyocabinet with kyotocabinet
- Add autoconf and automake build dependencies; needed because of
bogofilter-kyotocabinet.patch
2015-05-06 - lmuelle@suse.com
- Add README.SUSE to the doc package.
2015-04-30 - lmuelle@suse.com
- Provide and obsolete bogofilter from the db subpackage to ensure we stay
with the same back-end in the update case.
- Require a backend package from the common package.
- Split of the documentation into an independent package.
- Tag the common and doc package as noarch post-11.1.
2015-04-18 - mpluskal@suse.com
- Build different backends
* sqlite3 db and tokyocabinet
* switch between them using update-alternatives
- Disable checks as they do not work with suffixed builds
2015-04-05 - mpluskal@suse.com
- Update dependencies
* use shared gsl
- Cleanup spec-file with spec-cleaner
- Change backend from libdb to sqlite3 for post-13.2 systems
2013-07-23 - lmuelle@suse.com
- Update to version 1.2.4.
* Fix three crashes in command line and environment variable parsers
that caused NULL pointer dereferences with long option variants
of bogofilter --syslog-tag, or bogoutil --timestamp-date, or when
bogotune -M<file> cannot derive the bogofilter directory.
* Add getopt_long_chk(), a getopt_long variant that checks if the
overlapping short and long options agree on whether their argument
is not required, mandatory, or optional.  If they disagree, the
program aborts.
* Fix a crash in command line parser that causes a NULL pointer
dereference when --db-cachesize is used without argument.
Found with getopt_long_chk().
* Change lexer API/ABI a bit so as to work with flex 2.5.36 generated
lexers (for instance, on Fedora 18 "Spherical Cow") that flip the
type of yyleng from int to size_t. We use a signed long internally.
* Fix XML form of Bulgarian FAQ so that it validates;
and validate XHTML at build time.
* Mark Berkeley DB 5.2.42 and 5.3.21 supported.

See Also

Package Description
boinc-client-7.14.2-1.2.i586.rpm The BOINC client
boinc-client-7.14.2-1.2.x86_64.rpm The BOINC client
boinc-client-lang-7.14.2-1.2.noarch.rpm Translations for package boinc-client
boinc-manager-7.14.2-1.2.i586.rpm GUI to control and monitor boinc-client
boinc-manager-7.14.2-1.2.x86_64.rpm GUI to control and monitor boinc-client
boinc-manager-lang-7.14.2-1.2.noarch.rpm Translations for package boinc-client
bolt-0.7-2.1.i586.rpm Thunderbolt 3 device manager
bolt-0.7-2.1.x86_64.rpm Thunderbolt 3 device manager
bolt-tools-0.7-2.1.i586.rpm Bolt Tools
bolt-tools-0.7-2.1.x86_64.rpm Bolt Tools
bomber-19.04.0-1.1.i586.rpm Game involving the invasion of cities with a plane
bomber-19.04.0-1.1.x86_64.rpm Game involving the invasion of cities with a plane
bomber-lang-19.04.0-1.1.noarch.rpm Translations for package bomber
bomns-0.99.3-1.12.i586.rpm Best old-school Deathmatch game ever (only for two players)
bomns-0.99.3-1.12.x86_64.rpm Best old-school Deathmatch game ever (only for two players)
Advertisement
Advertisement